summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-06-26 01:39:28 +0000
committerMike Frysinger <vapier@gentoo.org>2015-06-26 01:39:28 +0000
commita53fcdd3905e6c99a8ca4684138fc3fef42ea0fe (patch)
treec2a73e0aced3c372e131160263002366db031f7a /www-apache
parentUpdate HOMEPAGE. (diff)
downloadgentoo-2-a53fcdd3905e6c99a8ca4684138fc3fef42ea0fe.tar.gz
gentoo-2-a53fcdd3905e6c99a8ca4684138fc3fef42ea0fe.tar.bz2
gentoo-2-a53fcdd3905e6c99a8ca4684138fc3fef42ea0fe.zip
Version bump. Allow mpm_prefork as upstream has tested it now.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/ChangeLog8
-rw-r--r--www-apache/mod_h2/mod_h2-0.7.3.ebuild47
-rw-r--r--www-apache/mod_h2/mod_h2-9999.ebuild12
3 files changed, 55 insertions, 12 deletions
diff --git a/www-apache/mod_h2/ChangeLog b/www-apache/mod_h2/ChangeLog
index 693fec9627ee..86c437a91674 100644
--- a/www-apache/mod_h2/ChangeLog
+++ b/www-apache/mod_h2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_h2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/ChangeLog,v 1.9 2015/06/22 13:23:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/ChangeLog,v 1.10 2015/06/26 01:39:28 vapier Exp $
+
+*mod_h2-0.7.3 (26 Jun 2015)
+
+ 26 Jun 2015; Mike Frysinger <vapier@gentoo.org> +mod_h2-0.7.3.ebuild,
+ mod_h2-9999.ebuild:
+ Version bump. Allow mpm_prefork as upstream has tested it now.
*mod_h2-0.7.2 (22 Jun 2015)
diff --git a/www-apache/mod_h2/mod_h2-0.7.3.ebuild b/www-apache/mod_h2/mod_h2-0.7.3.ebuild
new file mode 100644
index 000000000000..ed97db15d230
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-0.7.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/mod_h2-0.7.3.ebuild,v 1.1 2015/06/26 01:39:28 vapier Exp $
+
+EAPI="5"
+
+inherit apache-module
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ ssl? ( www-servers/apache[alpn] )"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_configure() {
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --disable-werror \
+ --disable-sandbox
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_h2.conf" "75_mod_h2.conf"
+}
diff --git a/www-apache/mod_h2/mod_h2-9999.ebuild b/www-apache/mod_h2/mod_h2-9999.ebuild
index 7e561c4e349e..8fa8c6685784 100644
--- a/www-apache/mod_h2/mod_h2-9999.ebuild
+++ b/www-apache/mod_h2/mod_h2-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/mod_h2-9999.ebuild,v 1.4 2015/06/17 17:49:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_h2/mod_h2-9999.ebuild,v 1.5 2015/06/26 01:39:28 vapier Exp $
EAPI="5"
@@ -25,16 +25,6 @@ RDEPEND=">=net-libs/nghttp2-1.0
ssl? ( www-servers/apache[alpn] )"
DEPEND="${RDEPEND}"
-# The mpm_prefork module doesn't work right. See upstream docs.
-# The threads logic is to handle the default eclass behavior which selects a
-# default mpm via the USE=threads flag.
-RDEPEND+="
- || (
- www-servers/apache[apache2_mpms_worker]
- www-servers/apache[apache2_mpms_event]
- www-servers/apache[threads,-apache2_mpms_prefork,-apache2_mpms_peruser]
- )"
-
need_apache2_4
src_configure() {