summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-17 23:48:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-17 23:48:15 +0000
commitbe08bf08e392bdfd7c4fdb2475517ede5480fb5f (patch)
tree2ead0a33b28f47d02debf7babc56d006e82e8504 /www-apache
parentstable sparc, bug 274738 (diff)
downloadgentoo-2-be08bf08e392bdfd7c4fdb2475517ede5480fb5f.tar.gz
gentoo-2-be08bf08e392bdfd7c4fdb2475517ede5480fb5f.tar.bz2
gentoo-2-be08bf08e392bdfd7c4fdb2475517ede5480fb5f.zip
Version bump. Fix building with GCC 4.4 (bug #278154).
(Portage version: 13833-svn/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/anyterm/ChangeLog11
-rw-r--r--www-apache/anyterm/anyterm-1.1.29.ebuild45
-rw-r--r--www-apache/anyterm/files/50_anyterm.conf5
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.15-browser-gentoo.patch75
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.15-postinst-en.txt59
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch64
-rw-r--r--www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch10
7 files changed, 65 insertions, 204 deletions
diff --git a/www-apache/anyterm/ChangeLog b/www-apache/anyterm/ChangeLog
index c0b0879b886f..d3bc453116be 100644
--- a/www-apache/anyterm/ChangeLog
+++ b/www-apache/anyterm/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-apache/anyterm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.19 2009/05/31 20:59:45 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/ChangeLog,v 1.20 2009/07/17 23:48:15 arfrever Exp $
+
+*anyterm-1.1.29 (17 Jul 2009)
+
+ 17 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -files/50_anyterm.conf, -files/anyterm-1.1.15-browser-gentoo.patch,
+ -files/anyterm-1.1.15-postinst-en.txt,
+ -files/anyterm-1.1.22-respect-flags.patch, +anyterm-1.1.29.ebuild,
+ +files/anyterm-1.1.29-gcc-4.4.patch:
+ Version bump. Fix building with GCC 4.4 (bug #278154).
31 May 2009; Markus Meier <maekke@gentoo.org> anyterm-1.1.28.ebuild:
add ~amd64, bug #265763
diff --git a/www-apache/anyterm/anyterm-1.1.29.ebuild b/www-apache/anyterm/anyterm-1.1.29.ebuild
new file mode 100644
index 000000000000..a06183fb8461
--- /dev/null
+++ b/www-apache/anyterm/anyterm-1.1.29.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/anyterm/anyterm-1.1.29.ebuild,v 1.1 2009/07/17 23:48:15 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A terminal anywhere."
+HOMEPAGE="http://anyterm.org/"
+SRC_URI="http://anyterm.org/download/${P}.tbz2"
+
+LICENSE="GPL-2 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.34.1
+ virtual/ssh"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.1.28-respect-LDFLAGS.patch"
+ epatch "${FILESDIR}/${P}-gcc-4.4.patch"
+}
+
+src_compile() {
+ # this package uses `ld -r -b binary` and thus resulting executalbe contains
+ # executable stack
+ append-ldflags -Wl,-z,noexecstack
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die
+}
+
+src_install() {
+ dosbin anytermd || die
+ dodoc CHANGELOG README || die
+ doman anytermd.1 || die
+ newinitd "${FILESDIR}/anyterm.init.d" anyterm || die
+ newconfd "${FILESDIR}/anyterm.conf.d" anyterm || die
+}
+
+pkg_postinst() {
+ elog "To proceed installation, read following:"
+ elog "http://anyterm.org/1.1/install.html"
+}
diff --git a/www-apache/anyterm/files/50_anyterm.conf b/www-apache/anyterm/files/50_anyterm.conf
deleted file mode 100644
index 3a36d8362862..000000000000
--- a/www-apache/anyterm/files/50_anyterm.conf
+++ /dev/null
@@ -1,5 +0,0 @@
-<IfDefine ANYTERM>
-LoadModule anyterm modules/anyterm.so
-</IfDefine>
-
-# vim: ts=4 filetype=apache
diff --git a/www-apache/anyterm/files/anyterm-1.1.15-browser-gentoo.patch b/www-apache/anyterm/files/anyterm-1.1.15-browser-gentoo.patch
deleted file mode 100644
index 0b06a5121a30..000000000000
--- a/www-apache/anyterm/files/anyterm-1.1.15-browser-gentoo.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-Index: anyterm-1.1.15/browser/anyterm.js
-===================================================================
---- anyterm-1.1.15.orig/browser/anyterm.js
-+++ anyterm-1.1.15/browser/anyterm.js
-@@ -24,16 +24,21 @@ var term;
- var open=false;
- var session;
-
--var method="POST";
--//var method="GET";
-+#USE=opera#//var method="POST";
-+#USE=opera#var method="GET";
-+#USE=-opera#var method="POST";
-+#USE=-opera#//var method="GET";
-
- // Random sequence numbers are needed to prevent Opera from caching
- // replies
-
- var is_opera = navigator.userAgent.toLowerCase().indexOf("opera") != -1;
--if (is_opera) {
-- method="GET";
--}
-+#USE=opera#if (is_opera) {
-+#USE=opera# method="GET";
-+#USE=opera#}
-+#USE=-opera#//if (is_opera) {
-+#USE=-opera#// method="GET";
-+#USE=-opera#//}
-
- var seqnum_val=Math.round(Math.random()*100000);
- function cachebust() {
-Index: anyterm-1.1.15/browser/.htaccess
-===================================================================
---- anyterm-1.1.15.orig/browser/.htaccess
-+++ anyterm-1.1.15/browser/.htaccess
-@@ -6,6 +6,8 @@
- # will be ignored if the anyterm module has not been loaded.
-
- <IfModule anyterm>
-+#USE=ssl#<IfModule mod_ssl.c>
-+#USE=pam#<IfModule mod_auth_pam.c>
-
- # Use an anyterm_command directive to specify the command to run
- # inside the terminal:
-@@ -24,6 +26,16 @@
- # Example:
- # anyterm_command '/path/to/anygetty --remotehost "Anyterm: %h" --autologin=%u'
-
-+# twp: Use ssh to avoid problems with Gentoo's /bin/login.
-+anyterm_command '/usr/bin/ssh %u@localhost'
-+
-+#USE=ssl#SSLRequireSSL
-+#USE=ssl#
-+#USE=pam#AuthPAM_Enabled on
-+#USE=pam#AuthType Basic
-+#USE=pam#AuthName "Anyterm"
-+#USE=pam#Require valid-user
-+#USE=pam#
- <Files anyterm-module>
- SetHandler anyterm
-
-@@ -34,9 +46,12 @@
- # CustomLog /path/to/logfile combined env=!DONTLOG
- # See the Apache documentation for details. Note "=!" not "!=" !
-
-- # SetEnv DONTLOG
-+#USE=opera# SetEnv DONTLOG
-+#USE=-opera# # SetEnv DONTLOG
- </Files>
-
-+#USE=pam#</IfModule>
-+#USE=ssl#</IfModule>
- # Additional Security Issues
-
- # If you're just testing Anyterm on a machine that's not connected to
diff --git a/www-apache/anyterm/files/anyterm-1.1.15-postinst-en.txt b/www-apache/anyterm/files/anyterm-1.1.15-postinst-en.txt
deleted file mode 100644
index 19a11013aa2f..000000000000
--- a/www-apache/anyterm/files/anyterm-1.1.15-postinst-en.txt
+++ /dev/null
@@ -1,59 +0,0 @@
-DEFAULT GENTOO INSTALLATION
-
-The default Gentoo installation is designed to work and be as secure as
-possible out-of-the box as long as you have USE="ssl pam -opera".
-
-
-USE FLAGS
-
-+ssl forces anyterm to only run over secure (HTTPS) connections.
--ssl disables secure connections, all data will pass over the network in
- plain text, including passwords!
-+pam enables PAM authentication, so anyone with an account on your computer
- can use anyterm without any further configuration.
--pam means that you will have to configure your own authentication
- mechanism.
-+opera Enables a workaround for a bug in the Opera browser, but you will have
- to modify apache's logging behaviour to prevent snooping by local
- users.
--opera Disables the Opera bug workaround.
-
-
-INSTALLATION INSTRUCTIONS
-
-1. Add the following flags to APACHE2_OPTS in /etc/init.d/apache2:
- -D ANYTERM
- -D SSL -D SSL_DEFAULT_VHOST # if USE=ssl
- -D AUTH_PAM # if USE=pam
-
-2. If you have USE=vhosts then you need to add the following directives to
- each virtual host's configuration file:
- <Directory "${MY_INSTALLDIR}">
- AllowOverride All
- </Directory>
-
-3. If you have USE=opera then you should disable logging of some requests. In
- each apache configuration file add env=!DONTLOG to each CustomLog
- directive. For example:
-
- USE="ssl -vhosts": edit /etc/apache2/modules.d/41_mod_ssl.default-vhost.conf:
-
- CustomLog logs/ssl_request_log \
- "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b" \
- env=!DONTLOG
-
- USE="-ssl -vhosts": edit /etc/apache2/modules.d/00_mod_log_config.conf:
- CustomLog logs/access_log common env=!DONTLOG
-
-4. Restart apache2:
- /etc/init.d/apache2 restart
-
-5. Browse to:
- https://${VHOST_HOSTNAME}${VHOST_APPDIR}/${PN}.html # if USE=ssl
- http://${VHOST_HOSTNAME}${VHOST_APPDIR}/${PN}.html # if USE=-ssl
-
-
-MORE INFORMATION
-
-http://anyterm.org/
-http://anyterm.org/security.html
diff --git a/www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch b/www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch
deleted file mode 100644
index 6dae0a41d41a..000000000000
--- a/www-apache/anyterm/files/anyterm-1.1.22-respect-flags.patch
+++ /dev/null
@@ -1,64 +0,0 @@
---- apachemod/Makefile
-+++ apachemod/Makefile
-@@ -85,7 +85,7 @@
- -DUSE_SHMEM \
- -I../boost_shmem
-
--COMPILE_FLAGS=$(CPP_FLAGS) $(shell $(APR_CONFIG) --cflags) -Wall -O0 -g
-+COMPILE_FLAGS=$(CPP_FLAGS) $(shell $(APR_CONFIG) --cflags) -Wall
-
- C_COMPILE_FLAGS=$(COMPILE_FLAGS) -std=gnu99
-
-@@ -108,23 +108,23 @@
- OBJS=$(addsuffix .lo,$(basename $(C_SRCS) $(CC_SRCS)))
-
- %.lo: %.cc
-- $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CC_COMPILE_FLAGS) -o $@ -c $<
-+ $(LIBTOOL) --mode=compile --tag=CXX $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(CC_COMPILE_FLAGS) -o $@ -c $<
-
- %.lo: %.c
-- $(LIBTOOL) --mode=compile $(CC) $(C_COMPILE_FLAGS) -o $@ -c $<
-+ $(LIBTOOL) --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) $(C_COMPILE_FLAGS) -o $@ -c $<
-
-
- compile: $(OBJS) $(LIBPBE_LIB)
-- $(APXS) -c -o anyterm.la $(OBJS) $(LINK_FLAGS)
-+ $(APXS) $(LDFLAGS) -c -o anyterm.la $(OBJS) $(LINK_FLAGS)
-
- install: FORCE
- $(APXS) -n anyterm -i anyterm.la
-
- %.d: %.cc
-- $(CXX) -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
-+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -MM -MG -MT $@ -MT $(<:%.cc=%.lo) $(CPP_FLAGS) -o $@ $<
-
- %.d: %.c
-- $(CC) -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
-+ $(CC) $(CPPFLAGS) $(CFLAGS) -MM -MG -MT $@ -MT $(<:%.c=%.lo) $(CPP_FLAGS) -o $@ $<
-
- DEPENDS=$(addsuffix .d,$(basename $(OBJS)))
-
---- libpbe/build/Makefile
-+++ libpbe/build/Makefile
-@@ -53,7 +53,7 @@
-
- WARN_FLAGS=-W -Wall
-
--OPTIMISE_FLAGS=-O
-+OPTIMISE_FLAGS=
-
- DEBUG_FLAGS=
-
-@@ -71,10 +71,10 @@
- $(AR) ruv $(LIBRARY) $(OBJS)
-
- %.o: %.cc
-- $(CXX) $(COMPILE_FLAGS) -c $<
-+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(COMPILE_FLAGS) -c $<
-
- %.d: %.cc
-- $(CXX) -pthread -MM -MT $@ -MT $(notdir $(<:%.cc=%.o)) $(INC_FLAGS) -o $@ $<
-+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -pthread -MM -MT $@ -MT $(notdir $(<:%.cc=%.o)) $(INC_FLAGS) -o $@ $<
-
- all: $(EXECUTABLE)
-
diff --git a/www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch b/www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch
new file mode 100644
index 000000000000..3809f5aac186
--- /dev/null
+++ b/www-apache/anyterm/files/anyterm-1.1.29-gcc-4.4.patch
@@ -0,0 +1,10 @@
+--- libpbe/src/SmtpClient.cc
++++ libpbe/src/SmtpClient.cc
+@@ -20,6 +20,7 @@
+ #include "ip.hh"
+ #include "select.hh"
+
++#include <stdio.h>
+ #include <syslog.h>
+ #include <unistd.h>
+