summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-10-27 15:12:25 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-10-27 15:12:25 +0000
commit6a8b88e6d139fa51209614a0a0b389a2bc3f6857 (patch)
treea4e4a02f61eb6ac92e016ddedd78e02d5ca6aa04 /www-apps/otrs
parentHOMEPAGE changed, revbump wrt #138872, fix doc installation #117009, should f... (diff)
downloadgentoo-2-6a8b88e6d139fa51209614a0a0b389a2bc3f6857.tar.gz
gentoo-2-6a8b88e6d139fa51209614a0a0b389a2bc3f6857.tar.bz2
gentoo-2-6a8b88e6d139fa51209614a0a0b389a2bc3f6857.zip
Version bump, bug #150863.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'www-apps/otrs')
-rw-r--r--www-apps/otrs/ChangeLog8
-rw-r--r--www-apps/otrs/files/dbi_finish.patch10
-rw-r--r--www-apps/otrs/files/digest-otrs-2.1.23
-rw-r--r--www-apps/otrs/otrs-2.1.2.ebuild119
4 files changed, 139 insertions, 1 deletions
diff --git a/www-apps/otrs/ChangeLog b/www-apps/otrs/ChangeLog
index 59bb6e469273..16f63e3d07b3 100644
--- a/www-apps/otrs/ChangeLog
+++ b/www-apps/otrs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/otrs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/ChangeLog,v 1.22 2006/10/20 02:45:53 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/ChangeLog,v 1.23 2006/10/27 15:12:25 rl03 Exp $
+
+*otrs-2.1.2 (27 Oct 2006)
+
+ 27 Oct 2006; Renat Lumpau <rl03@gentoo.org> +files/dbi_finish.patch,
+ +otrs-2.1.2.ebuild:
+ Version bump, bug #150863.
20 Oct 2006; Renat Lumpau <rl03@gentoo.org> -files/postinstall-en.txt,
-files/reconfig, -otrs-1.3.2.ebuild, -otrs-2.0.3.ebuild,
diff --git a/www-apps/otrs/files/dbi_finish.patch b/www-apps/otrs/files/dbi_finish.patch
new file mode 100644
index 000000000000..3817d586b966
--- /dev/null
+++ b/www-apps/otrs/files/dbi_finish.patch
@@ -0,0 +1,10 @@
+--- Kernel/System/DB.pm.old Wed Jun 14 15:45:49 2006
++++ Kernel/System/DB.pm Wed Jun 14 15:43:12 2006
+@@ -217,6 +217,7 @@
+ );
+ }
+ # do disconnect
++ $Self->{Curser}->finish() if (defined($Self->{Curser}));
+ $Self->{dbh}->disconnect() if ($Self->{dbh});
+ return 1;
+ }
diff --git a/www-apps/otrs/files/digest-otrs-2.1.2 b/www-apps/otrs/files/digest-otrs-2.1.2
new file mode 100644
index 000000000000..0c38975091d6
--- /dev/null
+++ b/www-apps/otrs/files/digest-otrs-2.1.2
@@ -0,0 +1,3 @@
+MD5 64f4fe22a089d848736c3ca72bf3c932 otrs-2.1.2.tar.bz2 12570909
+RMD160 bb097eae5709ebe64287ed62907bea8a399224bd otrs-2.1.2.tar.bz2 12570909
+SHA256 c2f5f2691f13803cb4e99113d96f52da157cf9d58393acd75179e314ca536440 otrs-2.1.2.tar.bz2 12570909
diff --git a/www-apps/otrs/otrs-2.1.2.ebuild b/www-apps/otrs/otrs-2.1.2.ebuild
new file mode 100644
index 000000000000..9b17033ae4cb
--- /dev/null
+++ b/www-apps/otrs/otrs-2.1.2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/otrs/otrs-2.1.2.ebuild,v 1.1 2006/10/27 15:12:25 rl03 Exp $
+
+inherit webapp eutils
+
+IUSE="mysql postgres fastcgi apache2 ldap gd pdf"
+
+DESCRIPTION="OTRS is an Open source Ticket Request System"
+HOMEPAGE="http://otrs.org/"
+SRC_URI="ftp://ftp.otrs.org/pub/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ ${DEPEND}
+ =dev-lang/perl-5*
+ dev-perl/Date-Pcalc
+ dev-perl/TimeDate
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/DBI
+ virtual/perl-CGI
+ virtual/perl-Digest-MD5
+ dev-perl/libwww-perl
+ dev-perl/IO-stringy
+ virtual/perl-MIME-Base64
+ dev-perl/MIME-tools
+ dev-perl/MailTools
+ dev-perl/Net-DNS
+ virtual/perl-libnet
+ dev-perl/Authen-SASL
+ dev-perl/XML-Parser
+ virtual/mta
+ pdf? ( dev-perl/PDF-API2 )
+ ldap? ( dev-perl/perl-ldap net-nds/openldap )
+ mysql? ( =dev-db/mysql-4* dev-perl/DBD-mysql )
+ postgres? ( dev-db/postgresql dev-perl/DBD-Pg )
+ apache2? ( >=net-www/apache-2
+ fastcgi? ( dev-perl/FCGI net-www/mod_fastcgi )
+ !fastcgi? ( =www-apache/libapreq2-2* ) )
+ !apache2? ( =net-www/apache-1*
+ fastcgi? ( dev-perl/FCGI net-www/mod_fastcgi )
+ !fastcgi? ( =www-apache/libapreq-1* ) )
+ gd? ( dev-perl/GD dev-perl/GDTextUtil dev-perl/GDGraph )
+"
+
+LICENSE="GPL-2"
+
+pkg_setup() {
+ webapp_pkg_setup
+ enewuser otrs -1 -1 /dev/null apache
+}
+
+src_unpack() {
+ unpack ${A}
+ cp ${S}/Kernel/Config.pm.dist ${S}/Kernel/Config.pm
+
+ # http://bugs.otrs.org/show_bug.cgi?id=1231
+ cd ${S}
+ epatch ${FILESDIR}/dbi_finish.patch
+
+ cd ${S}/Kernel/Config/
+ for foo in *.dist; do cp ${foo} $(basename ${foo} .dist); done
+
+ cd ${S}/scripts
+ rm -rf auto_* redhat* suse*
+
+ if use fastcgi; then
+ if ! use apache2; then
+ epatch ${FILESDIR}/apache1.patch
+ sed -e "s|cgi-bin|fcgi-bin|" -i ${S}/scripts/apache-httpd.include.conf
+ fi
+ if use apache2; then
+ epatch ${FILESDIR}/apache2.patch
+ sed -e "s|cgi-bin|fcgi-bin|" -i ${S}/scripts/apache2-httpd.include.conf
+ fi
+ sed -e "s|index.pl|index.fpl|" -i ${S}/var/httpd/htdocs/index.html
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+ dodir ${MY_HOSTROOTDIR}/${PF}
+
+ # install documentation
+ dodoc CHANGES CREDITS INSTALL README* TODO UPGRADING \
+ doc/otrs-database.dia doc/test-* doc/X-OTRS-Headers.txt \
+ .fetchmailrc.dist .mailfilter.dist .procmailrc.dist
+ dohtml doc/manual/{en,de}/html/*
+
+ # copy main files
+ cp -R .fetchmailrc.dist .mailfilter.dist .procmailrc.dist RELEASE Kernel bin scripts var ${D}/${MY_HOSTROOTDIR}/${PF}
+ mv ${D}/${MY_HOSTROOTDIR}/${PF}/var/httpd/htdocs/* ${D}/${MY_HTDOCSDIR}
+
+ # remove stuff from ${D} that shouldn't be there
+ rm -rf ${D}/${MY_HOSTROOTDIR}/${PF}/var/httpd
+
+ # keep some empty dirs
+ local a
+ local d="article log pics/images pics/stats pics sessions spool tmp"
+ for a in ${d}; do
+ keepdir ${MY_HOSTROOTDIR}/${PF}/var/${a}
+ done
+
+ # helpers
+ webapp_configfile ${MY_HOSTROOTDIR}/${PF}/Kernel/Config.pm
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-2.txt
+ webapp_hook_script ${FILESDIR}/reconfig-2
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn "webapp-config will not be run automatically"
+ ewarn "That messes up Apache configs"
+ ewarn "Don't run webapp-config with -d otrs. Instead, try"
+ ewarn "webapp-config -I -h <host> -d ot ${PN} ${PVR}"
+ ewarn
+ # webapp_pkg_postinst
+}