summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-24 17:48:45 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-24 17:48:45 +0000
commit4436f13724b328dbcebdfb5483c09468b2213586 (patch)
tree6c967dfbaca9ee99c5e515b3382e0f3caae89bd5 /www-apps/ownpaste
parentversion bump to new testing, removing previous testing (diff)
downloadgentoo-2-4436f13724b328dbcebdfb5483c09468b2213586.tar.gz
gentoo-2-4436f13724b328dbcebdfb5483c09468b2213586.tar.bz2
gentoo-2-4436f13724b328dbcebdfb5483c09468b2213586.zip
Convert to distutils-r1, bug #477724.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'www-apps/ownpaste')
-rw-r--r--www-apps/ownpaste/ChangeLog10
-rw-r--r--www-apps/ownpaste/ownpaste-0.2.2-r1.ebuild54
-rw-r--r--www-apps/ownpaste/ownpaste-0.2.2.ebuild59
-rw-r--r--www-apps/ownpaste/ownpaste-9999.ebuild43
4 files changed, 81 insertions, 85 deletions
diff --git a/www-apps/ownpaste/ChangeLog b/www-apps/ownpaste/ChangeLog
index 131c54fbf1cc..dc092ab35202 100644
--- a/www-apps/ownpaste/ChangeLog
+++ b/www-apps/ownpaste/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/ownpaste
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/ownpaste/ChangeLog,v 1.6 2012/12/26 23:30:45 ottxor Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ownpaste/ChangeLog,v 1.7 2013/07/24 17:48:45 mgorny Exp $
+
+*ownpaste-0.2.2-r1 (24 Jul 2013)
+
+ 24 Jul 2013; Michał Górny <mgorny@gentoo.org> +ownpaste-0.2.2-r1.ebuild,
+ -ownpaste-0.2.2.ebuild, ownpaste-9999.ebuild:
+ Convert to distutils-r1, bug #477724.
26 Dec 2012; Christoph Junghans <ottxor@gentoo.org> ownpaste-0.2.2.ebuild,
ownpaste-9999.ebuild:
diff --git a/www-apps/ownpaste/ownpaste-0.2.2-r1.ebuild b/www-apps/ownpaste/ownpaste-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..7661ff87d444
--- /dev/null
+++ b/www-apps/ownpaste/ownpaste-0.2.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ownpaste/ownpaste-0.2.2-r1.ebuild,v 1.1 2013/07/24 17:48:45 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+HG_ECLASS=""
+if [[ ${PV} = *9999* ]]; then
+ HG_ECLASS="mercurial"
+ EHG_REPO_URI="http://hg.rafaelmartins.eng.br/ownpaste/"
+fi
+
+inherit distutils-r1 ${HG_ECLASS}
+
+DESCRIPTION="Private pastebin (server-side implementation)"
+HOMEPAGE="http://ownpaste.rtfd.org/ http://pypi.python.org/pypi/ownpaste"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+fi
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/flask-script-0.3.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-sqlalchemy-0.15[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.6[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ if use doc; then
+ einfo 'building documentation'
+ emake -C docs html
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/www-apps/ownpaste/ownpaste-0.2.2.ebuild b/www-apps/ownpaste/ownpaste-0.2.2.ebuild
deleted file mode 100644
index 802eb87355e1..000000000000
--- a/www-apps/ownpaste/ownpaste-0.2.2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/ownpaste/ownpaste-0.2.2.ebuild,v 1.3 2012/12/26 23:30:45 ottxor Exp $
-
-EAPI=4
-
-PYTHON_COMPAT="python2_7"
-
-HG_ECLASS=""
-if [[ ${PV} = *9999* ]]; then
- HG_ECLASS="mercurial"
- EHG_REPO_URI="http://hg.rafaelmartins.eng.br/ownpaste/"
-fi
-
-inherit python-distutils-ng ${HG_ECLASS}
-
-DESCRIPTION="Private pastebin (server-side implementation)"
-HOMEPAGE="http://ownpaste.rtfd.org/ http://pypi.python.org/pypi/ownpaste"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
-fi
-
-RDEPEND="dev-python/setuptools
- >=dev-python/flask-0.8
- >=dev-python/flask-script-0.3.3
- >=dev-python/flask-sqlalchemy-0.15
- >=dev-python/jinja-2.6
- >=dev-python/werkzeug-0.8
- >=dev-python/sqlalchemy-migrate-0.7.2
- dev-python/pygments
- dev-python/pytz"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-src_compile() {
- python-distutils-ng_src_compile
-
- if use doc; then
- einfo 'building documentation'
- emake -C docs html
- fi
-}
-
-src_install() {
- python-distutils-ng_src_install
-
- if use doc; then
- einfo 'installing documentation'
- dohtml -r "${S}/docs/_build/html/"*
- fi
-}
diff --git a/www-apps/ownpaste/ownpaste-9999.ebuild b/www-apps/ownpaste/ownpaste-9999.ebuild
index 878d58fff142..0976ebe2b81a 100644
--- a/www-apps/ownpaste/ownpaste-9999.ebuild
+++ b/www-apps/ownpaste/ownpaste-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/ownpaste/ownpaste-9999.ebuild,v 1.4 2012/12/26 23:30:45 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ownpaste/ownpaste-9999.ebuild,v 1.5 2013/07/24 17:48:45 mgorny Exp $
-EAPI=4
+EAPI=5
-PYTHON_COMPAT="python2_7"
+PYTHON_COMPAT=( python2_7 )
HG_ECLASS=""
if [[ ${PV} = *9999* ]]; then
@@ -12,7 +12,7 @@ if [[ ${PV} = *9999* ]]; then
EHG_REPO_URI="http://hg.rafaelmartins.eng.br/ownpaste/"
fi
-inherit python-distutils-ng ${HG_ECLASS}
+inherit distutils-r1 ${HG_ECLASS}
DESCRIPTION="Private pastebin (server-side implementation)"
HOMEPAGE="http://ownpaste.rtfd.org/ http://pypi.python.org/pypi/ownpaste"
@@ -28,32 +28,27 @@ if [[ ${PV} = *9999* ]]; then
KEYWORDS=""
fi
-RDEPEND="dev-python/setuptools
- >=dev-python/flask-0.8
- >=dev-python/flask-script-0.3.3
- >=dev-python/flask-sqlalchemy-0.15
- >=dev-python/jinja-2.6
- >=dev-python/werkzeug-0.8
- >=dev-python/sqlalchemy-migrate-0.7.2
- dev-python/pygments
- dev-python/pytz"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/flask-script-0.3.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-sqlalchemy-0.15[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.6[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-migrate-0.7.2[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
-
-src_compile() {
- python-distutils-ng_src_compile
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+python_compile_all() {
if use doc; then
einfo 'building documentation'
emake -C docs html
fi
}
-src_install() {
- python-distutils-ng_src_install
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
- if use doc; then
- einfo 'installing documentation'
- dohtml -r "${S}/docs/_build/html/"*
- fi
+ distutils-r1_python_install_all
}