summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-01-22 16:24:18 +0000
committerPeter Volkov <pva@gentoo.org>2008-01-22 16:24:18 +0000
commit1deda9aada7b664b8a1cdbf40b6bcba063d721f8 (patch)
tree2dd3b0dbd6f283f6b2fa3ea609c51935f0c89af5 /www-apps
parentversion bump (diff)
downloadgentoo-2-1deda9aada7b664b8a1cdbf40b6bcba063d721f8.tar.gz
gentoo-2-1deda9aada7b664b8a1cdbf40b6bcba063d721f8.tar.bz2
gentoo-2-1deda9aada7b664b8a1cdbf40b6bcba063d721f8.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mantisbt/ChangeLog7
-rw-r--r--www-apps/mantisbt/files/digest-mantisbt-1.1.13
-rw-r--r--www-apps/mantisbt/mantisbt-1.1.1.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index d76b60dee796..e5d7b6eea263 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.53 2008/01/14 20:59:46 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.54 2008/01/22 16:24:17 pva Exp $
+
+*mantisbt-1.1.1 (22 Jan 2008)
+
+ 22 Jan 2008; <pva@gentoo.org> +mantisbt-1.1.1.ebuild:
+ Version bump.
14 Jan 2008; <pva@gentoo.org> files/postinstall-en-1.0.0.txt:
Added link to upgrade instructions and to manual into postinstall.
diff --git a/www-apps/mantisbt/files/digest-mantisbt-1.1.1 b/www-apps/mantisbt/files/digest-mantisbt-1.1.1
new file mode 100644
index 000000000000..016a5d768c62
--- /dev/null
+++ b/www-apps/mantisbt/files/digest-mantisbt-1.1.1
@@ -0,0 +1,3 @@
+MD5 7e646be79def5bb32b74b1a246caf766 mantis-1.1.1.tar.gz 2526314
+RMD160 30dc40ed6a236bbb80f50225201cb6c2e7ecfb3e mantis-1.1.1.tar.gz 2526314
+SHA256 9357d9ff7ce52f708a226c5c19230509764ceacfb89a964b45ff44dcf74f5c8b mantis-1.1.1.tar.gz 2526314
diff --git a/www-apps/mantisbt/mantisbt-1.1.1.ebuild b/www-apps/mantisbt/mantisbt-1.1.1.ebuild
new file mode 100644
index 000000000000..1044a8d3de11
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.1.1.ebuild,v 1.1 2008/01/22 16:24:17 pva Exp $
+
+inherit eutils webapp depend.php
+
+IUSE="bundled-adodb"
+MY_P=mantis-${PV}
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+S=${WORKDIR}/${MY_P}
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ virtual/httpd-php
+ virtual/httpd-cgi
+ !bundled-adodb? ( dev-php/adodb )
+"
+
+LICENSE="GPL-2"
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ require_php_with_use pcre
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use bundled-adodb ; then
+ sed -i -e \
+ "s:require_once( 'adodb/adodb.inc.php' );:require_once( \$t_core_dir . 'adodb/adodb.inc.php' );:" \
+ "${S}"/core/database_api.php
+ else
+ rm -r "${S}"/core/adodb/
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+ rm doc/{LICENSE,INSTALL}
+ dodoc doc/* packages/mantis-httpd.conf
+
+ rm -rf doc packages
+ mv config_inc.php.sample config_inc.php
+ cp -R . "${D}"/${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/config_inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-1.0.0.txt
+ webapp_src_install
+}