summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-01-17 09:50:35 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-01-17 09:50:35 +0000
commit368c684ccd16c49a26522f1625b52675d919f8a6 (patch)
tree140a1b71de84ba578343b0b4aaf4b5d3e696857d /www-apps
parentfix dependencies for 1.4.4, thanks to Pavel Sanda <ps@twin.jikos.cz>, should... (diff)
downloadgentoo-2-368c684ccd16c49a26522f1625b52675d919f8a6.tar.gz
gentoo-2-368c684ccd16c49a26522f1625b52675d919f8a6.tar.bz2
gentoo-2-368c684ccd16c49a26522f1625b52675d919f8a6.zip
Fixed dependencies (#205846).
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/sitebar/ChangeLog9
-rw-r--r--www-apps/sitebar/files/digest-sitebar-3.3.9-r13
-rw-r--r--www-apps/sitebar/sitebar-3.3.9-r1.ebuild32
3 files changed, 42 insertions, 2 deletions
diff --git a/www-apps/sitebar/ChangeLog b/www-apps/sitebar/ChangeLog
index c3376cfc910f..866bd7f13102 100644
--- a/www-apps/sitebar/ChangeLog
+++ b/www-apps/sitebar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/sitebar
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/sitebar/ChangeLog,v 1.19 2007/10/18 17:13:14 wrobel Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/sitebar/ChangeLog,v 1.20 2008/01/17 09:50:35 wrobel Exp $
+
+*sitebar-3.3.9-r1 (17 Jan 2008)
+
+ 17 Jan 2008; Gunnar Wrobel <wrobel@gentoo.org> +sitebar-3.3.9-r1.ebuild:
+ Fixed dependencies (#205846).
18 Oct 2007; <wrobel@gentoo.org> -files/debian.patch,
-sitebar-3.3.8-r1.ebuild:
diff --git a/www-apps/sitebar/files/digest-sitebar-3.3.9-r1 b/www-apps/sitebar/files/digest-sitebar-3.3.9-r1
new file mode 100644
index 000000000000..2f9c22f55c39
--- /dev/null
+++ b/www-apps/sitebar/files/digest-sitebar-3.3.9-r1
@@ -0,0 +1,3 @@
+MD5 9fcdd8080198adcc900dbfa0dcbee063 SiteBar-3.3.9.tar.bz2 526092
+RMD160 756dcaf7191cf078a7ef014ead75347d062545a8 SiteBar-3.3.9.tar.bz2 526092
+SHA256 6232ecbb4216117cf3bafa3746e51c14204f744804dfa75094a43d305dbcb355 SiteBar-3.3.9.tar.bz2 526092
diff --git a/www-apps/sitebar/sitebar-3.3.9-r1.ebuild b/www-apps/sitebar/sitebar-3.3.9-r1.ebuild
new file mode 100644
index 000000000000..b161ec4921fa
--- /dev/null
+++ b/www-apps/sitebar/sitebar-3.3.9-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/sitebar/sitebar-3.3.9-r1.ebuild,v 1.1 2008/01/17 09:50:35 wrobel Exp $
+
+inherit webapp eutils
+
+MY_P=SiteBar-${PV}
+
+DESCRIPTION="The Bookmark Server for Personal and Team Use"
+HOMEPAGE="http://sitebar.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/httpd-cgi
+ virtual/php"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ webapp_src_preinst
+ dodoc readme.txt doc/history.txt doc/install.txt doc/troubleshooting.txt
+ cp -R . "${D}/${MY_HTDOCSDIR}"
+ rm -rf "${D}/${MY_HTDOCSDIR}/doc" "${D}/${MY_HTDOCSDIR}/readme.txt"
+
+ webapp_serverowned "${MY_HTDOCSDIR}/inc"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+
+ webapp_src_install
+}