summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2005-11-05 15:58:59 +0000
committerLim Swee Tat <st_lim@gentoo.org>2005-11-05 15:58:59 +0000
commit923b9f9f589b3dc9b1449089cdde92929bcea7eb (patch)
treeb562950b3c9929eb9093b463eba7bf8d2fe354a9 /www-apps
parentAdding sqlite3 as a use flag and removing older stuff (diff)
downloadgentoo-2-923b9f9f589b3dc9b1449089cdde92929bcea7eb.tar.gz
gentoo-2-923b9f9f589b3dc9b1449089cdde92929bcea7eb.tar.bz2
gentoo-2-923b9f9f589b3dc9b1449089cdde92929bcea7eb.zip
Removed older files
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/dspam-web/dspam-web-3.4.0.ebuild162
-rw-r--r--www-apps/dspam-web/dspam-web-3.4.1.ebuild162
-rw-r--r--www-apps/dspam-web/dspam-web-3.4.2.ebuild162
-rw-r--r--www-apps/dspam-web/dspam-web-3.4_rc3.ebuild166
-rw-r--r--www-apps/dspam-web/dspam-web-3.6_rc3.ebuild162
-rw-r--r--www-apps/dspam-web/files/digest-dspam-web-3.4.01
-rw-r--r--www-apps/dspam-web/files/digest-dspam-web-3.4.11
-rw-r--r--www-apps/dspam-web/files/digest-dspam-web-3.4.21
-rw-r--r--www-apps/dspam-web/files/digest-dspam-web-3.4_rc31
-rw-r--r--www-apps/dspam-web/files/digest-dspam-web-3.6_rc31
10 files changed, 0 insertions, 819 deletions
diff --git a/www-apps/dspam-web/dspam-web-3.4.0.ebuild b/www-apps/dspam-web/dspam-web-3.4.0.ebuild
deleted file mode 100644
index 9b0e1224f43e..000000000000
--- a/www-apps/dspam-web/dspam-web-3.4.0.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/dspam-web-3.4.0.ebuild,v 1.4 2005/11/05 15:53:55 st_lim Exp $
-
-inherit webapp eutils
-
-MY_PN=${PN/-web/}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Web based administration and user controls for dspam"
-SRC_URI="http://dspam.nuclearelephant.com/sources/${MY_P}.tar.gz"
-
-HOMEPAGE="http://dspam.nuclearelephant.com/"
-LICENSE="GPL-2"
-DEPEND=">=mail-filter/dspam-3.2_rc3
- >=net-www/apache-1.3
- >=dev-lang/perl-5.8.2
- >=dev-perl/GD-2.0
- dev-perl/GD-Graph3d
- dev-perl/GDGraph
- dev-perl/GDTextUtil"
-KEYWORDS="~x86 ~ppc ~amd64"
-S=${WORKDIR}/${MY_P}
-HOMEDIR=/etc/mail/dspam
-IUSE="debug large-domain mysql neural oci8 postgres sqlite sqlite3 virtual-users"
-
-src_compile() {
- local myconf
-
- myconf="${myconf} --enable-long-username"
- use large-domain && myconf="${myconf} --enable-large-scale" ||\
- myconf="${myconf} --enable-domain-scale"
-
- myconf="${myconf} --with-dspam-mode=4755"
- myconf="${myconf} --with-dspam-owner=dspam"
- myconf="${myconf} --with-dspam-group=dspam"
- myconf="${myconf} --sysconfdir=${HOMEDIR}"
- myconf="${myconf} --with-logdir=${LOGDIR}"
- use virtual-users || myconf="${myconf} --with-dspam-home=${HOMEDIR}"
-
- # enables support for debugging (touch /etc/dspam/.debug to turn on)
- # optional: even MORE debugging output, use with extreme caution!
- use debug && myconf="${myconf} --enable-debug --enable-verbose-debug"
-
- # select storage driver
- if use mysql; then
- myconf="${myconf} --with-storage-driver=mysql_drv"
- myconf="${myconf} --with-mysql-includes=/usr/include/mysql"
- myconf="${myconf} --with-mysql-libraries=/usr/lib/mysql"
- myconf="${myconf} --enable-preferences-extension"
-
- if has_version sys-kernel/linux26-headers; then
- myconf="${myconf} --enable-daemon"
- fi
-
- use virtual-users && myconf="${myconf} --enable-virtual-users"
- # an experimental feature available with MySQL and PgSQL backend
- use neural && myconf="${myconf} --enable-neural-networking"
- elif use postgres ; then
- myconf="${myconf} --with-storage-driver=pgsql_drv"
- myconf="${myconf} --with-pgsql-includes=/usr/include/postgresql"
- myconf="${myconf} --with-pgsql-libraries=/usr/lib/postgresql"
- myconf="${myconf} --enable-preferences-extension"
-
- if has_version sys-kernel/linux26-headers; then
- myconf="${myconf} --enable-daemon"
- fi
-
- use virtual-users && myconf="${myconf} --enable-virtual-users"
- # an experimental feature available with MySQL and PgSQL backend
- use neural && myconf="${myconf} --enable-neural-networking"
- elif use oci8 ; then
- myconf="${myconf} --with-storage-driver=ora_drv"
- myconf="${myconf} --with-oracle-home=${ORACLE_HOME}"
- myconf="${myconf} --enable-virtual-users"
-
- # I am in no way a Oracle specialist. If someone knows
- # how to query the version of Oracle, then let me know.
- if (expr ${ORACLE_HOME/*\/} : 10 1>/dev/null 2>&1); then
- myconf="${myconf} --with-oracle-version=10"
- fi
- elif use sqlite3 ; then
- myconf="${myconf} --with-storage-driver=sqlite3_drv"
- myconf="${myconf} --enable-virtual-users"
- elif use sqlite ; then
- myconf="${myconf} --with-storage-driver=sqlite_drv"
- myconf="${myconf} --enable-virtual-users"
- else
- myconf="${myconf} --with-storage-driver=libdb4_drv"
- fi
-
- econf ${myconf} || die
- cd ${S}/cgi
- make
-}
-
-src_install () {
- cd ${S}/cgi
- webapp_src_preinst
-
- sed -e 's,/var/dspam,/etc/mail/dspam,' \
- -e 's,/usr/local,/usr,' \
- -i admin.cgi
- sed -e 's,/var/dspam,/etc/mail/dspam,' \
- -e 's,/usr/local,/usr,' \
- -i dspam.cgi
-
- insinto ${MY_HTDOCSDIR}
- insopts -m644 -o apache -g apache
- doins *.css
- doins *.gif
- doins rgb.txt
- doins default.prefs
- doins admins
- doins configure.pl
-
- newins ${FILESDIR}/htaccess .htaccess
- newins ${FILESDIR}/htpasswd .htpasswd
-
- insopts -m755 -o apache -g apache
- doins *.cgi
-
- for CGI_SCRIPT in admin.cgi admingraph.cgi dspam.cgi graph.cgi; do
- webapp_runbycgibin perl ${MY_HTDOCSDIR}/${CGI_SCRIPT}
- done
-
- dodir ${MY_HTDOCSDIR}/templates
-
- insinto ${MY_HTDOCSDIR}/templates
- doins templates/*.html
-
- #All files must be owned by server
- cd ${D}${MY_HTDOCSDIR}
- for x in `find . -type f -print` ; do
- webapp_serverowned ${MY_HTDOCSDIR}/$x
- done
-
- webapp_src_install
-}
-
-pkg_config () {
- # add apache to the dspam group so the CGIs can access the data
-
- local groups
- groups=`groups apache`
- groups=`echo ${groups} | sed -e 's/ /,/g'`
- usermod -G "${groups},dspam" apache
-}
-
-pkg_postinst () {
- einfo "The CGIs need to be executed as group dspam in order to write"
- einfo "to the dspam data directory. You will need to configure apache"
- einfo "manually to do this. Another option is to add the user apache"
- einfo "to the dspam group. You can do this automatically by running:"
- echo
- einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
- echo
- einfo "This app requires basic auth in order to operate properly."
- einfo "You will need to add dspam users to the .htpasswd file or"
- einfo "configure a different authentication mechanism for the user"
- einfo "accounts."
-}
diff --git a/www-apps/dspam-web/dspam-web-3.4.1.ebuild b/www-apps/dspam-web/dspam-web-3.4.1.ebuild
deleted file mode 100644
index ad2f35e73a8b..000000000000
--- a/www-apps/dspam-web/dspam-web-3.4.1.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/dspam-web-3.4.1.ebuild,v 1.3 2005/11/05 15:53:55 st_lim Exp $
-
-inherit webapp eutils
-
-MY_PN=${PN/-web/}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Web based administration and user controls for dspam"
-SRC_URI="http://dspam.nuclearelephant.com/sources/${MY_P}.tar.gz"
-
-HOMEPAGE="http://dspam.nuclearelephant.com/"
-LICENSE="GPL-2"
-DEPEND=">=mail-filter/dspam-3.2_rc3
- >=net-www/apache-1.3
- >=dev-lang/perl-5.8.2
- >=dev-perl/GD-2.0
- dev-perl/GD-Graph3d
- dev-perl/GDGraph
- dev-perl/GDTextUtil"
-KEYWORDS="~x86 ~ppc ~amd64"
-S=${WORKDIR}/${MY_P}
-HOMEDIR=/etc/mail/dspam
-IUSE="debug large-domain mysql neural oci8 postgres sqlite sqlite3 virtual-users"
-
-src_compile() {
- local myconf
-
- myconf="${myconf} --enable-long-username"
- use large-domain && myconf="${myconf} --enable-large-scale" ||\
- myconf="${myconf} --enable-domain-scale"
-
- myconf="${myconf} --with-dspam-mode=4755"
- myconf="${myconf} --with-dspam-owner=dspam"
- myconf="${myconf} --with-dspam-group=dspam"
- myconf="${myconf} --sysconfdir=${HOMEDIR}"
- myconf="${myconf} --with-logdir=${LOGDIR}"
- use virtual-users || myconf="${myconf} --with-dspam-home=${HOMEDIR}"
-
- # enables support for debugging (touch /etc/dspam/.debug to turn on)
- # optional: even MORE debugging output, use with extreme caution!
- use debug && myconf="${myconf} --enable-debug --enable-verbose-debug"
-
- # select storage driver
- if use mysql; then
- myconf="${myconf} --with-storage-driver=mysql_drv"
- myconf="${myconf} --with-mysql-includes=/usr/include/mysql"
- myconf="${myconf} --with-mysql-libraries=/usr/lib/mysql"
- myconf="${myconf} --enable-preferences-extension"
-
- if has_version sys-kernel/linux26-headers; then
- myconf="${myconf} --enable-daemon"
- fi
-
- use virtual-users && myconf="${myconf} --enable-virtual-users"
- # an experimental feature available with MySQL and PgSQL backend
- use neural && myconf="${myconf} --enable-neural-networking"
- elif use postgres ; then
- myconf="${myconf} --with-storage-driver=pgsql_drv"
- myconf="${myconf} --with-pgsql-includes=/usr/include/postgresql"
- myconf="${myconf} --with-pgsql-libraries=/usr/lib/postgresql"
- myconf="${myconf} --enable-preferences-extension"
-
- if has_version sys-kernel/linux26-headers; then
- myconf="${myconf} --enable-daemon"
- fi
-
- use virtual-users && myconf="${myconf} --enable-virtual-users"
- # an experimental feature available with MySQL and PgSQL backend
- use neural && myconf="${myconf} --enable-neural-networking"
- elif use oci8 ; then
- myconf="${myconf} --with-storage-driver=ora_drv"
- myconf="${myconf} --with-oracle-home=${ORACLE_HOME}"
- myconf="${myconf} --enable-virtual-users"
-
- # I am in no way a Oracle specialist. If someone knows
- # how to query the version of Oracle, then let me know.
- if (expr ${ORACLE_HOME/*\/} : 10 1>/dev/null 2>&1); then
- myconf="${myconf} --with-oracle-version=10"
- fi
- elif use sqlite3 ; then
- myconf="${myconf} --with-storage-driver=sqlite3_drv"
- myconf="${myconf} --enable-virtual-users"
- elif use sqlite ; then
- myconf="${myconf} --with-storage-driver=sqlite_drv"
- myconf="${myconf} --enable-virtual-users"
- else
- myconf="${myconf} --with-storage-driver=libdb4_drv"
- fi
-
- econf ${myconf} || die
- cd ${S}/cgi
- make
-}
-
-src_install () {
- cd ${S}/cgi
- webapp_src_preinst
-
- sed -e 's,/var/dspam,/etc/mail/dspam,' \
- -e 's,/usr/local,/usr,' \
- -i admin.cgi
- sed -e 's,/var/dspam,/etc/mail/dspam,' \
- -e 's,/usr/local,/usr,' \
- -i dspam.cgi
-
- insinto ${MY_HTDOCSDIR}
- insopts -m644 -o apache -g apache
- doins *.css
- doins *.gif
- doins rgb.txt
- doins default.prefs
- doins admins
- doins configure.pl
-
- newins ${FILESDIR}/htaccess .htaccess
- newins ${FILESDIR}/htpasswd .htpasswd
-
- insopts -m755 -o apache -g apache
- doins *.cgi
-
- for CGI_SCRIPT in admin.cgi admingraph.cgi dspam.cgi graph.cgi; do
- webapp_runbycgibin perl ${MY_HTDOCSDIR}/${CGI_SCRIPT}
- done
-
- dodir ${MY_HTDOCSDIR}/templates
-
- insinto ${MY_HTDOCSDIR}/templates
- doins templates/*.html
-
- #All files must be owned by server
- cd ${D}${MY_HTDOCSDIR}
- for x in `find . -type f -print` ; do
- webapp_serverowned ${MY_HTDOCSDIR}/$x
- done
-
- webapp_src_install
-}
-
-pkg_config () {
- # add apache to the dspam group so the CGIs can access the data
-
- local groups
- groups=`groups apache`
- groups=`echo ${groups} | sed -e 's/ /,/g'`
- usermod -G "${groups},dspam" apache
-}
-
-pkg_postinst () {
- einfo "The CGIs need to be executed as group dspam in order to write"
- einfo "to the dspam data directory. You will need to configure apache"
- einfo "manually to do this. Another option is to add the user apache"
- einfo "to the dspam group. You can do this automatically by running:"
- echo
- einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
- echo
- einfo "This app requires basic auth in order to operate properly."
- einfo "You will need to add dspam users to the .htpasswd file or"
- einfo "configure a different authentication mechanism for the user"
- einfo "accounts."
-}
diff --git a/www-apps/dspam-web/dspam-web-3.4.2.ebuild b/www-apps/dspam-web/dspam-web-3.4.2.ebuild
deleted file mode 100644
index 6f9e42aa4cc1..000000000000
--- a/www-apps/dspam-web/dspam-web-3.4.2.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/dspam-web-3.4.2.ebuild,v 1.3 2005/11/05 15:53:55 st_lim Exp $
-
-inherit webapp eutils
-
-MY_PN=${PN/-web/}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Web based administration and user controls for dspam"
-SRC_URI="http://dspam.nuclearelephant.com/sources/${MY_P}.tar.gz"
-
-HOMEPAGE="http://dspam.nuclearelephant.com/"
-LICENSE="GPL-2"
-DEPEND=">=mail-filter/dspam-3.2_rc3
- >=net-www/apache-1.3
- >=dev-lang/perl-5.8.2
- >=dev-perl/GD-2.0
- dev-perl/GD-Graph3d
- dev-perl/GDGraph
- dev-perl/GDTextUtil"
-KEYWORDS="~x86 ~ppc ~amd64"
-S=${WORKDIR}/${MY_P}
-HOMEDIR=/etc/mail/dspam
-IUSE="debug large-domain mysql neural oci8 postgres sqlite sqlite3 virtual-users"
-
-src_compile() {
- local myconf
-
- myconf="${myconf} --enable-long-username"
- use large-domain && myconf="${myconf} --enable-large-scale" ||\
- myconf="${myconf} --enable-domain-scale"
-
- myconf="${myconf} --with-dspam-mode=4755"
- myconf="${myconf} --with-dspam-owner=dspam"
- myconf="${myconf} --with-dspam-group=dspam"
- myconf="${myconf} --sysconfdir=${HOMEDIR}"
- myconf="${myconf} --with-logdir=${LOGDIR}"
- use virtual-users || myconf="${myconf} --with-dspam-home=${HOMEDIR}"
-
- # enables support for debugging (touch /etc/dspam/.debug to turn on)
- # optional: even MORE debugging output, use with extreme caution!
- use debug && myconf="${myconf} --enable-debug --enable-verbose-debug"
-
- # select storage driver
- if use mysql; then
- myconf="${myconf} --with-storage-driver=mysql_drv"
- myconf="${myconf} --with-mysql-includes=/usr/include/mysql"
- myconf="${myconf} --with-mysql-libraries=/usr/lib/mysql"
- myconf="${myconf} --enable-preferences-extension"
-
- if has_version sys-kernel/linux26-headers; then
- myconf="${myconf} --enable-daemon"
- fi
-
- use virtual-users && myconf="${myconf} --enable-virtual-users"
- # an experimental feature available with MySQL and PgSQL backend
- use neural && myconf="${myconf} --enable-neural-networking"
- elif use postgres ; then
- myconf="${myconf} --with-storage-driver=pgsql_drv"
- myconf="${myconf} --with-pgsql-includes=/usr/include/postgresql"
- myconf="${myconf} --with-pgsql-libraries=/usr/lib/postgresql"
- myconf="${myconf} --enable-preferences-extension"
-
- if has_version sys-kernel/linux26-headers; then
- myconf="${myconf} --enable-daemon"
- fi
-
- use virtual-users && myconf="${myconf} --enable-virtual-users"
- # an experimental feature available with MySQL and PgSQL backend
- use neural && myconf="${myconf} --enable-neural-networking"
- elif use oci8 ; then
- myconf="${myconf} --with-storage-driver=ora_drv"
- myconf="${myconf} --with-oracle-home=${ORACLE_HOME}"
- myconf="${myconf} --enable-virtual-users"
-
- # I am in no way a Oracle specialist. If someone knows
- # how to query the version of Oracle, then let me know.
- if (expr ${ORACLE_HOME/*\/} : 10 1>/dev/null 2>&1); then
- myconf="${myconf} --with-oracle-version=10"
- fi
- elif use sqlite3 ; then
- myconf="${myconf} --with-storage-driver=sqlite3_drv"
- myconf="${myconf} --enable-virtual-users"
- elif use sqlite ; then
- myconf="${myconf} --with-storage-driver=sqlite_drv"
- myconf="${myconf} --enable-virtual-users"
- else
- myconf="${myconf} --with-storage-driver=libdb4_drv"
- fi
-
- econf ${myconf} || die
- cd ${S}/cgi
- make
-}
-
-src_install () {
- cd ${S}/cgi
- webapp_src_preinst
-
- sed -e 's,/var/dspam,/etc/mail/dspam,' \
- -e 's,/usr/local,/usr,' \
- -i admin.cgi
- sed -e 's,/var/dspam,/etc/mail/dspam,' \
- -e 's,/usr/local,/usr,' \
- -i dspam.cgi
-
- insinto ${MY_HTDOCSDIR}
- insopts -m644 -o apache -g apache
- doins *.css
- doins *.gif
- doins rgb.txt
- doins default.prefs
- doins admins
- doins configure.pl
-
- newins ${FILESDIR}/htaccess .htaccess
- newins ${FILESDIR}/htpasswd .htpasswd
-
- insopts -m755 -o apache -g apache
- doins *.cgi
-
- for CGI_SCRIPT in admin.cgi admingraph.cgi dspam.cgi graph.cgi; do
- webapp_runbycgibin perl ${MY_HTDOCSDIR}/${CGI_SCRIPT}
- done
-
- dodir ${MY_HTDOCSDIR}/templates
-
- insinto ${MY_HTDOCSDIR}/templates
- doins templates/*.html
-
- #All files must be owned by server
- cd ${D}${MY_HTDOCSDIR}
- for x in `find . -type f -print` ; do
- webapp_serverowned ${MY_HTDOCSDIR}/$x
- done
-
- webapp_src_install
-}
-
-pkg_config () {
- # add apache to the dspam group so the CGIs can access the data
-
- local groups
- groups=`groups apache`
- groups=`echo ${groups} | sed -e 's/ /,/g'`
- usermod -G "${groups},dspam" apache
-}
-
-pkg_postinst () {
- einfo "The CGIs need to be executed as group dspam in order to write"
- einfo "to the dspam data directory. You will need to configure apache"
- einfo "manually to do this. Another option is to add the user apache"
- einfo "to the dspam group. You can do this automatically by running:"
- echo
- einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
- echo
- einfo "This app requires basic auth in order to operate properly."
- einfo "You will need to add dspam users to the .htpasswd file or"
- einfo "configure a different authentication mechanism for the user"
- einfo "accounts."
-}
diff --git a/www-apps/dspam-web/dspam-web-3.4_rc3.ebuild b/www-apps/dspam-web/dspam-web-3.4_rc3.ebuild
deleted file mode 100644
index 5bcd666ff370..000000000000
--- a/www-apps/dspam-web/dspam-web-3.4_rc3.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/dspam-web-3.4_rc3.ebuild,v 1.3 2005/11/05 15:53:55 st_lim Exp $
-
-inherit webapp eutils
-
-MY_PN=${PN/-web/}
-MY_PV=${PV/_rc3/.pr1}
-MY_P=${MY_PN}-${MY_PV}
-
-DESCRIPTION="Web based administration and user controls for dspam"
-SRC_URI="http://dspam.nuclearelephant.com/sources/${MY_P}.tar.gz"
-
-HOMEPAGE="http://dspam.nuclearelephant.com/"
-LICENSE="GPL-2"
-DEPEND=">=mail-filter/dspam-3.2_rc3
- >=net-www/apache-1.3
- >=dev-lang/perl-5.8.2
- >=dev-perl/GD-2.0
- dev-perl/GD-Graph3d
- dev-perl/GDGraph
- dev-perl/GDTextUtil"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="debug large-domain mysql neural oci8 postgres sqlite"
-S=${WORKDIR}/${MY_P}
-HOMEDIR=/etc/mail/dspam
-
-src_compile() {
- local myconf
-
- # these are the default settings
- #myconf="${myconf} --enable-daemon"
- #myconf="${myconf} --enable-nodalcore"
- myconf="${myconf} --enable-homedir"
- myconf="${myconf} --enable-long-username"
- myconf="${myconf} --enable-robinson"
- #myconf="${myconf} --enable-chi-square"
- #myconf="${myconf} --enable-robinson-pvalues"
- use large-domain && myconf="${myconf} --enable-large-scale" ||\
- myconf="${myconf} --enable-domain-scale"
-
- myconf="${myconf} --with-dspam-mode=4755"
- myconf="${myconf} --with-dspam-owner=dspam"
- myconf="${myconf} --with-dspam-group=dspam"
- myconf="${myconf} --with-dspam-home=${HOMEDIR} --sysconfdir=${HOMEDIR}"
- myconf="${myconf} --with-logdir=${LOGDIR}"
-
- use debug && myconf="${myconf} --enable-debug --enable-verbose-debug"
-
- # select storage driver
- if use mysql ; then
- myconf="${myconf} --with-storage-driver=mysql_drv"
- myconf="${myconf} --with-mysql-includes=/usr/include/mysql"
- myconf="${myconf} --with-mysql-libraries=/usr/lib/mysql"
- myconf="${myconf} --with-client-compression"
- myconf="${myconf} --enable-virtual-users"
- myconf="${myconf} --enable-preferences-extension"
-
- # an experimental feature available with MySQL and PgSQL backend
- if use neural ; then
- myconf="${myconf} --enable-neural-networking"
- fi
- elif use postgres ; then
- myconf="${myconf} --with-storage-driver=pgsql_drv"
- myconf="${myconf} --with-pgsql-includes=/usr/include/postgresql"
- myconf="${myconf} --with-pgsql-libraries=/usr/lib/postgresql"
- myconf="${myconf} --enable-virtual-users"
- myconf="${myconf} --enable-preferences-extension"
-
- # an experimental feature available with MySQL and PgSQL backend
- if use neural ; then
- myconf="${myconf} --enable-neural-networking"
- fi
- elif use oci8 ; then
- myconf="${myconf} --with-storage-driver=ora_drv"
- myconf="${myconf} --with-oracle-home=${ORACLE_HOME}"
- myconf="${myconf} --enable-virtual-users"
- myconf="${myconf} --enable-preferences-extension"
-
- # I am in no way a Oracle specialist. If someone knows
- # how to query the version of Oracle, then let me know.
- if (expr ${ORACLE_HOME/*\/} : 10 1>/dev/null 2>&1)
- then
- --with-oracle-version=MAJOR
- myconf="${myconf} --with-oracle-version=10"
- fi
- elif use sqlite ; then
- myconf="${myconf} --with-storage-driver=sqlite_drv"
- myconf="${myconf} --enable-virtual-users"
- myconf="${myconf} --enable-preferences-extension"
-
- else
- myconf="${myconf} --with-storage-driver=libdb4_drv"
- fi
-
- econf ${myconf} || die
- cd ${S}/cgi
- make
-}
-
-src_install () {
- cd ${S}/cgi
- webapp_src_preinst
-
- sed -e 's,/var/dspam,/etc/mail/dspam,' \
- -e 's,/usr/local,/usr,' \
- -i admin.cgi
- sed -e 's,/var/dspam,/etc/mail/dspam,' \
- -e 's,/usr/local,/usr,' \
- -i dspam.cgi
-
- insinto ${MY_HTDOCSDIR}
- insopts -m644 -o apache -g apache
- doins *.css
- doins *.gif
- doins rgb.txt
- doins default.prefs
- doins admins
- doins configure.pl
-
- newins ${FILESDIR}/htaccess .htaccess
- newins ${FILESDIR}/htpasswd .htpasswd
-
- insopts -m755 -o apache -g apache
- doins *.cgi
-
- for CGI_SCRIPT in admin.cgi admingraph.cgi dspam.cgi graph.cgi; do
- webapp_runbycgibin perl ${MY_HTDOCSDIR}/${CGI_SCRIPT}
- done
-
- dodir ${MY_HTDOCSDIR}/templates
-
- insinto ${MY_HTDOCSDIR}/templates
- doins templates/*.html
-
- #All files must be owned by server
- cd ${D}${MY_HTDOCSDIR}
- for x in `find . -type f -print` ; do
- webapp_serverowned ${MY_HTDOCSDIR}/$x
- done
-
- webapp_src_install
-}
-
-pkg_config () {
- # add apache to the dspam group so the CGIs can access the data
-
- local groups
- groups=`groups apache`
- groups=`echo ${groups} | sed -e 's/ /,/g'`
- usermod -G "${groups},dspam" apache
-}
-
-pkg_postinst () {
- einfo "The CGIs need to be executed as group dspam in order to write"
- einfo "to the dspam data directory. You will need to configure apache"
- einfo "manually to do this. Another option is to add the user apache"
- einfo "to the dspam group. You can do this automatically by running:"
- echo
- einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
- echo
- einfo "This app requires basic auth in order to operate properly."
- einfo "You will need to add dspam users to the .htpasswd file or"
- einfo "configure a different authentication mechanism for the user"
- einfo "accounts."
-}
diff --git a/www-apps/dspam-web/dspam-web-3.6_rc3.ebuild b/www-apps/dspam-web/dspam-web-3.6_rc3.ebuild
deleted file mode 100644
index e48a68249320..000000000000
--- a/www-apps/dspam-web/dspam-web-3.6_rc3.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dspam-web/dspam-web-3.6_rc3.ebuild,v 1.1 2005/11/05 15:53:55 st_lim Exp $
-
-inherit webapp eutils
-
-MY_PN=${PN/-web/}
-MY_PV=${PV/_/.}
-MY_P=${MY_PN}-${MY_PV}
-
-DESCRIPTION="Web based administration and user controls for dspam"
-SRC_URI="http://dspam.nuclearelephant.com/sources/${MY_P}.tar.gz"
-
-HOMEPAGE="http://dspam.nuclearelephant.com/"
-LICENSE="GPL-2"
-DEPEND=">=mail-filter/dspam-${PV}
- >=net-www/apache-1.3
- >=dev-lang/perl-5.8.2
- >=dev-perl/GD-2.0
- dev-perl/GD-Graph3d
- dev-perl/GDGraph
- dev-perl/GDTextUtil"
-KEYWORDS="~x86 ~ppc ~amd64"
-S=${WORKDIR}/${MY_P}
-IUSE="debug large-domain mysql neural oci8 postgres sqlite sqlite3 virtual-users"
-
-# some FHS-like structure
-HOMEDIR="/var/spool/dspam"
-CONFDIR="/etc/mail/dspam"
-LOGDIR="/var/log/dspam"
-
-src_compile() {
- local myconf
-
- myconf="${myconf} --enable-long-username"
- myconf="${myconf} --with-delivery-agent=/usr/bin/procmail"
- use large-domain && myconf="${myconf} --enable-large-scale" ||\
- myconf="${myconf} --enable-domain-scale"
-
- myconf="${myconf} --with-dspam-home=${HOMEDIR}"
- myconf="${myconf} --sysconfdir=${CONFDIR}"
- use virtual-users || myconf="${myconf} --enable-homedir"
-
- # enables support for debugging (touch /etc/dspam/.debug to turn on)
- # optional: even MORE debugging output, use with extreme caution!
- use debug && myconf="${myconf} --enable-debug --enable-verbose-debug"
-
- # select storage driver
- if use sqlite ; then
- myconf="${myconf} --with-storage-driver=sqlite_drv"
- myconf="${myconf} --enable-virtual-users"
- elif use mysql; then
- myconf="${myconf} --with-storage-driver=mysql_drv"
- myconf="${myconf} --with-mysql-includes=/usr/include/mysql"
- myconf="${myconf} --with-mysql-libraries=/usr/lib/mysql"
- myconf="${myconf} --enable-preferences-extension"
-
- if has_version ">sys-kernel/linux-headers-2.6"; then
- myconf="${myconf} --enable-daemon"
- fi
-
- use virtual-users && myconf="${myconf} --enable-virtual-users"
- # an experimental feature available with MySQL and PgSQL backend
- use neural && myconf="${myconf} --enable-neural-networking"
- elif use postgres ; then
- myconf="${myconf} --with-storage-driver=pgsql_drv"
- myconf="${myconf} --with-pgsql-includes=/usr/include/postgresql"
- myconf="${myconf} --with-pgsql-libraries=/usr/lib/postgresql"
- myconf="${myconf} --enable-preferences-extension"
-
- if has_version ">sys-kernel/linux-headers-2.6"; then
- myconf="${myconf} --enable-daemon"
- fi
-
- use virtual-users && myconf="${myconf} --enable-virtual-users"
- # an experimental feature available with MySQL and PgSQL backend
- use neural && myconf="${myconf} --enable-neural-networking"
- elif use oci8 ; then
- myconf="${myconf} --with-storage-driver=ora_drv"
- myconf="${myconf} --with-oracle-home=${ORACLE_HOME}"
- myconf="${myconf} --enable-virtual-users"
-
- # I am in no way a Oracle specialist. If someone knows
- # how to query the version of Oracle, then let me know.
- if (expr ${ORACLE_HOME/*\/} : 10 1>/dev/null 2>&1); then
- myconf="${myconf} --with-oracle-version=10"
- fi
- else
- myconf="${myconf} --with-storage-driver=libdb4_drv"
- fi
-
- econf ${myconf} || die
- cd ${S}/webui
- make
-}
-
-src_install () {
- cd ${S}/webui
- webapp_src_preinst
-
- sed -e 's,/var/dspam,/etc/mail/dspam,' \
- -e 's,/usr/local,/usr,' \
- -i ${S}/webui/cgi-bin/admin.cgi
- sed -e 's,/var/dspam,/etc/mail/dspam,' \
- -e 's,/usr/local,/usr,' \
- -i ${S}/webui/cgi-bin/dspam.cgi
-
- insinto ${MY_HTDOCSDIR}
- insopts -m644 -o apache -g apache
- doins *.css
- doins *.gif
- doins rgb.txt
- doins default.prefs
- doins admins
- doins configure.pl
-
- newins ${FILESDIR}/htaccess .htaccess
- newins ${FILESDIR}/htpasswd .htpasswd
-
- insopts -m755 -o apache -g apache
- doins ${S}/webui/cgi-bin/*.cgi
-
- for CGI_SCRIPT in admin.cgi admingraph.cgi dspam.cgi graph.cgi; do
- webapp_runbycgibin perl ${MY_HTDOCSDIR}/${CGI_SCRIPT}
- done
-
- dodir ${MY_HTDOCSDIR}/templates
-
- insinto ${MY_HTDOCSDIR}/templates
- doins templates/*.html
-
- #All files must be owned by server
- cd ${D}${MY_HTDOCSDIR}
- for x in `find . -type f -print` ; do
- webapp_serverowned ${MY_HTDOCSDIR}/$x
- done
-
- webapp_src_install
-}
-
-pkg_config () {
- # add apache to the dspam group so the CGIs can access the data
-
- local groups
- groups=`groups apache`
- groups=`echo ${groups} | sed -e 's/ /,/g'`
- usermod -G "${groups},dspam" apache
-}
-
-pkg_postinst () {
- einfo "The CGIs need to be executed as group dspam in order to write"
- einfo "to the dspam data directory. You will need to configure apache"
- einfo "manually to do this. Another option is to add the user apache"
- einfo "to the dspam group. You can do this automatically by running:"
- echo
- einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
- echo
- einfo "This app requires basic auth in order to operate properly."
- einfo "You will need to add dspam users to the .htpasswd file or"
- einfo "configure a different authentication mechanism for the user"
- einfo "accounts."
-}
diff --git a/www-apps/dspam-web/files/digest-dspam-web-3.4.0 b/www-apps/dspam-web/files/digest-dspam-web-3.4.0
deleted file mode 100644
index 4f34e479640d..000000000000
--- a/www-apps/dspam-web/files/digest-dspam-web-3.4.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 eafb06cc4beda7686b77720e9841537a dspam-3.4.0.tar.gz 687132
diff --git a/www-apps/dspam-web/files/digest-dspam-web-3.4.1 b/www-apps/dspam-web/files/digest-dspam-web-3.4.1
deleted file mode 100644
index 89d0c29f976a..000000000000
--- a/www-apps/dspam-web/files/digest-dspam-web-3.4.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 46764fdcf5db676ac784e7a633e19da3 dspam-3.4.1.tar.gz 692977
diff --git a/www-apps/dspam-web/files/digest-dspam-web-3.4.2 b/www-apps/dspam-web/files/digest-dspam-web-3.4.2
deleted file mode 100644
index 2ff3333a2125..000000000000
--- a/www-apps/dspam-web/files/digest-dspam-web-3.4.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0c3cbdf699b8a89e92f846332bf4cb54 dspam-3.4.2.tar.gz 697028
diff --git a/www-apps/dspam-web/files/digest-dspam-web-3.4_rc3 b/www-apps/dspam-web/files/digest-dspam-web-3.4_rc3
deleted file mode 100644
index 1c2ddc5284e3..000000000000
--- a/www-apps/dspam-web/files/digest-dspam-web-3.4_rc3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 6fd75bee56adbff457ef9bae7dcf6bc8 dspam-3.4.pr1.tar.gz 684032
diff --git a/www-apps/dspam-web/files/digest-dspam-web-3.6_rc3 b/www-apps/dspam-web/files/digest-dspam-web-3.6_rc3
deleted file mode 100644
index a15fddbec5b2..000000000000
--- a/www-apps/dspam-web/files/digest-dspam-web-3.6_rc3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 603698ca748a8e5c88097c14008352bd dspam-3.6.rc3.tar.gz 737148