summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-06-11 19:10:48 +0000
committerAlex Legler <a3li@gentoo.org>2009-06-11 19:10:48 +0000
commita2255bcb47f6019d044c9e07ffa23afd5bc0c8b4 (patch)
tree357a9704c53650c7fc1ae620337cb884ee8367e0 /www-apps
parent Non-Maintainer commit: Version bump to fix security bugs 261180, 258665, 268... (diff)
downloadgentoo-2-a2255bcb47f6019d044c9e07ffa23afd5bc0c8b4.tar.gz
gentoo-2-a2255bcb47f6019d044c9e07ffa23afd5bc0c8b4.tar.bz2
gentoo-2-a2255bcb47f6019d044c9e07ffa23afd5bc0c8b4.zip
Non-maintainer commit: Version bump, Security bugs #262280 and #264570.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/tikiwiki/ChangeLog9
-rw-r--r--www-apps/tikiwiki/tikiwiki-2.4.ebuild68
2 files changed, 75 insertions, 2 deletions
diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index b00a931d3c74..2e10420a178f 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/tikiwiki
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.64 2008/10/31 06:11:56 wrobel Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.65 2009/06/11 19:10:48 a3li Exp $
+
+*tikiwiki-2.4 (11 Jun 2009)
+
+ 11 Jun 2009; Alex Legler <a3li@gentoo.org> +tikiwiki-2.4.ebuild:
+ Non-maintainer commit: Version bump for security bugs 262280 and 264570.
31 Oct 2008; Gunnar Wrobel <wrobel@gentoo.org> -tikiwiki-2.0.ebuild:
Removed vulnerable tikiwiki-2.0 (#243854).
diff --git a/www-apps/tikiwiki/tikiwiki-2.4.ebuild b/www-apps/tikiwiki/tikiwiki-2.4.ebuild
new file mode 100644
index 000000000000..b9e0bac8adf4
--- /dev/null
+++ b/www-apps/tikiwiki/tikiwiki-2.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-2.4.ebuild,v 1.1 2009/06/11 19:10:48 a3li Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Full-featured Web Content Management System using PHP and Smarty Templates"
+HOMEPAGE="http://tikiwiki.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+IUSE="mysql postgres graphviz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="graphviz? ( media-gfx/graphviz )"
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup () {
+ webapp_pkg_setup
+
+ local my_flags=
+ use mysql && my_flags="${my_flags} mysql"
+ use postgres && my_flags="${my_flags} postgres"
+
+ require_php_with_use ${my_flags}
+}
+
+src_install() {
+ webapp_src_preinst
+
+ # Remove the execute permission from the setup.sh script
+ # and rename it. Its actions have been incorporated here.
+ chmod a-x setup.sh
+ mv setup.sh setup.sh.done
+
+ dodoc changelog.txt copyright.txt doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+ rm -rf changelog.txt copyright.txt doc/ INSTALL license.txt README
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local DIR DIRENTRY
+ local DIRS="backups db dump files img/trackers img/wiki
+ img/wiki_up modules/cache temp
+ templates_c templates styles maps whelp mods
+ lib/Galaxia/processes"
+
+ # Recursively set server ownership to allow server to write
+ # This is the rough equivalent of the setup.sh script
+ # provided in the distribution.
+ # Note: Cannot use xargs or find -exec here because
+ # these don't work with shell functions.
+
+ webapp_serverowned "${MY_HTDOCSDIR}"
+ webapp_serverowned "${MY_HTDOCSDIR}"/tiki-install.php
+
+ # ensure that directories exist, some don't.
+ # (part of original setup.sh)
+ for DIR in ${DIRS}; do
+ dodir "${MY_HTDOCSDIR}/${DIR}"
+ webapp_serverowned -R "${MY_HTDOCSDIR}/${DIR}"
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}