summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-01-24 16:04:41 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-01-24 16:04:41 +0000
commitbcd7fc222993dfbdd934d9ea3728ab1c98089680 (patch)
treec68b0e55459b37ce1b442b8383ac03b1ed177878 /www-apps
parentvarious upstream fixes that take care of 9 upstream bugs (diff)
downloadgentoo-2-bcd7fc222993dfbdd934d9ea3728ab1c98089680.tar.gz
gentoo-2-bcd7fc222993dfbdd934d9ea3728ab1c98089680.tar.bz2
gentoo-2-bcd7fc222993dfbdd934d9ea3728ab1c98089680.zip
upstream fix for music playlist
(Portage version: 2.1.4)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mythweb/ChangeLog7
-rw-r--r--www-apps/mythweb/files/digest-mythweb-0.20.2_p154880
-rw-r--r--www-apps/mythweb/mythweb-0.20.2_p15488.ebuild49
3 files changed, 55 insertions, 1 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index 0c3ff7156efc..70ac4f712b66 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/mythweb
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.52 2008/01/15 16:34:31 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.53 2008/01/24 16:04:40 cardoe Exp $
+
+*mythweb-0.20.2_p15488 (24 Jan 2008)
+
+ 24 Jan 2008; Doug Klima <cardoe@gentoo.org> +mythweb-0.20.2_p15488.ebuild:
+ upstream fix for music playlist
*mythweb-0.21_pre15448 (15 Jan 2008)
diff --git a/www-apps/mythweb/files/digest-mythweb-0.20.2_p15488 b/www-apps/mythweb/files/digest-mythweb-0.20.2_p15488
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/www-apps/mythweb/files/digest-mythweb-0.20.2_p15488
diff --git a/www-apps/mythweb/mythweb-0.20.2_p15488.ebuild b/www-apps/mythweb/mythweb-0.20.2_p15488.ebuild
new file mode 100644
index 000000000000..9626aa792c0b
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.20.2_p15488.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.20.2_p15488.ebuild,v 1.1 2008/01/24 16:04:40 cardoe Exp $
+
+ESVN_PROJECT="mythplugins"
+
+inherit mythtv webapp depend.php subversion
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-perl/DBI
+ dev-perl/DBD-mysql"
+
+need_php5_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use session mysql pcre posix
+}
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd "${S}/mythweb"
+ dodoc README TODO
+
+ dodir "${MY_HTDOCSDIR}"/data
+
+ cp -R [[:lower:]]* .htaccess "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/data
+ webapp_serverowned "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-0.20.txt
+
+ webapp_src_install
+}