summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-10-21 06:57:13 +0000
committerPeter Volkov <pva@gentoo.org>2008-10-21 06:57:13 +0000
commitd1a2b47d6a76cd2d70479ce7c16664aa1f66f1bb (patch)
tree22d5a98870a63f040e43da3064808d1043cb5e6d /www-apps
parentRemove dev-perl/FileHandle-Rollback dependency. It uses FileHandle (diff)
downloadgentoo-2-d1a2b47d6a76cd2d70479ce7c16664aa1f66f1bb.tar.gz
gentoo-2-d1a2b47d6a76cd2d70479ce7c16664aa1f66f1bb.tar.bz2
gentoo-2-d1a2b47d6a76cd2d70479ce7c16664aa1f66f1bb.zip
Version bump, bug #242712, thank Johny for report.
(Portage version: 2.2_rc12/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gallery/ChangeLog8
-rw-r--r--www-apps/gallery/gallery-2.3.ebuild71
-rw-r--r--www-apps/gallery/metadata.xml10
3 files changed, 88 insertions, 1 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index 907d4028c886..d943304a301b 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/gallery
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.161 2008/10/11 19:01:31 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.162 2008/10/21 06:57:13 pva Exp $
+
+*gallery-2.3 (21 Oct 2008)
+
+ 21 Oct 2008; Peter Volkov <pva@gentoo.org> metadata.xml,
+ +gallery-2.3.ebuild:
+ Version bump, bug #242712, thank Johny for report.
11 Oct 2008; Gunnar Wrobel <wrobel@gentoo.org> -gallery-1.5.8.ebuild,
-gallery-2.2.5.ebuild:
diff --git a/www-apps/gallery/gallery-2.3.ebuild b/www-apps/gallery/gallery-2.3.ebuild
new file mode 100644
index 000000000000..344578650fab
--- /dev/null
+++ b/www-apps/gallery/gallery-2.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.3.ebuild,v 1.1 2008/10/21 06:57:13 pva Exp $
+
+inherit webapp eutils depend.php confutils
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ffmpeg gd imagemagick mysql netpbm postgres raw unzip zip"
+
+RDEPEND="raw? ( >=media-gfx/dcraw-8.03 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20051216 )
+ imagemagick? ( >media-gfx/imagemagick-6.2.4 )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )"
+
+S=${WORKDIR}/${PN}2
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ confutils_require_any gd imagemagick netpbm
+ confutils_require_any mysql postgres
+
+ local php_flags="pcre session"
+ use mysql && php_flags="${php_flags} mysql"
+ use postgres && php_flags="${php_flags} postgres"
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${php_flags} || \
+ ( use gd && ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ) ; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following USE flags enabled:"
+ eerror
+ eerror "${php_flags}"
+ eerror
+ use gd && eerror "as well as with either gd or gd-external USE flag enabled."
+ die "Re-install ${PHP_PKG}."
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dohtml README.html
+ rm README.html LICENSE
+ sed -i -e "/^LICENSE\>/d" -e "/^README\.html\>/d" MANIFEST
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en2.txt"
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "You are strongly encouraged to back up your database"
+ elog "and the g2data directory, as upgrading to 2.2 will make"
+ elog "irreversible changes to both."
+ elog
+ elog "g2data dir: cp -Rf /path/to/g2data/ /path/to/backup"
+ elog "mysql: mysqldump --opt -u username -h hostname -p database > /path/to/backup.sql"
+ elog "postgres: pg_dump -h hostname --format=t database > /path/to/backup.sql"
+ webapp_pkg_postinst
+}
diff --git a/www-apps/gallery/metadata.xml b/www-apps/gallery/metadata.xml
index 596c5bfb47ad..8d4d34b3532f 100644
--- a/www-apps/gallery/metadata.xml
+++ b/www-apps/gallery/metadata.xml
@@ -9,4 +9,14 @@
<flag name='zip'>Add <pkg>app-arch/zip</pkg> for the zip download
module</flag>
</use>
+ <longdescription>
+ Gallery is a web based software product that lets you manage your photos on
+ your own website. With Gallery you can easily create and maintain albums of
+ photos via an intuitive interface. Photo management includes automatic
+ thumbnail creation, image resizing, rotation, ordering, captioning,
+ searching and more. Albums and photos can have view, edit, delete and other
+ permissions per individual authenticated user for an additional level of
+ privacy. It's great for communities - give accounts to your friends and
+ family and let them upload and manage their own photos on your website!
+ </longdescription>
</pkgmetadata>