summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-12-02 21:10:31 +0000
committerTim Harder <radhermit@gentoo.org>2013-12-02 21:10:31 +0000
commitdb78d59f80a4250321993ab224afc3add5d5605a (patch)
tree131d65b3014ac4d51b451e23a5ab80992384adf4 /www-apps
parentx86 stable, bug #487870 (diff)
downloadgentoo-2-db78d59f80a4250321993ab224afc3add5d5605a.tar.gz
gentoo-2-db78d59f80a4250321993ab224afc3add5d5605a.tar.bz2
gentoo-2-db78d59f80a4250321993ab224afc3add5d5605a.zip
Version bump (bug #487586).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/phpBB/ChangeLog9
-rw-r--r--www-apps/phpBB/phpBB-3.0.12.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/www-apps/phpBB/ChangeLog b/www-apps/phpBB/ChangeLog
index 7397cfa2fd3f..936897183358 100644
--- a/www-apps/phpBB/ChangeLog
+++ b/www-apps/phpBB/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/phpBB
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/ChangeLog,v 1.47 2012/12/16 13:53:11 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/ChangeLog,v 1.48 2013/12/02 21:10:31 radhermit Exp $
+
+*phpBB-3.0.12 (02 Dec 2013)
+
+ 02 Dec 2013; Tim Harder <radhermit@gentoo.org> +phpBB-3.0.12.ebuild:
+ Version bump (bug #487586).
16 Dec 2012; Agostino Sarubbo <ago@gentoo.org> phpBB-3.0.11.ebuild:
Stable for x86, wrt bug #441542
diff --git a/www-apps/phpBB/phpBB-3.0.12.ebuild b/www-apps/phpBB/phpBB-3.0.12.ebuild
new file mode 100644
index 000000000000..8f162c8506c5
--- /dev/null
+++ b/www-apps/phpBB/phpBB-3.0.12.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpBB/phpBB-3.0.12.ebuild,v 1.1 2013/12/02 21:10:31 radhermit Exp $
+
+EAPI=5
+
+inherit webapp
+
+DESCRIPTION="phpBB is an open-source bulletin board package"
+HOMEPAGE="http://www.phpbb.com/"
+SRC_URI="http://download.phpbb.com/pub/release/${PV:0:3}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="virtual/httpd-php"
+
+need_httpd_cgi
+
+S=${WORKDIR}/${PN}3
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/*
+ rm -rf docs
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/cache
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/images/avatars/upload
+ webapp_serverowned "${MY_HTDOCSDIR}"/store
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}