summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-06-04 13:36:01 +0000
committerBen de Groot <yngwin@gentoo.org>2008-06-04 13:36:01 +0000
commite7ed9f503f8dc31c2316b8fd1037a44b924f957e (patch)
tree0d20123526bc9c5213950d05015180315143fe81 /www-client/arora/arora-0.2_p20080604.ebuild
parentp.masking www-client/arora (diff)
downloadgentoo-2-e7ed9f503f8dc31c2316b8fd1037a44b924f957e.tar.gz
gentoo-2-e7ed9f503f8dc31c2316b8fd1037a44b924f957e.tar.bz2
gentoo-2-e7ed9f503f8dc31c2316b8fd1037a44b924f957e.zip
Adding www-client/arora git snapshot, for people who want to try it out.
(Portage version: 2.1.5.3)
Diffstat (limited to 'www-client/arora/arora-0.2_p20080604.ebuild')
-rw-r--r--www-client/arora/arora-0.2_p20080604.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/www-client/arora/arora-0.2_p20080604.ebuild b/www-client/arora/arora-0.2_p20080604.ebuild
new file mode 100644
index 000000000000..4a9096c1cc85
--- /dev/null
+++ b/www-client/arora/arora-0.2_p20080604.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/arora/arora-0.2_p20080604.ebuild,v 1.1 2008/06/04 13:36:01 yngwin Exp $
+
+EAPI=1
+inherit eutils qt4
+
+DESCRIPTION="A cross-platform Qt4 WebKit browser"
+HOMEPAGE="http://arora.googlecode.com/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/qt-webkit-4.4.0:4"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ eqmake4 || die "qmake failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin arora
+ newicon src/data/browser.svg arora.svg
+ make_desktop_entry arora Arora arora.svg
+}