summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-03-29 14:22:43 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-03-29 14:22:43 +0000
commitc8a85ec8aaba3a8ae17c0e0b8d43e34824159b38 (patch)
treec6f527118c637d1a12bf5db97aeec5b18e2d8ad3 /www-client/chromium
parentVersion bump by Karl Hiramoto (bug #342461). Disable implicit RDEPEND. (diff)
downloadgentoo-2-c8a85ec8aaba3a8ae17c0e0b8d43e34824159b38.tar.gz
gentoo-2-c8a85ec8aaba3a8ae17c0e0b8d43e34824159b38.tar.bz2
gentoo-2-c8a85ec8aaba3a8ae17c0e0b8d43e34824159b38.zip
Version bump for beta channel release. Restore check for PaX (bug #301880), handle more MIME types for GNOME (bug #360797 by pacho). Remove old.
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/ChangeLog11
-rw-r--r--www-client/chromium/chromium-11.0.696.25.ebuild (renamed from www-client/chromium/chromium-11.0.696.14.ebuild)39
-rw-r--r--www-client/chromium/chromium-12.0.712.0.ebuild12
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild14
4 files changed, 41 insertions, 35 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index c77317f24f4f..7b646f37f0b7 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.320 2011/03/26 09:31:15 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.321 2011/03/29 14:22:43 phajdan.jr Exp $
+
+*chromium-11.0.696.25 (29 Mar 2011)
+
+ 29 Mar 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ -chromium-11.0.696.14.ebuild, +chromium-11.0.696.25.ebuild,
+ chromium-12.0.712.0.ebuild, chromium-9999-r1.ebuild:
+ Version bump for beta channel release. Restore check for PaX (bug
+ #301880), handle more MIME types for GNOME (bug #360797 by pacho). Remove
+ old.
26 Mar 2011; Christian Faulhammer <fauli@gentoo.org>
chromium-10.0.648.204.ebuild:
diff --git a/www-client/chromium/chromium-11.0.696.14.ebuild b/www-client/chromium/chromium-11.0.696.25.ebuild
index 61a0cdf92842..55b880d4f131 100644
--- a/www-client/chromium/chromium-11.0.696.14.ebuild
+++ b/www-client/chromium/chromium-11.0.696.25.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-11.0.696.14.ebuild,v 1.1 2011/03/18 14:33:05 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-11.0.696.25.ebuild,v 1.1 2011/03/29 14:22:43 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
-V8_DEPEND="3.1.8.2"
inherit eutils fdo-mime flag-o-matic gnome2-utils multilib pax-utils \
portability python toolchain-funcs versionator virtualx
@@ -19,7 +18,6 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE="cups gnome gnome-keyring"
RDEPEND="app-arch/bzip2
- >=dev-lang/v8-${V8_DEPEND}
dev-libs/dbus-glib
>=dev-libs/icu-4.4.1
>=dev-libs/libevent-1.4.13
@@ -43,7 +41,6 @@ RDEPEND="app-arch/bzip2
x11-libs/libXtst"
DEPEND="${RDEPEND}
dev-lang/perl
- >=dev-util/chromium-tools-0.1.4
>=dev-util/gperf-3.0.3
>=dev-util/pkgconfig-0.23
sys-devel/flex
@@ -135,29 +132,6 @@ src_prepare() {
\! -path 'third_party/zlib/contrib/minizip/*' \
-delete || die
- # Check for the maintainer to ensure that the dependencies
- # are up-to-date.
- local v8_bundled="$(v8-extract-version v8/src/version.cc)"
- if [ "${V8_DEPEND}" != "${v8_bundled}" ]; then
- die "update v8 dependency to ${v8_bundled}"
- fi
-
- # Remove bundled v8.
- find v8 -type f \! -iname '*.gyp*' -delete || die
-
- # Disable experimental extensions incompatible with system-provided V8,
- # bug #354343.
- cp "${FILESDIR}/experimental.gyp" "v8/src/extensions/experimental" || die
- sed -e 's/ENABLE_JAVASCRIPT_I18N_API=1/ENABLE_JAVASCRIPT_I18N_API=0/g' \
- -i build/features_override.gypi || die
-
- # The implementation files include v8 headers with full path,
- # like #include "v8/include/v8.h". Make sure the system headers
- # will be used.
- # TODO: find a solution that can be upstreamed.
- rmdir v8/include || die
- ln -s /usr/include v8/include || die
-
# Make sure the build system will use the right python, bug #344367.
# Only convert directories that need it, to save time.
python_convert_shebangs -q -r 2 build tools
@@ -184,7 +158,6 @@ src_configure() {
-Duse_system_libpng=1
-Duse_system_libxml=1
-Duse_system_speex=1
- -Duse_system_v8=1
-Duse_system_vpx=1
-Duse_system_xdg_utils=1
-Duse_system_zlib=1"
@@ -201,6 +174,12 @@ src_configure() {
-Dlinux_sandbox_path=${CHROMIUM_HOME}/chrome_sandbox
-Dlinux_sandbox_chrome_path=${CHROMIUM_HOME}/chrome"
+ if host-is-pax; then
+ # Prevent the build from failing (bug #301880). The performance
+ # difference is very small.
+ myconf+=" -Dv8_use_snapshot=0"
+ fi
+
# Our system ffmpeg should support more codecs than the bundled one
# for Chromium.
myconf+=" -Dproprietary_codecs=1"
@@ -294,8 +273,10 @@ src_install() {
newins chrome/app/theme/chromium/product_logo_${SIZE}.png \
chromium-browser.png || die
done
+ local mime_types="text/html;text/xml;application/xhtml+xml;"
+ mime_types+="x-scheme-handler/http;x-scheme-handler/https;" # bug #360797
make_desktop_entry chromium-browser "Chromium" chromium-browser \
- "Network;WebBrowser" "MimeType=text/html;text/xml;application/xhtml+xml;"
+ "Network;WebBrowser" "MimeType=${mime_types}"
sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop || die
# Install GNOME default application entry (bug #303100).
diff --git a/www-client/chromium/chromium-12.0.712.0.ebuild b/www-client/chromium/chromium-12.0.712.0.ebuild
index b89cecc7c3bc..27e4551b6d5e 100644
--- a/www-client/chromium/chromium-12.0.712.0.ebuild
+++ b/www-client/chromium/chromium-12.0.712.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-12.0.712.0.ebuild,v 1.1 2011/03/25 10:44:53 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-12.0.712.0.ebuild,v 1.2 2011/03/29 14:22:43 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -175,6 +175,12 @@ src_configure() {
-Dlinux_sandbox_path=${CHROMIUM_HOME}/chrome_sandbox
-Dlinux_sandbox_chrome_path=${CHROMIUM_HOME}/chrome"
+ if host-is-pax; then
+ # Prevent the build from failing (bug #301880). The performance
+ # difference is very small.
+ myconf+=" -Dv8_use_snapshot=0"
+ fi
+
# Our system ffmpeg should support more codecs than the bundled one
# for Chromium.
myconf+=" -Dproprietary_codecs=1"
@@ -277,8 +283,10 @@ src_install() {
newins chrome/app/theme/chromium/product_logo_${SIZE}.png \
chromium-browser.png || die
done
+ local mime_types="text/html;text/xml;application/xhtml+xml;"
+ mime_types+="x-scheme-handler/http;x-scheme-handler/https;" # bug #360797
make_desktop_entry chromium-browser "Chromium" chromium-browser \
- "Network;WebBrowser" "MimeType=text/html;text/xml;application/xhtml+xml;"
+ "Network;WebBrowser" "MimeType=${mime_types}"
sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop || die
# Install GNOME default application entry (bug #303100).
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index 4453634a1b16..7bf87e6bd07f 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.10 2011/03/25 10:44:53 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.11 2011/03/29 14:22:43 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -222,6 +222,12 @@ src_configure() {
-Dlinux_sandbox_path=${CHROMIUM_HOME}/chrome_sandbox
-Dlinux_sandbox_chrome_path=${CHROMIUM_HOME}/chrome"
+ if host-is-pax; then
+ # Prevent the build from failing (bug #301880). The performance
+ # difference is very small.
+ myconf+=" -Dv8_use_snapshot=0"
+ fi
+
# Our system ffmpeg should support more codecs than the bundled one
# for Chromium.
myconf+=" -Dproprietary_codecs=1"
@@ -330,8 +336,10 @@ src_install() {
newins chrome/app/theme/chromium/product_logo_${SIZE}.png \
chromium-browser${SUFFIX}.png || die
done
- make_desktop_entry chromium-browser${SUFFIX} "Chromium ${SLOT}" chromium-browser${SUFFIX} \
- "Network;WebBrowser" "MimeType=text/html;text/xml;application/xhtml+xml;"
+ local mime_types="text/html;text/xml;application/xhtml+xml;"
+ mime_types+="x-scheme-handler/http;x-scheme-handler/https;" # bug #360797
+ make_desktop_entry chromium-browser "Chromium" chromium-browser \
+ "Network;WebBrowser" "MimeType=${mime_types}"
sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop || die
# Install GNOME default application entry (bug #303100).