summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-04-05 08:38:50 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-04-05 08:38:50 +0000
commitd2d83953c72025489c4cc3ce2af636d82d50268c (patch)
treebb26167a07346bbfa59d444f7460d573d712e41d /www-client/chromium
parentVaxlib is deprecated (diff)
downloadgentoo-2-d2d83953c72025489c4cc3ce2af636d82d50268c.tar.gz
gentoo-2-d2d83953c72025489c4cc3ce2af636d82d50268c.tar.bz2
gentoo-2-d2d83953c72025489c4cc3ce2af636d82d50268c.zip
Also run net_unittests in src_test (known issues: bug #361885, bug #361939). Add optional dependency on Kerberos for HTTP authentication.
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-12.0.712.0-r1.ebuild23
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild23
-rw-r--r--www-client/chromium/files/chromium-gssapi-heimdal-r0.patch10
4 files changed, 53 insertions, 11 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 32d1318d71c0..dcc397f68aac 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.325 2011/04/03 16:51:10 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.326 2011/04/05 08:38:50 phajdan.jr Exp $
+
+ 05 Apr 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +files/chromium-gssapi-heimdal-r0.patch, chromium-12.0.712.0-r1.ebuild,
+ chromium-9999-r1.ebuild:
+ Also run net_unittests in src_test (known issues: bug #361885, bug
+ #361939). Add optional dependency on Kerberos for HTTP authentication.
*chromium-12.0.712.0-r1 (03 Apr 2011)
diff --git a/www-client/chromium/chromium-12.0.712.0-r1.ebuild b/www-client/chromium/chromium-12.0.712.0-r1.ebuild
index 3512059ce47e..f8943355a284 100644
--- a/www-client/chromium/chromium-12.0.712.0-r1.ebuild
+++ b/www-client/chromium/chromium-12.0.712.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-12.0.712.0-r1.ebuild,v 1.1 2011/04/03 16:51:10 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-12.0.712.0-r1.ebuild,v 1.2 2011/04/05 08:38:50 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -15,7 +15,7 @@ SRC_URI="http://build.chromium.org/official/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="cups gnome gnome-keyring"
+IUSE="cups gnome gnome-keyring kerberos"
RDEPEND="app-arch/bzip2
dev-libs/dbus-glib
@@ -44,8 +44,10 @@ DEPEND="${RDEPEND}
>=dev-util/gperf-3.0.3
>=dev-util/pkgconfig-0.23
sys-devel/flex
- >=sys-devel/make-3.81-r2"
+ >=sys-devel/make-3.81-r2
+ test? ( dev-python/simplejson dev-python/tlslite virtual/krb5 )"
RDEPEND+="
+ kerberos? ( virtual/krb5 )
x11-misc/xdg-utils
virtual/ttf-fonts"
@@ -103,6 +105,9 @@ src_prepare() {
# Backport FFmpeg compatibility patch, bug #355405.
epatch "${FILESDIR}/${PN}-ffmpeg-build-r1.patch"
+ # Make Chromium recognize Gentoo's Heimdal, to be upstreamed.
+ epatch "${FILESDIR}/${PN}-gssapi-heimdal-r0.patch"
+
# Remove most bundled libraries. Some are still needed.
find third_party -type f \! -iname '*.gyp*' \
\! -path 'third_party/WebKit/*' \
@@ -128,6 +133,7 @@ src_prepare() {
\! -path 'third_party/openmax/*' \
\! -path 'third_party/ots/*' \
\! -path 'third_party/protobuf/*' \
+ \! -path 'third_party/pyftpdlib/*' \
\! -path 'third_party/skia/*' \
\! -path 'third_party/speex/speex.h' \
\! -path 'third_party/sqlite/*' \
@@ -230,8 +236,8 @@ src_compile() {
emake chrome chrome_sandbox BUILDTYPE=Release V=1 || die
pax-mark m out/Release/chrome
if use test; then
- emake base_unittests BUILDTYPE=Release V=1 || die
- pax-mark m out/Release/base_unittests
+ emake {base,net}_unittests BUILDTYPE=Release V=1 || die
+ pax-mark m out/Release/{base,net}_unittests
fi
}
@@ -249,6 +255,13 @@ src_test() {
# For more info see bug #350347.
LC_ALL="${mylocale}" VIRTUALX_COMMAND=out/Release/base_unittests virtualmake \
'--gtest_filter=-ICUStringConversionsTest.*'
+
+ # DiskCache: we need net/data/cache_tests in the tarball (export_tarball.py)
+ # NetUtilTest: bug #361885.
+ # HTTPS/SSL: bug #361939.
+ # UDP: unstable, active development. We should revisit this later.
+ LC_ALL="${mylocale}" VIRTUALX_COMMAND=out/Release/net_unittests virtualmake \
+ '--gtest_filter=-*DiskCache*:NetUtilTest.IDNToUnicode*:NetUtilTest.FormatUrl*:*HTTPS*:*SSL*:*UDP*'
}
src_install() {
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index 4973a0cfad0e..43fcc3ac67f8 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.12 2011/03/30 11:36:30 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.13 2011/04/05 08:38:50 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -17,7 +17,7 @@ EGCLIENT_REPO_URI="http://src.chromium.org/svn/trunk/src/"
LICENSE="BSD"
SLOT="live"
KEYWORDS=""
-IUSE="cups gnome gnome-keyring"
+IUSE="cups gnome gnome-keyring kerberos"
RDEPEND="app-arch/bzip2
dev-libs/dbus-glib
@@ -46,9 +46,11 @@ DEPEND="${RDEPEND}
>=dev-util/gperf-3.0.3
>=dev-util/pkgconfig-0.23
sys-devel/flex
- >=sys-devel/make-3.81-r2"
+ >=sys-devel/make-3.81-r2
+ test? ( dev-python/simplejson dev-python/tlslite virtual/krb5 )"
RDEPEND+="
!=www-client/chromium-9999
+ kerberos? ( virtual/krb5 )
x11-misc/xdg-utils
virtual/ttf-fonts"
@@ -147,6 +149,9 @@ src_prepare() {
# Make sure we don't use bundled libvpx headers.
epatch "${FILESDIR}/${PN}-system-vpx-r4.patch"
+ # Make Chromium recognize Gentoo's Heimdal, to be upstreamed.
+ epatch "${FILESDIR}/${PN}-gssapi-heimdal-r0.patch"
+
# Remove most bundled libraries. Some are still needed.
find third_party -type f \! -iname '*.gyp*' \
\! -path 'third_party/WebKit/*' \
@@ -172,6 +177,7 @@ src_prepare() {
\! -path 'third_party/openmax/*' \
\! -path 'third_party/ots/*' \
\! -path 'third_party/protobuf/*' \
+ \! -path 'third_party/pyftpdlib/*' \
\! -path 'third_party/skia/*' \
\! -path 'third_party/speex/speex.h' \
\! -path 'third_party/sqlite/*' \
@@ -274,8 +280,8 @@ src_compile() {
emake chrome chrome_sandbox BUILDTYPE=Release V=1 || die
pax-mark m out/Release/chrome
if use test; then
- emake base_unittests BUILDTYPE=Release V=1 || die
- pax-mark m out/Release/base_unittests
+ emake {base,net}_unittests BUILDTYPE=Release V=1 || die
+ pax-mark m out/Release/{base,net}_unittests
fi
}
@@ -293,6 +299,13 @@ src_test() {
# For more info see bug #350347.
LC_ALL="${mylocale}" VIRTUALX_COMMAND=out/Release/base_unittests virtualmake \
'--gtest_filter=-ICUStringConversionsTest.*'
+
+ # DiskCache: we need net/data/cache_tests in the tarball (export_tarball.py)
+ # NetUtilTest: bug #361885.
+ # HTTPS/SSL: bug #361939.
+ # UDP: unstable, active development. We should revisit this later.
+ LC_ALL="${mylocale}" VIRTUALX_COMMAND=out/Release/net_unittests virtualmake \
+ '--gtest_filter=-*DiskCache*:NetUtilTest.IDNToUnicode*:NetUtilTest.FormatUrl*:*HTTPS*:*SSL*:*UDP*'
}
src_install() {
diff --git a/www-client/chromium/files/chromium-gssapi-heimdal-r0.patch b/www-client/chromium/files/chromium-gssapi-heimdal-r0.patch
new file mode 100644
index 000000000000..15ec98a620e4
--- /dev/null
+++ b/www-client/chromium/files/chromium-gssapi-heimdal-r0.patch
@@ -0,0 +1,10 @@
+--- net/http/http_auth_gssapi_posix.cc.orig 2011-04-05 08:25:52.000000000 +0200
++++ net/http/http_auth_gssapi_posix.cc 2011-04-05 08:26:32.000000000 +0200
+@@ -437,6 +437,7 @@
+ #else
+ "libgssapi_krb5.so.2", // MIT Kerberos - FC, Suse10, Debian
+ "libgssapi.so.4", // Heimdal - Suse10, MDK
++ "libgssapi.so.2", // Heimdal - Gentoo
+ "libgssapi.so.1" // Heimdal - Suse9, CITI - FC, MDK, Suse10
+ #endif
+ };