summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-11-01 06:21:22 +0000
committerTim Harder <radhermit@gentoo.org>2012-11-01 06:21:22 +0000
commit13900e1fa938cfe50fab78230883e310015188cf (patch)
tree5fe0c389db4fcd027f80c37a07fad328e19f49eb /www-client/dwb
parentBump (diff)
downloadgentoo-2-13900e1fa938cfe50fab78230883e310015188cf.tar.gz
gentoo-2-13900e1fa938cfe50fab78230883e310015188cf.tar.bz2
gentoo-2-13900e1fa938cfe50fab78230883e310015188cf.zip
Revision bump. Apply fix for search engine adding issue (bug #440692 by John Brendler).
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-client/dwb')
-rw-r--r--www-client/dwb/ChangeLog9
-rw-r--r--www-client/dwb/dwb-2012.10.28-r1.ebuild50
-rw-r--r--www-client/dwb/files/dwb-2012.10.28-search-engine.patch11
3 files changed, 69 insertions, 1 deletions
diff --git a/www-client/dwb/ChangeLog b/www-client/dwb/ChangeLog
index c20ca581cd8a..0f2251df76e9 100644
--- a/www-client/dwb/ChangeLog
+++ b/www-client/dwb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/dwb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/ChangeLog,v 1.9 2012/10/28 19:35:14 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/ChangeLog,v 1.10 2012/11/01 06:21:22 radhermit Exp $
+
+*dwb-2012.10.28-r1 (01 Nov 2012)
+
+ 01 Nov 2012; Tim Harder <radhermit@gentoo.org> +dwb-2012.10.28-r1.ebuild,
+ +files/dwb-2012.10.28-search-engine.patch:
+ Revision bump. Apply fix for search engine adding issue (bug #440692 by John
+ Brendler).
28 Oct 2012; Tim Harder <radhermit@gentoo.org> dwb-2012.10.28.ebuild:
LDFLAGS are now respected.
diff --git a/www-client/dwb/dwb-2012.10.28-r1.ebuild b/www-client/dwb/dwb-2012.10.28-r1.ebuild
new file mode 100644
index 000000000000..b293a7350210
--- /dev/null
+++ b/www-client/dwb/dwb-2012.10.28-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/dwb/dwb-2012.10.28-r1.ebuild,v 1.1 2012/11/01 06:21:22 radhermit Exp $
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
+HOMEPAGE="http://portix.bitbucket.org/dwb/"
+SRC_URI="mirror://bitbucket/portix/dwb/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples gtk3"
+
+RDEPEND=">=net-libs/libsoup-2.32:2.4
+ !gtk3? (
+ >=net-libs/webkit-gtk-1.4.0:2
+ x11-libs/gtk+:2
+ )
+ gtk3? (
+ >=net-libs/webkit-gtk-1.4.0:3
+ x11-libs/gtk+:3
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-verbose-build.patch
+ epatch "${FILESDIR}"/${P}-search-engine.patch
+ sed -i "/^CFLAGS += -\(pipe\|g\|O2\)/d" config.mk || die
+}
+
+src_compile() {
+ local myconf
+ use gtk3 && myconf+=" GTK=3"
+
+ emake CC="$(tc-getCC)" ${myconf}
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/www-client/dwb/files/dwb-2012.10.28-search-engine.patch b/www-client/dwb/files/dwb-2012.10.28-search-engine.patch
new file mode 100644
index 000000000000..9335c946efac
--- /dev/null
+++ b/www-client/dwb/files/dwb-2012.10.28-search-engine.patch
@@ -0,0 +1,11 @@
+--- dwb-2012.10.28/scripts/base.js
++++ dwb-2012.10.28/scripts/base.js
+@@ -692,7 +692,7 @@ Object.freeze((function () {
+ return __addSearchEngine();
+ },
+ submitSearchEngine : function (obj) {
+- return __submitSearchEngine(obj.searchString);
++ return __submitSearchEngine(JSON.parse(obj).searchString);
+ },
+ focusInput : function () {
+ __focusInput();