summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-06-09 14:34:35 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-06-09 14:34:35 +0000
commit0876d431aa09f6f2dae3b237aada0d801893fc1e (patch)
tree114cc416d80a8909b682e87e081c912d23374b99 /www-client/epiphany
parentVersion bump for Gnome 3.16. (diff)
downloadgentoo-2-0876d431aa09f6f2dae3b237aada0d801893fc1e.tar.gz
gentoo-2-0876d431aa09f6f2dae3b237aada0d801893fc1e.tar.bz2
gentoo-2-0876d431aa09f6f2dae3b237aada0d801893fc1e.zip
Version bump for Gnome 3.16.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/ChangeLog8
-rw-r--r--www-client/epiphany/epiphany-3.16.1.ebuild98
-rw-r--r--www-client/epiphany/files/epiphany-3.16.0-unittest-1.patch30
3 files changed, 135 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 5cb169ab9209..bdab93581a38 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.314 2015/05/01 13:49:42 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.315 2015/06/09 14:34:35 eva Exp $
+
+*epiphany-3.16.1 (09 Jun 2015)
+
+ 09 Jun 2015; Gilles Dartiguelongue <eva@gentoo.org> +epiphany-3.16.1.ebuild,
+ +files/epiphany-3.16.0-unittest-1.patch:
+ Version bump for Gnome 3.16.
01 May 2015; Gilles Dartiguelongue <eva@gentoo.org> epiphany-3.14.2.ebuild:
Add missing gnome-common dependency, bug #547902.
diff --git a/www-client/epiphany/epiphany-3.16.1.ebuild b/www-client/epiphany/epiphany-3.16.1.ebuild
new file mode 100644
index 000000000000..c97f94e5954c
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.16.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-3.16.1.ebuild,v 1.1 2015/06/09 14:34:35 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 pax-utils versionator virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+# TODO: coverage
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+jit +nss test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.5.5
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-2.7.4:4[jit?]
+ >=net-libs/libsoup-2.48:2.4
+ >=x11-libs/gtk+-3.13:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+
+ x11-themes/gnome-icon-theme
+ x11-themes/gnome-icon-theme-symbolic
+
+ nss? ( dev-libs/nss )
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${COMMON_DEPEND}
+ >=gnome-base/gnome-common-3.6
+ >=dev-util/intltool-0.50
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix missing symbol in webextension.so, bug #728972
+ epatch "${FILESDIR}"/${PN}-3.14.0-missing-symbol.patch
+
+ # Fix unittests
+ epatch "${FILESDIR}"/${PN}-3.16.0-unittest-1.patch
+ epatch "${FILESDIR}"/${PN}-3.14.0-unittest-2.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable nss) \
+ $(use_enable test tests) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # needed to avoid "Command line `dbus-launch ...' exited with non-zero exit status 1"
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DISPLAY
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+ gnome2_src_install
+ use jit && pax-mark m "${ED}usr/bin/epiphany"
+}
diff --git a/www-client/epiphany/files/epiphany-3.16.0-unittest-1.patch b/www-client/epiphany/files/epiphany-3.16.0-unittest-1.patch
new file mode 100644
index 000000000000..baa8a421da13
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-3.16.0-unittest-1.patch
@@ -0,0 +1,30 @@
+From 7ed4a68e2106480f0984703f70b7c25734803161 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 10 May 2015 17:35:57 +0200
+Subject: [PATCH 2/3] Gentoo tests run in ${PORTAGE_TMPDIR} which is not
+ guaranteed to be /tmp
+
+---
+ tests/ephy-file-helpers-test.c | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/tests/ephy-file-helpers-test.c b/tests/ephy-file-helpers-test.c
+index 43d0009..0fcb585 100644
+--- a/tests/ephy-file-helpers-test.c
++++ b/tests/ephy-file-helpers-test.c
+@@ -89,12 +89,7 @@ test_ephy_file_helpers_init (void)
+
+ /* Cleanup dir left behind. */
+ if (keep_dir) {
+- /* As a safety measure, only try recursive delete on paths
+- * prefixed with /tmp. */
+- if (g_str_has_prefix (tmp_dir, "/tmp"))
+ g_assert (ephy_file_delete_dir_recursively (tmp_dir, NULL));
+- else
+- g_warning ("INIT: dangerous path returned as tmp_dir: %s", tmp_dir);
+ }
+
+ g_free (tmp_dir);
+--
+2.3.6
+