summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-06-25 14:24:38 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-06-25 14:24:38 +0000
commit2cf4ba93f95deaa1677b3da652a53ec28ad961d5 (patch)
tree089d9c12ae74141030d29fa2c25425dbf49cfcf1 /www-client/firefox
parentCleanup old versions (diff)
downloadgentoo-2-2cf4ba93f95deaa1677b3da652a53ec28ad961d5.tar.gz
gentoo-2-2cf4ba93f95deaa1677b3da652a53ec28ad961d5.tar.bz2
gentoo-2-2cf4ba93f95deaa1677b3da652a53ec28ad961d5.zip
Fix bug 372845 (pgo needs python[sqlite]), bug 372817 (sandbox violations), bug 372815 (pgo failure due to env leakage)
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/ChangeLog6
-rw-r--r--www-client/firefox/firefox-5.0.ebuild22
2 files changed, 24 insertions, 4 deletions
diff --git a/www-client/firefox/ChangeLog b/www-client/firefox/ChangeLog
index 7744fa0a696d..a05b601ea3c3 100644
--- a/www-client/firefox/ChangeLog
+++ b/www-client/firefox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/firefox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/ChangeLog,v 1.74 2011/06/24 09:55:00 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/ChangeLog,v 1.75 2011/06/25 14:24:38 nirbheek Exp $
+
+ 25 Jun 2011; Nirbheek Chauhan <nirbheek@gentoo.org> firefox-5.0.ebuild:
+ Fix bug 372845 (pgo needs python[sqlite]), bug 372817 (sandbox violations),
+ bug 372815 (pgo failure due to env leakage)
*firefox-5.0 (24 Jun 2011)
diff --git a/www-client/firefox/firefox-5.0.ebuild b/www-client/firefox/firefox-5.0.ebuild
index 68e70ce22eab..0aacdd95647a 100644
--- a/www-client/firefox/firefox-5.0.ebuild
+++ b/www-client/firefox/firefox-5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-5.0.ebuild,v 1.1 2011/06/24 09:55:00 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-5.0.ebuild,v 1.2 2011/06/25 14:24:38 nirbheek Exp $
EAPI="3"
VIRTUALX_REQUIRED="pgo"
@@ -42,10 +42,12 @@ RDEPEND="
system-sqlite? ( >=dev-db/sqlite-3.7.4[fts3,secure-delete,unlock-notify,debug=] )
webm? ( media-libs/libvpx
media-libs/alsa-lib )"
-
+# We don't use PYTHON_DEPEND/PYTHON_USE_WITH for some silly reason
DEPEND="${RDEPEND}
dev-util/pkgconfig
- pgo? ( >=sys-devel/gcc-4.5 )
+ pgo? (
+ =dev-lang/python-2*[sqlite]
+ >=sys-devel/gcc-4.5 )
webm? ( x86? ( ${ASM_DEPEND} )
amd64? ( ${ASM_DEPEND} ) )"
@@ -118,6 +120,13 @@ linguas() {
pkg_setup() {
moz_pkgsetup
+ # Avoid PGO profiling problems due to enviroment leakage
+ # These should *always* be cleaned up anyway
+ unset DBUS_SESSION_BUS_ADDRESS \
+ XDG_SESSION_COOKIE \
+ ORBIT_SOCKETDIR \
+ SESSION_MANAGER
+
if ! use bindist ; then
einfo
elog "You are enabling official branding. You may not redistribute this build"
@@ -167,6 +176,13 @@ src_prepare() {
sed -i -e "s:/usr/lib/mozilla/plugins:/usr/$(get_libdir)/nsbrowser/plugins:" \
"${S}"/xpcom/io/nsAppFileLocationProvider.cpp || die "sed failed to replace plugin path!"
+ # Fix sandbox violations during make clean, bug 372817
+ sed -e "s:\(/no-such-file\):${T}\1:g" \
+ -i "${S}"/config/rules.mk \
+ -i "${S}"/js/src/config/rules.mk \
+ -i "${S}"/nsprpub/configure{.in,} \
+ || die
+
eautoreconf
cd js/src