summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-03-25 13:36:58 +0000
committerAlex Alexander <wired@gentoo.org>2011-03-25 13:36:58 +0000
commit096bf51ad6b285c606f2573c62fcb84bb1472bb4 (patch)
treebb9456eb20bbe814a1412bc513ef6ad17dcbb2d6 /www-client/uzbl/uzbl-2011.03.17.ebuild
parentInitial version (diff)
downloadgentoo-2-096bf51ad6b285c606f2573c62fcb84bb1472bb4.tar.gz
gentoo-2-096bf51ad6b285c606f2573c62fcb84bb1472bb4.tar.bz2
gentoo-2-096bf51ad6b285c606f2573c62fcb84bb1472bb4.zip
version bump. added missing runtime dep, bug #360149
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'www-client/uzbl/uzbl-2011.03.17.ebuild')
-rw-r--r--www-client/uzbl/uzbl-2011.03.17.ebuild128
1 files changed, 128 insertions, 0 deletions
diff --git a/www-client/uzbl/uzbl-2011.03.17.ebuild b/www-client/uzbl/uzbl-2011.03.17.ebuild
new file mode 100644
index 000000000000..ec189d05580f
--- /dev/null
+++ b/www-client/uzbl/uzbl-2011.03.17.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/uzbl/uzbl-2011.03.17.ebuild,v 1.1 2011/03/25 13:36:58 wired Exp $
+
+EAPI="4"
+
+inherit base
+
+IUSE=""
+if [[ ${PV} == *9999* ]]; then
+ inherit git
+ EGIT_REPO_URI=${EGIT_REPO_URI:-"git://github.com/Dieterbe/uzbl.git"}
+ KEYWORDS=""
+ SRC_URI=""
+ IUSE="experimental"
+ use experimental &&
+ EGIT_BRANCH="experimental" &&
+ EGIT_COMMIT="experimental"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://github.com/Dieterbe/${PN}/tarball/${PV} -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Web interface tools which adhere to the unix philosophy."
+HOMEPAGE="http://www.uzbl.org"
+
+LICENSE="LGPL-2.1 MPL-1.1"
+SLOT="0"
+IUSE+=" +browser helpers +tabbed vim-syntax"
+
+REQUIRED_USE="tabbed? ( browser )"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ >=dev-libs/icu-4.0.1
+ >=net-libs/libsoup-2.24:2.4
+ >=net-libs/webkit-gtk-1.1.15:2
+ >=x11-libs/gtk+-2.14:2
+"
+
+DEPEND="
+ >=dev-util/pkgconfig-0.19
+ ${COMMON_DEPEND}
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-misc/xdg-utils
+ browser? (
+ x11-misc/xclip
+ )
+ helpers? (
+ dev-python/pygtk
+ dev-python/pygobject
+ gnome-extra/zenity
+ net-misc/socat
+ x11-libs/pango
+ x11-misc/dmenu
+ x11-misc/xclip
+ )
+ tabbed? (
+ dev-python/pygtk
+ )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+"
+# TODO document what requires the above helpers
+
+pkg_setup() {
+ if ! use helpers; then
+ elog "uzbl's extra scripts use various optional applications:"
+ elog
+ elog " dev-python/pygtk"
+ elog " dev-python/pygobject"
+ elog " gnome-extra/zenity"
+ elog " net-misc/socat"
+ elog " x11-libs/pango"
+ elog " x11-misc/dmenu"
+ elog " x11-misc/xclip"
+ elog
+ elog "Make sure you emerge the ones you need manually."
+ elog "You may also activate the *helpers* USE flag to"
+ elog "install all of them automatically."
+ else
+ einfo "You have enabled the *helpers* USE flag that installs"
+ einfo "various optional applications used by uzbl's extra scripts."
+ fi
+ ewarn
+ ewarn "This version introduces some backwards-incompatible changes."
+ ewarn "Please read http://www.uzbl.org/news.php?id=33 for more details."
+ ewarn
+}
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ git_src_unpack
+ else
+ unpack ${A}
+ mv Dieterbe-uzbl-* "${S}"
+ fi
+}
+
+src_prepare() {
+ if [[ ${PV} == *9999* ]]; then
+ git_src_prepare
+ fi
+
+ # remove -ggdb
+ sed -i "s/-ggdb //g" Makefile ||
+ die "-ggdb removal sed failed"
+}
+
+src_install() {
+ local targets="install-uzbl-core"
+ use browser && targets="${targets} install-uzbl-browser"
+ use browser && use tabbed && targets="${targets} install-uzbl-tabbed"
+
+ emake DESTDIR="${D}" PREFIX="/usr" DOCDIR="${D}/usr/share/doc/${PF}" ${targets} ||
+ die "Installation failed"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${S}"/extras/vim/ftdetect/uzbl.vim || die "vim-syntax doins failed"
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins "${S}"/extras/vim/syntax/uzbl.vim || die "vim-syntax doins failed"
+ fi
+
+}