summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-10-22 17:27:49 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-10-22 17:27:49 +0000
commit35d00f49251aef704967ee051fdb66315d4d32f0 (patch)
treea5cc9d9f9224b8ae8c6bff08138dff9cb5da9fd5 /www-client
parentKeywording for ppc. (diff)
downloadgentoo-2-35d00f49251aef704967ee051fdb66315d4d32f0.tar.gz
gentoo-2-35d00f49251aef704967ee051fdb66315d4d32f0.tar.bz2
gentoo-2-35d00f49251aef704967ee051fdb66315d4d32f0.zip
Fix missing favicon on most websites (due to a missing pattern matching) per bug #290024
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/ChangeLog9
-rw-r--r--www-client/epiphany/epiphany-2.26.3-r2.ebuild90
-rw-r--r--www-client/epiphany/files/epiphany-2.26.3-favicon-cache.patch17
3 files changed, 115 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 31412aba0b84..374184822390 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/epiphany
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.218 2009/10/03 14:20:02 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.219 2009/10/22 17:27:49 mrpouet Exp $
+
+*epiphany-2.26.3-r2 (22 Oct 2009)
+
+ 22 Oct 2009; Romain Perier <mrpouet@gentoo.org>
+ +epiphany-2.26.3-r2.ebuild, +files/epiphany-2.26.3-favicon-cache.patch:
+ Fix missing favicon on most websites (due to a missing pattern matching)
+ per bug #290024.
03 Oct 2009; Tobias Klausmann <klausman@gentoo.org>
epiphany-2.26.3-r1.ebuild:
diff --git a/www-client/epiphany/epiphany-2.26.3-r2.ebuild b/www-client/epiphany/epiphany-2.26.3-r2.ebuild
new file mode 100644
index 000000000000..0a100dd01dfd
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.26.3-r2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.26.3-r2.ebuild,v 1.1 2009/10/22 17:27:49 mrpouet Exp $
+
+EAPI="2"
+
+inherit gnome2 eutils multilib autotools
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="avahi doc networkmanager python spell"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=x11-libs/gtk+-2.16.0
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=x11-libs/libnotify-0.4
+ >=media-libs/libcanberra-0.3[gtk]
+ >=dev-libs/dbus-glib-0.71
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ networkmanager? ( net-misc/networkmanager )
+ =net-libs/xulrunner-1.9*
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6 )
+ spell? ( app-text/enchant )
+ x11-themes/gnome-icon-theme"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ >=app-text/gnome-doc-utils-0.3.2
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --with-gecko=libxul-embedding
+ --with-distributor-name=Gentoo
+ --enable-canberra
+ $(use_enable avahi zeroconf)
+ $(use_enable networkmanager network-manager)
+ $(use_enable spell spell-checker)
+ $(use_enable python)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix libcanberra automagic support, bug #266232
+ epatch "${FILESDIR}/${PN}-2.26.1-automagic-libcanberra.patch"
+
+ # Fix sandbox violations, bug #263585
+ epatch "${FILESDIR}/${PN}-2.26-fix-sandbox-violations.patch"
+
+ # Fix detection of system plugin, bug #279417
+ epatch "${FILESDIR}/${P}-system-plugin.patch"
+
+ # Fix missing favicons of most web-sites, bug #290024
+ epatch "${FILESDIR}/${P}-favicon-cache.patch"
+
+ # Make it libtool-1 compatible
+ rm -v m4/lt* m4/libtool.m4 || die "removing libtool macros failed"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+
+ # All .la files are for plugins or extensions that are dlopened.
+ # Upstream should pass *_la_LIBTOOLFLAGS = --tag=disable-static to drop them instead
+ # but gecko is a dead branch for them, so do it ourselves:
+ find "${D}" -name '*.la' -delete
+}
diff --git a/www-client/epiphany/files/epiphany-2.26.3-favicon-cache.patch b/www-client/epiphany/files/epiphany-2.26.3-favicon-cache.patch
new file mode 100644
index 000000000000..c7158aee90e2
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-2.26.3-favicon-cache.patch
@@ -0,0 +1,17 @@
+Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=290024
+
+Ephy does not display favicon of most websites due to a missing pattern match,
+for "image/vnd.microsoft.icon" mimetype.
+
+Index: epiphany/embed/ephy-favicon-cache.c
+===================================================================
+--- epiphany.orig/embed/ephy-favicon-cache.c 2009-05-21 09:53:41.207975209 -0400
++++ epiphany/embed/ephy-favicon-cache.c 2009-05-21 09:54:28.061689298 -0400
+@@ -696,6 +696,7 @@
+ return NULL;
+ }
+ valid = strcmp (mime_type, "image/x-ico") == 0 ||
++ strcmp (mime_type, "image/vnd.microsoft.icon") == 0 ||
+ strcmp (mime_type, "image/png") == 0 ||
+ strcmp (mime_type, "image/gif") == 0;
+ is_ao = strcmp (mime_type, "application/octet-stream") == 0;