summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-26 06:02:41 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-26 06:02:41 +0000
commit82bbce72030c71d1aa7760a1b4369fb55281ccf0 (patch)
treed17e3d84cddc4782fceed776c1c8d20c6de3ede1 /www-client
parentapp-text/ghostscript-esp removal, see #261434. (diff)
downloadgentoo-2-82bbce72030c71d1aa7760a1b4369fb55281ccf0.tar.gz
gentoo-2-82bbce72030c71d1aa7760a1b4369fb55281ccf0.tar.bz2
gentoo-2-82bbce72030c71d1aa7760a1b4369fb55281ccf0.zip
Bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/lynx/ChangeLog9
-rw-r--r--www-client/lynx/lynx-2.8.7_rc4.ebuild106
2 files changed, 113 insertions, 2 deletions
diff --git a/www-client/lynx/ChangeLog b/www-client/lynx/ChangeLog
index 71e1a4488a08..2b0c1e8b6b92 100644
--- a/www-client/lynx/ChangeLog
+++ b/www-client/lynx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/lynx
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.74 2009/05/01 20:44:05 loki_val Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.75 2009/05/26 06:02:41 loki_val Exp $
+
+*lynx-2.8.7_rc4 (26 May 2009)
+
+ 26 May 2009; Peter Alfredsen <loki_val@gentoo.org> +lynx-2.8.7_rc4.ebuild:
+ Bump
01 May 2009; Peter Alfredsen <loki_val@gentoo.org> lynx-2.8.7_rc2.ebuild:
Pull in pkg-config
diff --git a/www-client/lynx/lynx-2.8.7_rc4.ebuild b/www-client/lynx/lynx-2.8.7_rc4.ebuild
new file mode 100644
index 000000000000..b73738092db3
--- /dev/null
+++ b/www-client/lynx/lynx-2.8.7_rc4.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.7_rc4.ebuild,v 1.1 2009/05/26 06:02:41 loki_val Exp $
+
+EAPI=2
+
+inherit eutils versionator
+
+# VERSIONING SCHEME TRANSLATION
+# Upstream : Gentoo
+# rel. : _p
+# pre. : _rc
+# dev. : _pre
+
+if [[ "${PV/_p[0-9]}" != "${PV}" ]]
+then
+ MY_P="${PN}${PV/_p/rel.}"
+
+elif [[ "${PV/_rc[0-9]}" != "${PV}" ]]
+then
+ MY_P="${PN}${PV/_rc/pre.}"
+
+elif [[ "${PV/_pre[0-9]}" != "${PV}" ]]
+then
+ MY_P="${PN}${PV/_pre/dev.}"
+
+fi
+
+DESCRIPTION="An excellent console-based web browser with ssl support"
+HOMEPAGE="http://lynx.isc.org/"
+SRC_URI="http://lynx.isc.org/current/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="bzip2 cjk gnutls ipv6 nls openssl unicode"
+
+RDEPEND="sys-libs/ncurses[unicode?]
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ openssl? ( >=dev-libs/openssl-0.9.8 )
+ !openssl? (
+ gnutls? ( >=net-libs/gnutls-2.6.4 )
+ )
+ bzip2? ( app-arch/bzip2 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/pkgconfig-0.23"
+
+S="${WORKDIR}/${PN}$(replace_all_version_separators - $(get_version_component_range 1-3))"
+
+pkg_setup() {
+ if use openssl
+ then
+ if use gnutls
+ then
+ elog "Both openssl and gnutls use-flags specified. Openssl will be used."
+ fi
+ else
+ if ! use gnutls
+ then
+ elog "No SSL library selected, you will not be able to access secure websites."
+ fi
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-cgi-links \
+ --enable-persistent-cookies \
+ --enable-prettysrc \
+ --enable-nsl-fork \
+ --enable-file-upload \
+ --enable-read-eta \
+ --enable-color-style \
+ --enable-scrollbar \
+ --enable-included-msgs \
+ --with-zlib \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_enable cjk) \
+ $(use_enable unicode japanese-utf8) \
+ $(use_with openssl ssl) \
+ $(use_with gnutls) \
+ $(use_with bzip2 bzlib) \
+ $(use unicode && printf '%s' '--with-screen=ncursesw')
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ sed -i -e "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
+ "${D}"/etc/lynx.cfg || die "lynx.cfg not found"
+ if use unicode
+ then
+ sed -i -e '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
+ "${D}"/etc/lynx.cfg || die "lynx.cfg not found"
+ fi
+ dodoc CHANGES COPYHEADER PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ dohtml -r lynx_help/*
+}