summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-05 03:03:09 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-05 03:03:09 +0000
commit9be2a18d250ea1472c893f356e59a0780dc4fca4 (patch)
tree2214d188520c28698f7484b883f985f3fd614b20 /www-client
parentRemove obsolete sys-devel/gcc[libffi] built_with_use check wrt #406927 by Mic... (diff)
downloadgentoo-2-9be2a18d250ea1472c893f356e59a0780dc4fca4.tar.gz
gentoo-2-9be2a18d250ea1472c893f356e59a0780dc4fca4.tar.bz2
gentoo-2-9be2a18d250ea1472c893f356e59a0780dc4fca4.zip
Fix build problems on PaX with USE=introspection and mark /usr/bin/epiphany so that it runs on PaX when webkit-gtk was built with USE=jit.
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/ChangeLog10
-rw-r--r--www-client/epiphany/epiphany-3.2.1-r1.ebuild87
-rw-r--r--www-client/epiphany/files/epiphany-3.2.1-paxctl-introspection.patch41
-rwxr-xr-xwww-client/epiphany/files/gir-paxctl-lt-wrapper14
-rwxr-xr-xwww-client/epiphany/files/paxctl.sh24
5 files changed, 175 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 06b149b3fb79..fd324633a624 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/epiphany
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.277 2012/02/14 04:19:36 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.278 2012/03/05 03:03:09 tetromino Exp $
+
+*epiphany-3.2.1-r1 (05 Mar 2012)
+
+ 05 Mar 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +epiphany-3.2.1-r1.ebuild, +files/epiphany-3.2.1-paxctl-introspection.patch,
+ +files/gir-paxctl-lt-wrapper, +files/paxctl.sh:
+ Fix build problems on PaX with USE=introspection and mark /usr/bin/epiphany
+ so that it runs on PaX when webkit-gtk was built with USE=jit.
14 Feb 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
epiphany-3.2.1.ebuild:
diff --git a/www-client/epiphany/epiphany-3.2.1-r1.ebuild b/www-client/epiphany/epiphany-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..fdd0d2f3af50
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.2.1-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-3.2.1-r1.ebuild,v 1.1 2012/03/05 03:03:09 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+
+inherit autotools eutils gnome2 pax-utils
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="http://projects.gnome.org/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="avahi doc +introspection +networkmanager +nss test"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# XXX: Should we add seed support? Seed seems to be unmaintained now.
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
+# and 2.30.0
+COMMON_DEPEND=">=dev-libs/glib-2.30.0:2
+ >=x11-libs/gtk+-3.0.2:3[introspection?]
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=app-text/iso-codes-0.35
+ >=net-libs/webkit-gtk-1.6.1:3[introspection?]
+ >=net-libs/libsoup-gnome-2.33.1:2.4
+ >=gnome-base/gnome-keyring-2.26.0
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=x11-libs/libnotify-0.5.1
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+
+ app-misc/ca-certificates
+ x11-themes/gnome-icon-theme
+
+ avahi? ( >=net-dns/avahi-0.6.22 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ nss? ( dev-libs/nss )"
+# networkmanager is used purely via dbus
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gnome-icon-theme-symbolic
+ networkmanager? ( >=net-misc/networkmanager-0.8.997 )"
+DEPEND="${COMMON_DEPEND}
+ app-text/gnome-doc-utils
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+ G2CONF="${G2CONF}
+ --enable-shared
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --disable-static
+ --with-distributor-name=Gentoo
+ --with-ca-file=${EPREFIX}/etc/ssl/certs/ca-certificates.crt
+ $(use_enable avahi zeroconf)
+ $(use_enable introspection)
+ $(use_enable nss)
+ $(use_enable test tests)"
+ # Upstream no longer makes networkmanager optional, but we still want
+ # to make it possible for prefix users to use epiphany
+ use networkmanager && CFLAGS="${CFLAGS} -DENABLE_NETWORK_MANAGER"
+}
+
+src_prepare() {
+ # Make networkmanager optional for prefix people
+ epatch "${FILESDIR}/${PN}-3.2.0-optional-networkmanager.patch"
+ # Build-time segfaults under PaX with USE=introspection
+ epatch "${FILESDIR}/${PN}-3.2.1-paxctl-introspection.patch"
+ cp "${FILESDIR}/gir-paxctl-lt-wrapper" \
+ "${FILESDIR}/paxctl.sh" "${S}/" || die
+ sed -e "s:@S@:${S}:" -i gir-paxctl-lt-wrapper || die
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ pax-mark m "${ED}usr/bin/epiphany"
+}
diff --git a/www-client/epiphany/files/epiphany-3.2.1-paxctl-introspection.patch b/www-client/epiphany/files/epiphany-3.2.1-paxctl-introspection.patch
new file mode 100644
index 000000000000..ba5eab47ef0b
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-3.2.1-paxctl-introspection.patch
@@ -0,0 +1,41 @@
+From f9ba4d6428f06f717eb16e83a728f82b314383f1 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sun, 4 Mar 2012 19:47:17 -0500
+Subject: [PATCH] Add libtool wrapper for building introspection under PaX
+
+---
+ src/Makefile.am | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index c46160c..2aa94d1 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -299,7 +299,7 @@ EPHY_GIR_C_FILES = \
+
+ EphyEgg-$(EPIPHANY_API_VERSION).gir: $(INTROSPECTION_SCANNER)
+ $(AM_V_GEN) PKG_CONFIG_PATH=$(top_builddir)/data:$$PKG_CONFIG_PATH \
+- $(INTROSPECTION_SCANNER) -v --warn-all \
++ LIBTOOL="$(LIBTOOL)" $(INTROSPECTION_SCANNER) -v --warn-all \
+ --identifier-prefix=Egg \
+ --symbol-prefix=egg \
+ --namespace=EphyEgg \
+@@ -307,6 +307,7 @@ EphyEgg-$(EPIPHANY_API_VERSION).gir: $(INTROSPECTION_SCANNER)
+ --include=Gtk-3.0 \
+ --include=libxml2-2.0 \
+ --library=$(top_builddir)/lib/egg/libegg.la \
++ --libtool="bash $(top_srcdir)/gir-paxctl-lt-wrapper -m" \
+ --pkg=gtk+-3.0 \
+ --pkg=libxml-2.0 \
+ --output=$@ \
+@@ -318,6 +319,7 @@ EphyEgg-$(EPIPHANY_API_VERSION).gir: $(INTROSPECTION_SCANNER)
+
+ Epiphany-$(EPIPHANY_API_VERSION).gir: EphyEgg-$(EPIPHANY_API_VERSION).gir $(INTROSPECTION_SCANNER) $(EPHY_GIR_H_FILES) \
+ $(EPHY_GIR_C_FILES) epiphany
++ bash $(top_srcdir)/paxctl.sh -m ./epiphany
+ $(AM_V_GEN) PKG_CONFIG_PATH=$(top_builddir)/data:$$PKG_CONFIG_PATH \
+ $(INTROSPECTION_SCANNER) -v --warn-all \
+ --identifier-prefix=Ephy \
+--
+1.7.8.5
+
diff --git a/www-client/epiphany/files/gir-paxctl-lt-wrapper b/www-client/epiphany/files/gir-paxctl-lt-wrapper
new file mode 100755
index 000000000000..c0e606be2c67
--- /dev/null
+++ b/www-client/epiphany/files/gir-paxctl-lt-wrapper
@@ -0,0 +1,14 @@
+#!/bin/bash
+# Wrapper for $(LIBTOOL) that performs PaX marking on the dumper binary
+# generated by g-ir-scanner.
+
+flags=${1//-}; shift
+
+echo ${LIBTOOL} "$@"
+${LIBTOOL} "$@"
+
+retval=$?
+
+bash "@S@/paxctl.sh" "${flags}" $(find . -path "*tmp-introspect*/.libs/*")
+
+exit ${retval}
diff --git a/www-client/epiphany/files/paxctl.sh b/www-client/epiphany/files/paxctl.sh
new file mode 100755
index 000000000000..bb1b6e072f21
--- /dev/null
+++ b/www-client/epiphany/files/paxctl.sh
@@ -0,0 +1,24 @@
+#!/bin/bash
+# PaX marking code stolen from pax-utils.eclass
+
+flags=${1//-}; shift
+
+if type -p paxctl > /dev/null; then
+ echo "PT PaX marking -${flags} $@"
+ for f in "$@"; do
+ # First, try modifying the existing PAX_FLAGS header
+ paxctl -q${flags} "${f}" && continue
+ # Second, try stealing the (unused under PaX) PT_GNU_STACK header
+ paxctl -qc${flags} "${f}" && continue
+ # Third, try pulling the base down a page, to create space and
+ # insert a PT_GNU_STACK header (works on ET_EXEC)
+ paxctl -qC${flags} "${f}" && continue
+ done
+elif type -p scanelf > /dev/null; then
+ # Try scanelf, the Gentoo swiss-army knife ELF utility
+ # Currently this sets PT if it can, no option to control what it does.
+ echo "Fallback PaX marking -${flags} $@"
+ scanelf -Xxz ${flags} "$@"
+fi
+
+exit 0