summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-12-31 17:05:36 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-12-31 17:05:36 +0000
commita142fb7ddd2ca3d0cdffef7a378b2e5144bf763e (patch)
tree998877171da4094c7f57ae272c698e4a64fd246f /www-client
parentVersion bump (diff)
downloadgentoo-2-a142fb7ddd2ca3d0cdffef7a378b2e5144bf763e.tar.gz
gentoo-2-a142fb7ddd2ca3d0cdffef7a378b2e5144bf763e.tar.bz2
gentoo-2-a142fb7ddd2ca3d0cdffef7a378b2e5144bf763e.zip
Version bumped.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/kita/ChangeLog8
-rw-r--r--www-client/kita/files/kita-1.90.4-gems.patch87
-rw-r--r--www-client/kita/files/kita2.desktop10
-rw-r--r--www-client/kita/kita-1.90.4.ebuild41
4 files changed, 145 insertions, 1 deletions
diff --git a/www-client/kita/ChangeLog b/www-client/kita/ChangeLog
index e04ef8c1960a..bd2ad67ea3f9 100644
--- a/www-client/kita/ChangeLog
+++ b/www-client/kita/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/kita
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/kita/ChangeLog,v 1.34 2008/12/03 16:08:22 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/kita/ChangeLog,v 1.35 2008/12/31 17:05:36 matsuu Exp $
+
+*kita-1.90.4 (31 Dec 2008)
+
+ 31 Dec 2008; MATSUU Takuto <matsuu@gentoo.org> +files/kita2.desktop,
+ +files/kita-1.90.4-gems.patch, +kita-1.90.4.ebuild:
+ Version bumped.
*kita-0.177.5 (03 Dec 2008)
diff --git a/www-client/kita/files/kita-1.90.4-gems.patch b/www-client/kita/files/kita-1.90.4-gems.patch
new file mode 100644
index 000000000000..57f12b69e447
--- /dev/null
+++ b/www-client/kita/files/kita-1.90.4-gems.patch
@@ -0,0 +1,87 @@
+diff -Naur kita2-1.90.4.orig/config.rb kita2-1.90.4/config.rb
+--- kita2-1.90.4.orig/config.rb 2008-09-22 23:38:14.000000000 +0900
++++ kita2-1.90.4/config.rb 2009-01-01 01:40:20.000000000 +0900
+@@ -21,7 +21,7 @@
+
+ require 'singleton'
+
+-class Config
++class KitaConfig
+ include Singleton
+
+ def initialize
+diff -Naur kita2-1.90.4.orig/mainwindow.rb kita2-1.90.4/mainwindow.rb
+--- kita2-1.90.4.orig/mainwindow.rb 2008-04-24 22:52:46.000000000 +0900
++++ kita2-1.90.4/mainwindow.rb 2009-01-01 01:40:20.000000000 +0900
+@@ -53,7 +53,7 @@
+
+ statusBar.show
+
+- if Config.instance.auto_login
++ if KitaConfig.instance.auto_login
+ login
+ end
+ end
+@@ -90,7 +90,7 @@
+ end
+
+ def login
+- config = Config.instance
++ config = KitaConfig.instance
+ user_id = config.user_id
+ password = config.password
+
+diff -Naur kita2-1.90.4.orig/preferencedialog.rb kita2-1.90.4/preferencedialog.rb
+--- kita2-1.90.4.orig/preferencedialog.rb 2008-09-22 23:38:14.000000000 +0900
++++ kita2-1.90.4/preferencedialog.rb 2009-01-01 01:40:20.000000000 +0900
+@@ -42,7 +42,7 @@
+ end
+
+ def load_config
+- config = Config.instance
++ config = KitaConfig.instance
+ @face_page.thread_font_requester.setFont(config.thread_font)
+ @account_page.id_line.text = config.user_id
+ @account_page.password_line.text = config.password
+@@ -61,7 +61,7 @@
+ kotehan = @write_page.kotehan_edit.text.split("\n").grep(/^.+$/)
+ thread_font = @face_page.thread_font_requester.font
+
+- config = Config.instance
++ config = KitaConfig.instance
+ config.thread_font = thread_font
+ config.user_id = id
+ config.password = password
+diff -Naur kita2-1.90.4.orig/threadview.rb kita2-1.90.4/threadview.rb
+--- kita2-1.90.4.orig/threadview.rb 2008-09-22 23:38:14.000000000 +0900
++++ kita2-1.90.4/threadview.rb 2009-01-01 01:40:20.000000000 +0900
+@@ -92,7 +92,7 @@
+ end
+
+ def write(dat)
+- config = Config.instance
++ config = KitaConfig.instance
+ @html_part.begin()
+ @html_part.write("<html><head><style type=\"text/css\">")
+ @html_part.write("body { font-size: #{config.thread_font.pointSize()}pt;" +
+diff -Naur kita2-1.90.4.orig/writedialog.rb kita2-1.90.4/writedialog.rb
+--- kita2-1.90.4.orig/writedialog.rb 2008-09-17 22:59:42.000000000 +0900
++++ kita2-1.90.4/writedialog.rb 2009-01-01 01:40:20.000000000 +0900
+@@ -43,14 +43,14 @@
+ index_path = Util.dat_url_to_index_path(@dat_url)
+ config = KDE::Config.new(index_path)
+ names = config.readListEntry("Names")
+- kotehan = Config.instance.kotehan
++ kotehan = KitaConfig.instance.kotehan
+
+ @name_combo.clear
+- @name_combo.insertItem(Config.instance.default_name)
++ @name_combo.insertItem(KitaConfig.instance.default_name)
+ @name_combo.insertStringList(kotehan)
+ @name_combo.insertStringList(names)
+
+- @mail_line.text = Config.instance.default_mail
++ @mail_line.text = KitaConfig.instance.default_mail
+ @body_edit.text = ""
+ @sage_checkbox.setChecked(false)
+ @ok_button.setEnabled(false)
diff --git a/www-client/kita/files/kita2.desktop b/www-client/kita/files/kita2.desktop
new file mode 100644
index 000000000000..1b9f1e1dc6bd
--- /dev/null
+++ b/www-client/kita/files/kita2.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Kita2
+Exec=kita2 %i %m -caption "%c"
+Icon=kita2
+Type=Application
+Comment=Kita - 2ch client for KDE
+Comment[ja]=Kita - KDE用2ちゃんねるブラウザ
+Terminal=0
+Categories=Application;Network;
diff --git a/www-client/kita/kita-1.90.4.ebuild b/www-client/kita/kita-1.90.4.ebuild
new file mode 100644
index 000000000000..3e34e346a799
--- /dev/null
+++ b/www-client/kita/kita-1.90.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/kita/kita-1.90.4.ebuild,v 1.1 2008/12/31 17:05:36 matsuu Exp $
+
+inherit eutils
+
+SLOT="2"
+MY_PN="${PN}${SLOT}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Kita - 2ch client for KDE"
+HOMEPAGE="http://kita.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/kita/33012/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="kde-base/korundum
+ kde-base/qtruby"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gems.patch"
+}
+
+src_install() {
+ local mydir=/usr/share/${MY_PN}
+ exeinto ${mydir}
+ doexe *.rb
+ insinto ${mydir}
+ doins *.kdevelop *.png *.ui
+
+ newicon kita.png ${MY_PN}.png
+ domenu "${FILESDIR}/${MY_PN}.desktop"
+
+ dodoc README.ja
+ make_wrapper ${MY_PN} ./kita.rb ${mydir}
+}