summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2014-09-10 22:14:54 +0000
committerWilliam Hubbs <williamh@gentoo.org>2014-09-10 22:14:54 +0000
commita67686d8b64b0be91f10c6d091705205bf054081 (patch)
tree9125bbe3678adad4748010450f34d6174ca7844f /www-client
parentadding missing subslot dep for libgcrypt to prevent preserved-libs from havin... (diff)
downloadgentoo-2-a67686d8b64b0be91f10c6d091705205bf054081.tar.gz
gentoo-2-a67686d8b64b0be91f10c6d091705205bf054081.tar.bz2
gentoo-2-a67686d8b64b0be91f10c6d091705205bf054081.zip
version bump
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/pybugz/ChangeLog7
-rw-r--r--www-client/pybugz/pybugz-0.11.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/www-client/pybugz/ChangeLog b/www-client/pybugz/ChangeLog
index 83106fa780c5..ee00139ba7b1 100644
--- a/www-client/pybugz/ChangeLog
+++ b/www-client/pybugz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/pybugz
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/pybugz/ChangeLog,v 1.127 2014/09/08 02:54:39 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/pybugz/ChangeLog,v 1.128 2014/09/10 22:14:54 williamh Exp $
+
+*pybugz-0.11.1 (10 Sep 2014)
+
+ 10 Sep 2014; William Hubbs <williamh@gentoo.org> +pybugz-0.11.1.ebuild:
+ version bump
08 Sep 2014; William Hubbs <williamh@gentoo.org> pybugz-0.11.ebuild,
pybugz-9999.ebuild:
diff --git a/www-client/pybugz/pybugz-0.11.1.ebuild b/www-client/pybugz/pybugz-0.11.1.ebuild
new file mode 100644
index 000000000000..ca88bab84516
--- /dev/null
+++ b/www-client/pybugz/pybugz-0.11.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/pybugz/pybugz-0.11.1.ebuild,v 1.1 2014/09/10 22:14:54 williamh Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python3_3 python3_4 )
+PYTHON_REQ_USE="readline(+)"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/williamh/pybugz.git
+ https://github.com/williamh/pybugz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+ inherit vcs-snapshot
+fi
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
+HOMEPAGE="http://www.github.com/williamh/pybugz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND="${DEPEND}
+ zsh-completion? ( app-shells/zsh )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp contrib/bash-completion bugz
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ newins contrib/zsh-completion _pybugz
+ fi
+}