summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-11-04 07:03:12 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-11-04 07:03:12 +0000
commitc62a5852c623e5fb2f7297aaf9c5747381978ee6 (patch)
treedf49b58a4954e25f2589fad05f2eb71d45da40be /www-client
parentRemove older versions (diff)
downloadgentoo-2-c62a5852c623e5fb2f7297aaf9c5747381978ee6.tar.gz
gentoo-2-c62a5852c623e5fb2f7297aaf9c5747381978ee6.tar.bz2
gentoo-2-c62a5852c623e5fb2f7297aaf9c5747381978ee6.zip
Version bumped.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/kazehakase/ChangeLog7
-rw-r--r--www-client/kazehakase/files/digest-kazehakase-0.4.23
-rw-r--r--www-client/kazehakase/kazehakase-0.4.2.ebuild67
3 files changed, 76 insertions, 1 deletions
diff --git a/www-client/kazehakase/ChangeLog b/www-client/kazehakase/ChangeLog
index 7e2623321334..df0434f961f5 100644
--- a/www-client/kazehakase/ChangeLog
+++ b/www-client/kazehakase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/kazehakase
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/ChangeLog,v 1.36 2006/10/04 15:35:01 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/ChangeLog,v 1.37 2006/11/04 07:03:12 matsuu Exp $
+
+*kazehakase-0.4.2 (04 Nov 2006)
+
+ 04 Nov 2006; MATSUU Takuto <matsuu@gentoo.org> +kazehakase-0.4.2.ebuild:
+ Version bumped.
04 Oct 2006; MATSUU Takuto <matsuu@gentoo.org> -kazehakase-0.3.1.ebuild:
Remove old version.
diff --git a/www-client/kazehakase/files/digest-kazehakase-0.4.2 b/www-client/kazehakase/files/digest-kazehakase-0.4.2
new file mode 100644
index 000000000000..aa4a01e87815
--- /dev/null
+++ b/www-client/kazehakase/files/digest-kazehakase-0.4.2
@@ -0,0 +1,3 @@
+MD5 72bbe9efddd0b221fa70c77252ab7e37 kazehakase-0.4.2.tar.gz 1347103
+RMD160 6ce443daf04d091494d0f35101b10c134ac2c4e7 kazehakase-0.4.2.tar.gz 1347103
+SHA256 da2d3b52834bcb4488262930177529aece1721637c70837ee0a4fd796d65e0df kazehakase-0.4.2.tar.gz 1347103
diff --git a/www-client/kazehakase/kazehakase-0.4.2.ebuild b/www-client/kazehakase/kazehakase-0.4.2.ebuild
new file mode 100644
index 000000000000..f35449860cb0
--- /dev/null
+++ b/www-client/kazehakase/kazehakase-0.4.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/kazehakase/kazehakase-0.4.2.ebuild,v 1.1 2006/11/04 07:03:12 matsuu Exp $
+
+IUSE="hyperestraier migemo ruby ssl thumbnail"
+
+DESCRIPTION="a browser with gecko engine like Epiphany or Galeon."
+SRC_URI="mirror://sourceforge.jp/${PN}/22447/${P}.tar.gz"
+HOMEPAGE="http://kazehakase.sourceforge.jp/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+
+DEPEND="|| ( >=www-client/mozilla-firefox-1.0.2-r1
+ >=www-client/seamonkey-1.0
+ >=mail-client/mozilla-thunderbird-0.8
+ >=net-libs/xulrunner-1.8 )
+ >=x11-libs/gtk+-2.6
+ ssl? ( >=net-libs/gnutls-1.2.0 )
+ ruby? ( dev-ruby/ruby-gtk2 dev-ruby/ruby-gettext )"
+
+RDEPEND="${DEPEND}
+ hyperestraier? ( >=app-text/hyperestraier-1.2 )
+ migemo? ( || ( app-text/migemo app-text/cmigemo ) )
+ thumbnail? ( || ( virtual/ghostscript
+ >=www-client/mozilla-firefox-2.0_beta1 ) )"
+
+src_compile(){
+ local myconf
+
+ if use hyperestraier; then
+ myconf="${myconf} --with-search-engine=hyperestraier"
+ else
+ myconf="${myconf} --without-search-engine"
+ fi
+
+ myconf="${myconf} $(use_enable migemo)"
+ use ruby || myconf="${myconf} --with-ruby=no --with-rgettext=no"
+ use ssl || myconf="${myconf} --disable-ssl"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README* TODO*
+}
+
+pkg_postinst(){
+ if use thumbnail; then
+ einfo "To enable thumbnail, "
+ einfo " 1. Go to Preference."
+ einfo " 2. Check \"Create thumbnail\"."
+ einfo
+ ewarn "Creating thumbnail process is still unstable (sometimes causes crash),"
+ ewarn "but most causes of unstability are Mozilla. If you find a crash bug on"
+ ewarn "Kazehakase, please confirm the following:"
+ ewarn
+ ewarn " 1. Load a crash page with Mozilla."
+ ewarn " 2. Print preview the page."
+ ewarn " 3. Close print preview window."
+ ewarn " 4. Print the page to a file."
+ ewarn
+ fi
+}