summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2014-12-11 15:01:11 +0000
committerJason Zaman <perfinion@gentoo.org>2014-12-11 15:01:11 +0000
commitcd26bae3748a03773987e4998936637713650f99 (patch)
tree959887696bacc6c76ee5b7d97bfed05321cd9f4d /www-client
parentManifest (diff)
downloadgentoo-2-cd26bae3748a03773987e4998936637713650f99.tar.gz
gentoo-2-cd26bae3748a03773987e4998936637713650f99.tar.bz2
gentoo-2-cd26bae3748a03773987e4998936637713650f99.zip
fix -9999 to use paxmark.sh
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x7EF137EC935B0EAF)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/luakit/ChangeLog7
-rw-r--r--www-client/luakit/luakit-9999.ebuild11
-rw-r--r--www-client/luakit/metadata.xml1
3 files changed, 12 insertions, 7 deletions
diff --git a/www-client/luakit/ChangeLog b/www-client/luakit/ChangeLog
index 4e288639eb42..58dca5d70515 100644
--- a/www-client/luakit/ChangeLog
+++ b/www-client/luakit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/luakit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/luakit/ChangeLog,v 1.34 2014/05/08 04:05:33 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/luakit/ChangeLog,v 1.35 2014/12/11 15:01:11 perfinion Exp $
+
+ 11 Dec 2014; Jason Zaman <perfinion@gentoo.org> luakit-9999.ebuild,
+ metadata.xml:
+ fix -9999 to use paxmark.sh
08 May 2014; Alex Alexander <wired@gentoo.org> metadata.xml:
maintainer-needed
@@ -161,4 +165,3 @@
12 Aug 2010; Alex Alexander <wired@gentoo.org> +luakit-2010.08.07.ebuild,
+luakit-2010.08.13.ebuild, +luakit-9999.ebuild, +metadata.xml:
new ebuilds for luakit
-
diff --git a/www-client/luakit/luakit-9999.ebuild b/www-client/luakit/luakit-9999.ebuild
index 95560ee9c0ce..aa677e95ef55 100644
--- a/www-client/luakit/luakit-9999.ebuild
+++ b/www-client/luakit/luakit-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/luakit/luakit-9999.ebuild,v 1.23 2013/07/15 18:22:05 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/luakit/luakit-9999.ebuild,v 1.24 2014/12/11 15:01:11 perfinion Exp $
EAPI=4
inherit toolchain-funcs
-IUSE="luajit vim-syntax"
+IUSE="luajit pax_kernel vim-syntax"
if [[ ${PV} == *9999* ]]; then
inherit git-2
@@ -41,6 +41,7 @@ COMMON_DEPEND="
DEPEND="
virtual/pkgconfig
sys-apps/help2man
+ pax_kernel? ( sys-apps/elfix )
${COMMON_DEPEND}
"
@@ -53,8 +54,8 @@ RDEPEND="
src_prepare() {
sed -i -e "/^CFLAGS/s/-ggdb//" config.mk || die
# bug 385471
- sed "s,@\$(CC) -o \$@ \$(OBJS) \$(LDFLAGS),@\$(CC) -o \$@ \$(OBJS)
- \$(LDFLAGS)\n\t\paxctl -Cm luakit,g" -i Makefile
+ use pax_kernel && sed "s,@\$(CC) -o \$@ \$(OBJS) \$(LDFLAGS),@\$(CC) \
+ -o \$@ \$(OBJS) \$(LDFLAGS)\n\tpaxmark.sh -m luakit,g" -i Makefile
}
src_compile() {
diff --git a/www-client/luakit/metadata.xml b/www-client/luakit/metadata.xml
index 735cf12b5895..e417547e3e94 100644
--- a/www-client/luakit/metadata.xml
+++ b/www-client/luakit/metadata.xml
@@ -8,5 +8,6 @@
<flag name="luajit">Use the lua just-in-time compiler
<pkg>dev-lang/luajit</pkg> instead of <pkg>dev-lang/lua</pkg>, which
should make luakit faster.</flag>
+ <flag name="pax_kernel">Use paxctl to mark the luakit binary.</flag>
</use>
</pkgmetadata>