summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-10-18 08:10:30 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-10-18 08:10:30 +0000
commitde3e19ecad27a8cc1170013389edb743ece0a597 (patch)
treef9cdcda498a7a7fcebe0c6b5be829eec07dc4557 /www-client
parent2.1.10.29 version bump. This fixes regressions in 2.1.10.28 and 2.2.0_alpha68 (diff)
downloadgentoo-2-de3e19ecad27a8cc1170013389edb743ece0a597.tar.gz
gentoo-2-de3e19ecad27a8cc1170013389edb743ece0a597.tar.bz2
gentoo-2-de3e19ecad27a8cc1170013389edb743ece0a597.zip
Bump to EAPI-4; use pkg_pretend and make missing sandbox support in kernel fatal if installing the package; add a die hook for better diagnostics and more precise error messages.
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-16.0.904.0-r2.ebuild65
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild65
3 files changed, 105 insertions, 33 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index cae727f31d76..f5c416b34138 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.469 2011/10/17 18:29:58 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.470 2011/10/18 08:10:30 phajdan.jr Exp $
+
+ 18 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ chromium-16.0.904.0-r2.ebuild, chromium-9999-r1.ebuild:
+ Bump to EAPI-4; use pkg_pretend and make missing sandbox support in kernel
+ fatal if installing the package; add a die hook for better diagnostics and
+ more precise error messages.
17 Oct 2011; Andreas Schuerch <nativemad@gentoo.org>
chromium-14.0.835.202.ebuild:
diff --git a/www-client/chromium/chromium-16.0.904.0-r2.ebuild b/www-client/chromium/chromium-16.0.904.0-r2.ebuild
index 23e6103810e9..0a61e3bd9e31 100644
--- a/www-client/chromium/chromium-16.0.904.0-r2.ebuild
+++ b/www-client/chromium/chromium-16.0.904.0-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-16.0.904.0-r2.ebuild,v 1.3 2011/10/15 03:12:32 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-16.0.904.0-r2.ebuild,v 1.4 2011/10/18 08:10:30 phajdan.jr Exp $
-EAPI="3"
+EAPI="4"
PYTHON_DEPEND="2:2.6"
inherit eutils fdo-mime flag-o-matic gnome2-utils linux-info multilib \
@@ -98,29 +98,62 @@ get_installed_v8_version() {
best_version dev-lang/v8 | sed -e 's@dev-lang/v8-@@g'
}
-pkg_setup() {
- CHROMIUM_HOME="/usr/$(get_libdir)/chromium-browser"
+pkg_pretend() {
+ if [[ "${MERGE_TYPE}" == "source" || "${MERGE_TYPE}" == "binary" ]]; then
+ # Fail if the kernel doesn't support features needed for sandboxing,
+ # bug #363907.
+ ERROR_PID_NS="PID_NS is required for sandbox to work"
+ ERROR_NET_NS="NET_NS is required for sandbox to work"
+ CONFIG_CHECK="PID_NS NET_NS"
+ check_extra_config
+ fi
+}
- # Make sure the build system will use the right tools, bug #340795.
- tc-export AR CC CXX RANLIB
+if ! has chromium-pkg_die ${EBUILD_DEATH_HOOKS}; then
+ EBUILD_DEATH_HOOKS+=" chromium-pkg_die";
+fi
- # Make sure the build system will use the right python, bug #344367.
- python_set_active_version 2
- python_pkg_setup
+chromium-pkg_die() {
+ if [[ "${EBUILD_PHASE}" != "compile" ]]; then
+ return
+ fi
# Prevent user problems like bug #348235.
eshopts_push -s extglob
if is-flagq '-g?(gdb)?([1-9])'; then
- ewarn "You have enabled debug info (probably have -g or -ggdb in your \$C{,XX}FLAGS)."
- ewarn "You may experience really long compilation times and/or increased memory usage."
- ewarn "If compilation fails, please try removing -g{,gdb} before reporting a bug."
+ ewarn
+ ewarn "You have enabled debug info (i.e. -g or -ggdb in your CFLAGS/CXXFLAGS)."
+ ewarn "Please try removing -g{,gdb} before reporting a bug."
+ ewarn
fi
eshopts_pop
- # Warn if the kernel doesn't support features useful for sandboxing,
- # bug #363907.
- CONFIG_CHECK="~PID_NS ~NET_NS"
- check_extra_config
+ # ccache often causes bogus compile failures, especially when the cache gets
+ # corrupted.
+ if has ccache ${FEATURES}; then
+ ewarn
+ ewarn "You have enabled ccache. Please try disabling ccache"
+ ewarn "before reporting a bug."
+ ewarn
+ fi
+
+ # If the system doesn't have enough memory, the compilation is known to
+ # fail. Print info about memory to recognize this condition.
+ einfo
+ einfo "$(grep MemTotal /proc/meminfo)"
+ einfo "$(grep SwapTotal /proc/meminfo)"
+ einfo
+}
+
+pkg_setup() {
+ CHROMIUM_HOME="/usr/$(get_libdir)/chromium-browser"
+
+ # Make sure the build system will use the right tools, bug #340795.
+ tc-export AR CC CXX RANLIB
+
+ # Make sure the build system will use the right python, bug #344367.
+ python_set_active_version 2
+ python_pkg_setup
if use bindist; then
elog "bindist enabled: H.264 video support will be disabled."
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index aa225c55bc68..b1109ddb012d 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.60 2011/10/15 03:12:32 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.61 2011/10/18 08:10:30 phajdan.jr Exp $
-EAPI="3"
+EAPI="4"
PYTHON_DEPEND="2:2.6"
inherit eutils fdo-mime flag-o-matic gnome2-utils linux-info multilib \
@@ -150,6 +150,53 @@ get_installed_v8_version() {
best_version dev-lang/v8 | sed -e 's@dev-lang/v8-@@g'
}
+pkg_pretend() {
+ if [[ "${MERGE_TYPE}" == "source" || "${MERGE_TYPE}" == "binary" ]]; then
+ # Fail if the kernel doesn't support features needed for sandboxing,
+ # bug #363907.
+ ERROR_PID_NS="PID_NS is required for sandbox to work"
+ ERROR_NET_NS="NET_NS is required for sandbox to work"
+ CONFIG_CHECK="PID_NS NET_NS"
+ check_extra_config
+ fi
+}
+
+if ! has chromium-pkg_die ${EBUILD_DEATH_HOOKS}; then
+ EBUILD_DEATH_HOOKS+=" chromium-pkg_die";
+fi
+
+chromium-pkg_die() {
+ if [[ "${EBUILD_PHASE}" != "compile" ]]; then
+ return
+ fi
+
+ # Prevent user problems like bug #348235.
+ eshopts_push -s extglob
+ if is-flagq '-g?(gdb)?([1-9])'; then
+ ewarn
+ ewarn "You have enabled debug info (i.e. -g or -ggdb in your CFLAGS/CXXFLAGS)."
+ ewarn "Please try removing -g{,gdb} before reporting a bug."
+ ewarn
+ fi
+ eshopts_pop
+
+ # ccache often causes bogus compile failures, especially when the cache gets
+ # corrupted.
+ if has ccache ${FEATURES}; then
+ ewarn
+ ewarn "You have enabled ccache. Please try disabling ccache"
+ ewarn "before reporting a bug."
+ ewarn
+ fi
+
+ # If the system doesn't have enough memory, the compilation is known to
+ # fail. Print info about memory to recognize this condition.
+ einfo
+ einfo "$(grep MemTotal /proc/meminfo)"
+ einfo "$(grep SwapTotal /proc/meminfo)"
+ einfo
+}
+
pkg_setup() {
SUFFIX="-${SLOT}"
CHROMIUM_HOME="/usr/$(get_libdir)/chromium-browser${SUFFIX}"
@@ -161,20 +208,6 @@ pkg_setup() {
python_set_active_version 2
python_pkg_setup
- # Prevent user problems like bug #348235.
- eshopts_push -s extglob
- if is-flagq '-g?(gdb)?([1-9])'; then
- ewarn "You have enabled debug info (probably have -g or -ggdb in your \$C{,XX}FLAGS)."
- ewarn "You may experience really long compilation times and/or increased memory usage."
- ewarn "If compilation fails, please try removing -g{,gdb} before reporting a bug."
- fi
- eshopts_pop
-
- # Warn if the kernel doesn't support features useful for sandboxing,
- # bug #363907.
- CONFIG_CHECK="~PID_NS ~NET_NS"
- check_extra_config
-
if use bindist; then
elog "bindist enabled: H.264 video support will be disabled."
else