summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephanie J. Lockwood-Childs <wormo@gentoo.org>2010-01-11 06:55:05 +0000
committerStephanie J. Lockwood-Childs <wormo@gentoo.org>2010-01-11 06:55:05 +0000
commite16c6a7e5fb20fc73e9a258cdd5011765c61f32c (patch)
tree27ad81e16182b3bc69c627708f70b37f3a6a34bf /www-client
parentVersion bump (bug #300564). (diff)
downloadgentoo-2-e16c6a7e5fb20fc73e9a258cdd5011765c61f32c.tar.gz
gentoo-2-e16c6a7e5fb20fc73e9a258cdd5011765c61f32c.tar.bz2
gentoo-2-e16c6a7e5fb20fc73e9a258cdd5011765c61f32c.zip
New version that enables session features by default, thanks
to Martin Mokrejs for requesting session support and to lynx author Thomas Dickey for pointing out that it is now considered stable enough to be enabled by default (bug #292164) (Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/lynx/ChangeLog13
-rw-r--r--www-client/lynx/lynx-2.8.8_pre2.ebuild128
2 files changed, 139 insertions, 2 deletions
diff --git a/www-client/lynx/ChangeLog b/www-client/lynx/ChangeLog
index 8d6df8bb5b47..00a539343a98 100644
--- a/www-client/lynx/ChangeLog
+++ b/www-client/lynx/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for www-client/lynx
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.100 2009/10/05 06:47:54 wormo Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.101 2010/01/11 06:55:05 wormo Exp $
+
+*lynx-2.8.8_pre2 (11 Jan 2010)
+
+ 11 Jan 2010; Stephanie Lockwood-Childs <wormo@gentoo.org>
+ +lynx-2.8.8_pre2.ebuild:
+ New version that enables session features by default, thanks
+ to Martin Mokrejs for requesting session support and to lynx author
+ Thomas Dickey for pointing out that it is now considered stable enough
+ to be enabled by default (bug #292164)
05 Oct 2009; Stephanie Lockwood-Childs <wormo@gentoo.org>
+files/lynx-2.8.7-include-locale.patch, lynx-2.8.7_p1.ebuild:
diff --git a/www-client/lynx/lynx-2.8.8_pre2.ebuild b/www-client/lynx/lynx-2.8.8_pre2.ebuild
new file mode 100644
index 000000000000..c248ec51fe19
--- /dev/null
+++ b/www-client/lynx/lynx-2.8.8_pre2.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.8_pre2.ebuild,v 1.1 2010/01/11 06:55:05 wormo Exp $
+
+EAPI=2
+
+inherit eutils versionator
+
+# VERSIONING SCHEME TRANSLATION
+# Upstream : Gentoo
+# rel. : _p
+# pre. : _rc
+# dev. : _pre
+
+if [[ "${PV/_p[0-9]}" != "${PV}" ]]
+then
+ MY_P="${PN}${PV/_p/rel.}"
+
+elif [[ "${PV/_rc[0-9]}" != "${PV}" ]]
+then
+ MY_P="${PN}${PV/_rc/pre.}"
+
+elif [[ "${PV/_pre[0-9]}" != "${PV}" ]]
+then
+ MY_P="${PN}${PV/_pre/dev.}"
+
+fi
+
+DESCRIPTION="An excellent console-based web browser with ssl support"
+HOMEPAGE="http://lynx.isc.org/"
+SRC_URI="http://lynx.isc.org/current/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="bzip2 cjk gnutls ipv6 nls ssl unicode"
+
+RDEPEND="sys-libs/ncurses[unicode?]
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ ssl? (
+ !gnutls? ( >=dev-libs/openssl-0.9.8 )
+ gnutls? ( >=net-libs/gnutls-2.6.4 )
+ )
+ bzip2? ( app-arch/bzip2 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/pkgconfig-0.23"
+
+S="${WORKDIR}/${PN}$(replace_all_version_separators - $(get_version_component_range 1-3))"
+
+pkg_setup() {
+ if ! use ssl
+ then
+ elog "SSL support disabled; you will not be able to access secure websites."
+ fi
+}
+
+src_prepare() {
+ # fix up toplevel makefile to enable parallel make (bug #262972)
+ #
+ # add '+' prefix to lines using $(MAKE_RECUR),
+ # making sure '+' comes after leading whitespace
+ sed -i -e '/$(MAKE_RECUR)/ s/\([[:blank:]]\)/\1+/' makefile.in || \
+ die "failed to update makefile.in"
+
+ # fix configure for openssl compiled with kerberos (bug #267749)
+ epatch "${FILESDIR}/lynx-2.8.7-configure-openssl.patch"
+}
+
+src_configure() {
+ local myargs
+
+ if use ssl
+ then
+ # --with-gnutls and --with-ssl are alternatives,
+ # the latter enabling openssl support so it should be
+ # _not_ be used if gnutls ssl implementation is desired
+ if use gnutls
+ then
+ myargs="$myargs --with-gnutls" # ssl implementation = gnutls
+ else
+ myargs="$myargs --with-ssl" # ssl implementation = openssl
+ fi
+ fi
+
+ if use unicode
+ then
+ myargs="$myargs --with-screen=ncursesw"
+ fi
+
+ econf \
+ --enable-cgi-links \
+ --enable-persistent-cookies \
+ --enable-prettysrc \
+ --enable-nsl-fork \
+ --enable-file-upload \
+ --enable-read-eta \
+ --enable-color-style \
+ --enable-scrollbar \
+ --enable-included-msgs \
+ --with-zlib \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_enable cjk) \
+ $(use_enable unicode japanese-utf8) \
+ $(use_with bzip2 bzlib) \
+ $myargs
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ sed -i -e "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
+ "${D}"/etc/lynx.cfg || die "lynx.cfg not found"
+ if use unicode
+ then
+ sed -i -e '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
+ "${D}"/etc/lynx.cfg || die "lynx.cfg not found"
+ fi
+ dodoc CHANGES COPYHEADER PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ dohtml -r lynx_help/*
+}