summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2015-03-01 01:44:10 +0000
committerIan Stakenvicius <axs@gentoo.org>2015-03-01 01:44:10 +0000
commite583d77767ac4896e9b060407f55a2871fe75e41 (patch)
tree068516be87fa0c0de8dc1d5d995722b583cd6870 /www-client
parentvanilla-3.18.8 + genpatches-3.18-10 + grsecurity-3.1-3.18.8-201502271843 (diff)
downloadgentoo-2-e583d77767ac4896e9b060407f55a2871fe75e41.tar.gz
gentoo-2-e583d77767ac4896e9b060407f55a2871fe75e41.tar.bz2
gentoo-2-e583d77767ac4896e9b060407f55a2871fe75e41.zip
dropped USE=jit from firefox-36.0 as disabling jit is not supported according to upstream, also added configure flags to enable the jit simulators for arm and mips; works around bug 541534
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/ChangeLog7
-rw-r--r--www-client/firefox/firefox-36.0.ebuild25
2 files changed, 18 insertions, 14 deletions
diff --git a/www-client/firefox/ChangeLog b/www-client/firefox/ChangeLog
index 1c6710fad527..43ce9bdff92f 100644
--- a/www-client/firefox/ChangeLog
+++ b/www-client/firefox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/firefox
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/ChangeLog,v 1.389 2015/02/27 13:25:27 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/ChangeLog,v 1.390 2015/03/01 01:44:10 axs Exp $
+
+ 01 Mar 2015; Ian Stakenvicius (_AxS_) <axs@gentoo.org> firefox-36.0.ebuild:
+ dropped USE=jit from firefox-36.0 as disabling jit is not supported according
+ to upstream, also added configure flags to enable the jit simulators for arm
+ and mips; works around bug 541534
27 Feb 2015; Agostino Sarubbo <ago@gentoo.org> firefox-31.5.0.ebuild:
Stable for amd64, wrt bug #541316
diff --git a/www-client/firefox/firefox-36.0.ebuild b/www-client/firefox/firefox-36.0.ebuild
index f7058f246e01..b616bb66a083 100644
--- a/www-client/firefox/firefox-36.0.ebuild
+++ b/www-client/firefox/firefox-36.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-36.0.ebuild,v 1.3 2015/02/27 08:36:41 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-36.0.ebuild,v 1.4 2015/03/01 01:44:10 axs Exp $
EAPI="5"
VIRTUALX_REQUIRED="pgo"
@@ -34,7 +34,7 @@ MOZ_FTP_URI="ftp://ftp.mozilla.org/pub/${PN}/releases/"
MOZ_HTTP_URI="http://ftp.mozilla.org/pub/${PN}/releases/"
MOZCONFIG_OPTIONAL_WIFI=1
-MOZCONFIG_OPTIONAL_JIT="enabled"
+# No longer optional -- MOZCONFIG_OPTIONAL_JIT="enabled"
inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils mozconfig-v5.36 multilib pax-utils fdo-mime autotools virtualx mozlinguas
@@ -131,13 +131,6 @@ pkg_pretend() {
CHECKREQS_DISK_BUILD="4G"
fi
check-reqs_pkg_setup
-
- if use jit && [[ -n ${PROFILE_IS_HARDENED} ]]; then
- ewarn "You are emerging this package on a hardened profile with USE=jit enabled."
- ewarn "This is horribly insecure as it disables all PAGEEXEC restrictions."
- ewarn "Please ensure you know what you are doing. If you don't, please consider"
- ewarn "emerging the package with USE=-jit"
- fi
}
src_unpack() {
@@ -229,6 +222,12 @@ src_configure() {
# Other ff-specific settings
mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
+ # Force jit
+ mozconfig_annotate '' --enable-ion
+ # Force jit simulators for mips and arm
+ use arm && mozconfig_annotate '' --enable-arm-simulator
+ use mips && mozconfig_annotate '' --enable-mips-simulator
+
# Allow for a proper pgo build
if use pgo; then
echo "mk_add_options PROFILE_GEN_SCRIPT='\$(PYTHON) \$(OBJDIR)/_profile/pgo/profileserver.py'" >> "${S}"/.mozconfig
@@ -355,11 +354,11 @@ src_install() {
fi
# Required in order to use plugins and even run firefox on hardened.
- if use jit; then
+# if use jit; then
pax-mark m "${ED}"${MOZILLA_FIVE_HOME}/{firefox,firefox-bin,plugin-container}
- else
- pax-mark m "${ED}"${MOZILLA_FIVE_HOME}/plugin-container
- fi
+# else
+# pax-mark m "${ED}"${MOZILLA_FIVE_HOME}/plugin-container
+# fi
if use minimal; then
rm -r "${ED}"/usr/include "${ED}${MOZILLA_FIVE_HOME}"/{idl,include,lib,sdk} \