summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-02-12 23:03:50 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-02-12 23:03:50 +0000
commit10706320f5fdb3701f859e7fa700952c70a84693 (patch)
tree3a8dd106c596aede935bd6b9d69d8415e41785fd /www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild
parentBugfixes. (diff)
downloadgentoo-2-10706320f5fdb3701f859e7fa700952c70a84693.tar.gz
gentoo-2-10706320f5fdb3701f859e7fa700952c70a84693.tar.bz2
gentoo-2-10706320f5fdb3701f859e7fa700952c70a84693.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild')
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild
new file mode 100644
index 000000000000..ea862a65f409
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/profile-sync-daemon/profile-sync-daemon-5.45.1.ebuild,v 1.1 2014/02/12 23:03:50 hasufell Exp $
+
+EAPI=5
+
+inherit eutils vcs-snapshot
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
+SRC_URI="https://github.com/graysky2/profile-sync-daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync
+ systemd? ( sys-apps/systemd )"
+
+src_install() {
+ emake -j1 DESTDIR="${ED}" \
+ install-openrc-all \
+ $(usex systemd "install-systemd" "")
+
+ fperms -x /etc/cron.hourly/psd-update
+}
+
+pkg_postinst() {
+ elog "The cronjob is -x by default."
+ elog "You might want to set it +x if you don't use"
+ elog "the systemd provided \"psd-resync.timer\"."
+}