summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-10-08 01:19:46 +0000
committerTim Harder <radhermit@gentoo.org>2014-10-08 01:19:46 +0000
commitbee283a6efd0e0d8453a579294e3d68d0ea79657 (patch)
tree523098cfb66f8c32c0da8aa0291709ef5f47aed8 /www-misc
parentMark stable on amd64. See bug #522520. (diff)
downloadgentoo-2-bee283a6efd0e0d8453a579294e3d68d0ea79657.tar.gz
gentoo-2-bee283a6efd0e0d8453a579294e3d68d0ea79657.tar.bz2
gentoo-2-bee283a6efd0e0d8453a579294e3d68d0ea79657.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/urlwatch/ChangeLog7
-rw-r--r--www-misc/urlwatch/urlwatch-1.17.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/www-misc/urlwatch/ChangeLog b/www-misc/urlwatch/ChangeLog
index 30c811cdd730..6f60ad28d5ae 100644
--- a/www-misc/urlwatch/ChangeLog
+++ b/www-misc/urlwatch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-misc/urlwatch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/ChangeLog,v 1.6 2014/04/03 02:09:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/ChangeLog,v 1.7 2014/10/08 01:19:46 radhermit Exp $
+
+*urlwatch-1.17 (08 Oct 2014)
+
+ 08 Oct 2014; Tim Harder <radhermit@gentoo.org> +urlwatch-1.17.ebuild:
+ Version bump.
03 Apr 2014; Tim Harder <radhermit@gentoo.org> urlwatch-1.16.ebuild:
Add python3_4 support.
diff --git a/www-misc/urlwatch/urlwatch-1.17.ebuild b/www-misc/urlwatch/urlwatch-1.17.ebuild
new file mode 100644
index 000000000000..85f6097099e8
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-1.17.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/urlwatch-1.17.ebuild,v 1.1 2014/10/08 01:19:46 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="http://thp.io/2008/urlwatch/ http://pypi.python.org/pypi/urlwatch"
+SRC_URI="http://thp.io/2008/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/python-futures[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ || ( www-client/lynx app-text/html2text )"
+
+python_prepare() {
+ if [[ ${EPYTHON} == python3.* ]]; then
+ 2to3 -nw --no-diffs urlwatch lib/urlwatch/*.py \
+ share/urlwatch/examples/hooks.py.example setup.py || die
+ fi
+}