summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-12-12 21:21:38 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-12-12 21:21:38 +0000
commit858bec80df419b4b82ba9a5952f2a913a373feb8 (patch)
treeaa8f9dcd00cd18529bd7b8d8fa3813da45fd1f49 /www-plugins/lightspark
parentInitial commit, ebuild by me. (diff)
downloadgentoo-2-858bec80df419b4b82ba9a5952f2a913a373feb8.tar.gz
gentoo-2-858bec80df419b4b82ba9a5952f2a913a373feb8.tar.bz2
gentoo-2-858bec80df419b4b82ba9a5952f2a913a373feb8.zip
Work around llvm-2.8 issue with gcc-4.5, bug #348552
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/lightspark')
-rw-r--r--www-plugins/lightspark/ChangeLog6
-rw-r--r--www-plugins/lightspark/files/lightspark-0.4.5-llvm-2.8-gcc-4.5.patch11
-rw-r--r--www-plugins/lightspark/lightspark-0.4.5.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/www-plugins/lightspark/ChangeLog b/www-plugins/lightspark/ChangeLog
index 0b42bd0febba..8e69f8ea46ad 100644
--- a/www-plugins/lightspark/ChangeLog
+++ b/www-plugins/lightspark/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-plugins/lightspark
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.20 2010/12/12 16:09:37 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/ChangeLog,v 1.21 2010/12/12 21:21:38 chithanh Exp $
+
+ 12 Dec 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ lightspark-0.4.5.ebuild, +files/lightspark-0.4.5-llvm-2.8-gcc-4.5.patch:
+ Work around llvm-2.8 issue with gcc-4.5, bug #348552
*lightspark-0.4.5 (12 Dec 2010)
diff --git a/www-plugins/lightspark/files/lightspark-0.4.5-llvm-2.8-gcc-4.5.patch b/www-plugins/lightspark/files/lightspark-0.4.5-llvm-2.8-gcc-4.5.patch
new file mode 100644
index 000000000000..3882a0ae226a
--- /dev/null
+++ b/www-plugins/lightspark/files/lightspark-0.4.5-llvm-2.8-gcc-4.5.patch
@@ -0,0 +1,11 @@
+diff -ur a/scripting/abc.h b/scripting/abc.h
+--- a/scripting/abc.h 2010-12-08 17:55:46.000000000 +0100
++++ b/scripting/abc.h 2010-12-12 21:49:56.549000030 +0100
+@@ -19,6 +19,7 @@
+
+ #ifndef _ABC_H
+ #define _ABC_H
++#define alignof _alignof
+
+ #include "compat.h"
+ #include <llvm/Module.h>
diff --git a/www-plugins/lightspark/lightspark-0.4.5.ebuild b/www-plugins/lightspark/lightspark-0.4.5.ebuild
index 3fd1c2e0b621..450382a49eca 100644
--- a/www-plugins/lightspark/lightspark-0.4.5.ebuild
+++ b/www-plugins/lightspark/lightspark-0.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.5.ebuild,v 1.1 2010/12/12 16:09:36 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/lightspark/lightspark-0.4.5.ebuild,v 1.2 2010/12/12 21:21:38 chithanh Exp $
EAPI=3
inherit cmake-utils nsplugins multilib
@@ -45,6 +45,7 @@ S=${WORKDIR}/${P/_rc*/}
PATCHES=(
"${FILESDIR}"/${PN}-0.4.4.3-cmakelists.patch
"${FILESDIR}"/${PN}-0.4.5-allow-disabling-pulseaudio.patch
+ "${FILESDIR}"/${PN}-0.4.5-llvm-2.8-gcc-4.5.patch
)
src_configure() {