summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2015-02-08 16:05:41 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2015-02-08 16:05:41 +0000
commitf83d76a2cdcc4795bf69129eb6605bba096ebde0 (patch)
tree27cb31f1df8266a86e91a6b8abd7255d65962d9f /www-plugins
parentVersion bump. (diff)
downloadgentoo-2-f83d76a2cdcc4795bf69129eb6605bba096ebde0.tar.gz
gentoo-2-f83d76a2cdcc4795bf69129eb6605bba096ebde0.tar.bz2
gentoo-2-f83d76a2cdcc4795bf69129eb6605bba096ebde0.zip
Add support for widevine
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/chrome-binary-plugins/ChangeLog8
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-40.0.2214.111_p1.ebuild10
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-41.0.2272.43_beta1.ebuild10
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-42.0.2292.0_alpha1.ebuild10
-rw-r--r--www-plugins/chrome-binary-plugins/metadata.xml1
5 files changed, 32 insertions, 7 deletions
diff --git a/www-plugins/chrome-binary-plugins/ChangeLog b/www-plugins/chrome-binary-plugins/ChangeLog
index ddcca2a69191..3d5bada8df47 100644
--- a/www-plugins/chrome-binary-plugins/ChangeLog
+++ b/www-plugins/chrome-binary-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-plugins/chrome-binary-plugins
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.220 2015/02/06 15:29:44 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/ChangeLog,v 1.221 2015/02/08 16:05:41 zx2c4 Exp $
+
+ 08 Feb 2015; Jason A. Donenfeld <zx2c4@gentoo.org>
+ chrome-binary-plugins-40.0.2214.111_p1.ebuild,
+ chrome-binary-plugins-41.0.2272.43_beta1.ebuild,
+ chrome-binary-plugins-42.0.2292.0_alpha1.ebuild, metadata.xml:
+ Add support for widevine
*chrome-binary-plugins-41.0.2272.43_beta1 (06 Feb 2015)
*chrome-binary-plugins-40.0.2214.111_p1 (06 Feb 2015)
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-40.0.2214.111_p1.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-40.0.2214.111_p1.ebuild
index 1ba318ffa126..c27cdb2da69e 100644
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-40.0.2214.111_p1.ebuild
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-40.0.2214.111_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-40.0.2214.111_p1.ebuild,v 1.1 2015/02/06 15:29:44 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-40.0.2214.111_p1.ebuild,v 1.2 2015/02/08 16:05:41 zx2c4 Exp $
EAPI=5
@@ -46,7 +46,7 @@ KEYWORDS="~amd64 ~x86"
fi
LICENSE="google-chrome"
-IUSE="+flash"
+IUSE="+flash +widevine"
RESTRICT="bindist mirror strip"
for x in 0 beta stable unstable; do
@@ -76,6 +76,12 @@ src_install() {
insinto /usr/$(get_libdir)/chromium-browser/
+ if use widevine; then
+ doins libwidevinecdm.so
+ strings ./chrome | grep -C 1 " (version:" | tail -1 > widevine.version
+ doins widevine.version
+ fi
+
if use flash; then
doins -r PepperFlash
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-41.0.2272.43_beta1.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-41.0.2272.43_beta1.ebuild
index 2d4d265e5405..e605308e585f 100644
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-41.0.2272.43_beta1.ebuild
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-41.0.2272.43_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-41.0.2272.43_beta1.ebuild,v 1.1 2015/02/06 15:29:44 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-41.0.2272.43_beta1.ebuild,v 1.2 2015/02/08 16:05:41 zx2c4 Exp $
EAPI=5
@@ -46,7 +46,7 @@ KEYWORDS="~amd64 ~x86"
fi
LICENSE="google-chrome"
-IUSE="+flash"
+IUSE="+flash +widevine"
RESTRICT="bindist mirror strip"
for x in 0 beta stable unstable; do
@@ -76,6 +76,12 @@ src_install() {
insinto /usr/$(get_libdir)/chromium-browser/
+ if use widevine; then
+ doins libwidevinecdm.so
+ strings ./chrome | grep -C 1 " (version:" | tail -1 > widevine.version
+ doins widevine.version
+ fi
+
if use flash; then
doins -r PepperFlash
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-42.0.2292.0_alpha1.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-42.0.2292.0_alpha1.ebuild
index eaab1cc2b70a..410ca103bf89 100644
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-42.0.2292.0_alpha1.ebuild
+++ b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-42.0.2292.0_alpha1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-42.0.2292.0_alpha1.ebuild,v 1.1 2015/02/04 02:12:49 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/chrome-binary-plugins/chrome-binary-plugins-42.0.2292.0_alpha1.ebuild,v 1.2 2015/02/08 16:05:41 zx2c4 Exp $
EAPI=5
@@ -46,7 +46,7 @@ KEYWORDS="~amd64 ~x86"
fi
LICENSE="google-chrome"
-IUSE="+flash"
+IUSE="+flash +widevine"
RESTRICT="bindist mirror strip"
for x in 0 beta stable unstable; do
@@ -76,6 +76,12 @@ src_install() {
insinto /usr/$(get_libdir)/chromium-browser/
+ if use widevine; then
+ doins libwidevinecdm.so
+ strings ./chrome | grep -C 1 " (version:" | tail -1 > widevine.version
+ doins widevine.version
+ fi
+
if use flash; then
doins -r PepperFlash
diff --git a/www-plugins/chrome-binary-plugins/metadata.xml b/www-plugins/chrome-binary-plugins/metadata.xml
index 527cd54ff5ba..09868e174618 100644
--- a/www-plugins/chrome-binary-plugins/metadata.xml
+++ b/www-plugins/chrome-binary-plugins/metadata.xml
@@ -12,5 +12,6 @@
</maintainer>
<use>
<flag name="flash">Install Chrome's native Pepper Flash</flag>
+ <flag name="widevine">Install the Widevine DRM library</flag>
</use>
</pkgmetadata>