summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-20 04:22:47 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-20 04:22:47 +0000
commit70edb74cf541d05a0b0c29276232abefb635c772 (patch)
treecd26e09a7ece23d24a6af4d960950b86503b52e5 /www-servers/apache
parentBump (but leave masked) for #412481 (diff)
downloadgentoo-2-70edb74cf541d05a0b0c29276232abefb635c772.tar.gz
gentoo-2-70edb74cf541d05a0b0c29276232abefb635c772.tar.bz2
gentoo-2-70edb74cf541d05a0b0c29276232abefb635c772.zip
Fix for #412481
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'www-servers/apache')
-rw-r--r--www-servers/apache/ChangeLog8
-rw-r--r--www-servers/apache/apache-2.2.22-r1.ebuild110
-rw-r--r--www-servers/apache/files/2.2.22-envvars-std.in28
3 files changed, 145 insertions, 1 deletions
diff --git a/www-servers/apache/ChangeLog b/www-servers/apache/ChangeLog
index 07428281de07..e6c1fece51ea 100644
--- a/www-servers/apache/ChangeLog
+++ b/www-servers/apache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/apache
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.191 2012/04/20 03:58:46 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.192 2012/04/20 04:22:46 patrick Exp $
+
+*apache-2.2.22-r1 (20 Apr 2012)
+
+ 20 Apr 2012; Patrick Lauer <patrick@gentoo.org> +apache-2.2.22-r1.ebuild,
+ +files/2.2.22-envvars-std.in:
+ Fix for #412481
*apache-2.4.2 (20 Apr 2012)
diff --git a/www-servers/apache/apache-2.2.22-r1.ebuild b/www-servers/apache/apache-2.2.22-r1.ebuild
new file mode 100644
index 000000000000..91567b9432a0
--- /dev/null
+++ b/www-servers/apache/apache-2.2.22-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.2.22-r1.ebuild,v 1.1 2012/04/20 04:22:46 patrick Exp $
+
+EAPI="2"
+
+# latest gentoo apache files
+GENTOO_PATCHSTAMP="20120213"
+GENTOO_DEVELOPER="jmbsvicetto"
+GENTOO_PATCHNAME="gentoo-apache-2.2.22"
+
+# IUSE/USE_EXPAND magic
+IUSE_MPMS_FORK="itk peruser prefork"
+IUSE_MPMS_THREAD="event worker"
+
+IUSE_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon
+authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
+authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta
+charset_lite cgi cgid dav dav_fs dav_lock dbd deflate dir disk_cache dumpio
+env expires ext_filter file_cache filter headers ident imagemap include info
+log_config log_forensic logio mem_cache mime mime_magic negotiation proxy
+proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http proxy_scgi rewrite
+reqtimeout setenvif speling status substitute unique_id userdir usertrack
+version vhost_alias"
+# The following are also in the source as of this version, but are not available
+# for user selection:
+# bucketeer case_filter case_filter_in echo http isapi optional_fn_export
+# optional_fn_import optional_hook_export optional_hook_import
+
+# inter-module dependencies
+# TODO: this may still be incomplete
+MODULE_DEPENDS="
+ dav_fs:dav
+ dav_lock:dav
+ deflate:filter
+ disk_cache:cache
+ ext_filter:filter
+ file_cache:cache
+ log_forensic:log_config
+ logio:log_config
+ mem_cache:cache
+ mime_magic:mime
+ proxy_ajp:proxy
+ proxy_balancer:proxy
+ proxy_connect:proxy
+ proxy_ftp:proxy
+ proxy_http:proxy
+ proxy_scgi:proxy
+ substitute:filter
+"
+
+# module<->define mappings
+MODULE_DEFINES="
+ auth_digest:AUTH_DIGEST
+ authnz_ldap:AUTHNZ_LDAP
+ cache:CACHE
+ dav:DAV
+ dav_fs:DAV
+ dav_lock:DAV
+ disk_cache:CACHE
+ file_cache:CACHE
+ info:INFO
+ ldap:LDAP
+ mem_cache:CACHE
+ proxy:PROXY
+ proxy_ajp:PROXY
+ proxy_balancer:PROXY
+ proxy_connect:PROXY
+ proxy_ftp:PROXY
+ proxy_http:PROXY
+ ssl:SSL
+ status:STATUS
+ suexec:SUEXEC
+ userdir:USERDIR
+"
+
+# critical modules for the default config
+MODULE_CRITICAL="
+ authz_host
+ dir
+ mime
+"
+
+inherit apache-2
+
+DESCRIPTION="The Apache Web Server."
+HOMEPAGE="http://httpd.apache.org/"
+
+# some helper scripts are Apache-1.1, thus both are here
+LICENSE="Apache-2.0 Apache-1.1"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=dev-libs/openssl-0.9.8m
+ apache2_modules_deflate? ( sys-libs/zlib )"
+
+# dependency on >=dev-libs/apr-1.4.5 for bug #368651
+RDEPEND="${RDEPEND}
+ >=dev-libs/apr-1.4.5
+ >=dev-libs/openssl-0.9.8m
+ apache2_modules_mime? ( app-misc/mime-types )"
+
+# init script fixup - should be rolled into next tarball #389965
+src_prepare() {
+ apache-2_src_prepare
+ sed -i -e 's/! test -f/test -f/' "${GENTOO_PATCHDIR}"/init/apache2.initd || die "Failed to fix init script"
+ cp ${FILESDIR}/2.2.22-envvars-std.in ${S}/support/envvars-std.in || die "Failed to apply LD_PRELOAD fix"
+}
diff --git a/www-servers/apache/files/2.2.22-envvars-std.in b/www-servers/apache/files/2.2.22-envvars-std.in
new file mode 100644
index 000000000000..9493bc749ca2
--- /dev/null
+++ b/www-servers/apache/files/2.2.22-envvars-std.in
@@ -0,0 +1,28 @@
+# Licensed to the Apache Software Foundation (ASF) under one or more
+# contributor license agreements. See the NOTICE file distributed with
+# this work for additional information regarding copyright ownership.
+# The ASF licenses this file to You under the Apache License, Version 2.0
+# (the "License"); you may not use this file except in compliance with
+# the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+#
+# envvars-std - default environment variables for apachectl
+#
+# This file is generated from envvars-std.in
+#
+if test "x$@SHLIBPATH_VAR@" != "x" ; then
+ @SHLIBPATH_VAR@="@exp_libdir@:$@SHLIBPATH_VAR@"
+else
+ @SHLIBPATH_VAR@="@exp_libdir@"
+fi
+export @SHLIBPATH_VAR@
+#
+@OS_SPECIFIC_VARS@