summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-05-28 23:52:23 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-05-28 23:52:23 +0000
commitf6e2d43cb436d44eb49c4eb5477b92be995ba9b9 (patch)
treef1c808c00d573cbb1bf82fa0ef1c0f64b567341e /www-servers/monkeyd
parentold gtk+:1 packages missed in the purge (diff)
downloadgentoo-2-f6e2d43cb436d44eb49c4eb5477b92be995ba9b9.tar.gz
gentoo-2-f6e2d43cb436d44eb49c4eb5477b92be995ba9b9.tar.bz2
gentoo-2-f6e2d43cb436d44eb49c4eb5477b92be995ba9b9.zip
Incorporate suggestions from gentoo-dev ML, thanks mgorny
(Portage version: 2.1.11.62/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-servers/monkeyd')
-rw-r--r--www-servers/monkeyd/ChangeLog7
-rw-r--r--www-servers/monkeyd/metadata.xml2
-rw-r--r--www-servers/monkeyd/monkeyd-1.2.0.ebuild18
3 files changed, 16 insertions, 11 deletions
diff --git a/www-servers/monkeyd/ChangeLog b/www-servers/monkeyd/ChangeLog
index 0b8279e7ceee..0b62dbec0fa5 100644
--- a/www-servers/monkeyd/ChangeLog
+++ b/www-servers/monkeyd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-servers/monkeyd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.52 2013/05/28 12:55:02 blueness Exp $
+# Copyright 1999- Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.53 2013/05/28 23:52:23 blueness Exp $
+
+ ; Anthony G. Basile <blueness@gentoo.org> metadata.xml, monkeyd-1.2.0.ebuild:
+ Incorporate suggestions from gentoo-dev ML, thanks mgorny
*monkeyd-1.2.0 (28 May 2013)
diff --git a/www-servers/monkeyd/metadata.xml b/www-servers/monkeyd/metadata.xml
index 0f40c54bf1e1..560c188cd6b4 100644
--- a/www-servers/monkeyd/metadata.xml
+++ b/www-servers/monkeyd/metadata.xml
@@ -7,6 +7,6 @@
</maintainer>
<use>
<flag name="debug">Enable lots of debugging info</flag>
- <flag name="shared-lib">Install shared lib</flag>
+ <flag name="minimal">Do not install shared lib and include files</flag>
</use>
</pkgmetadata>
diff --git a/www-servers/monkeyd/monkeyd-1.2.0.ebuild b/www-servers/monkeyd/monkeyd-1.2.0.ebuild
index a80f8afe0ed7..e6865987a8ba 100644
--- a/www-servers/monkeyd/monkeyd-1.2.0.ebuild
+++ b/www-servers/monkeyd/monkeyd-1.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999- Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-1.2.0.ebuild,v 1.1 2013/05/28 12:55:02 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-1.2.0.ebuild,v 1.2 2013/05/28 23:52:23 blueness Exp $
EAPI="5"
@@ -15,13 +15,15 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
-PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah cgi monkeyd_plugins_dirlisting fastcgi
-monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_polarssl"
-IUSE="-debug php shared-lib uclibc ${PLUGINS}"
+PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah cgi monkeyd_plugins_dirlisting fastcgi monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_polarssl"
+IUSE="-debug php minimal ssl uclibc ${PLUGINS}"
# uclibc is often compiled without backtrace info so we should
# force this off. If someone complains, consider relaxing it.
-REQUIRED_USE="uclibc? ( !debug )"
+REQUIRED_USE="
+ uclibc? ( !debug )
+ ssl? ( monkeyd_plugins_polarssl )
+"
RDEPEND="php? ( dev-lang/php )"
@@ -50,7 +52,7 @@ src_prepare() {
sed -i -e '/$STRIP /d' -e 's/install -s -m 644/install -m 755/' configure || die "No configure file"
# We don't need the includes, sym link to libmonkey.so, or monkey.cp when not installing the .so
- use shared-lib || {
+ use minimal && {
sed -i '/install -d \\$(INCDIR)/d' configure || die "No configure file"
sed -i '/install -m 644 src\/include\/\*.h \\$(INCDIR)/d' configure || die "No configure file"
sed -i '/ln -sf/d' configure || die "No configure file"
@@ -80,7 +82,7 @@ src_configure() {
myconf+=" --no-backtrace"
fi
- use shared-lib && myconf+=" --enable-shared"
+ use minimal || myconf+=" --enable-shared"
local enable_plugins=""
local disable_plugins=""