summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-11-02 10:19:15 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-11-02 10:19:15 +0000
commit35ee958559cfe68842f963119cb6c331ebc2983a (patch)
tree5130795fe005896d89c6be648a78b448f9494235 /www-servers/tomcat
parentRemove sec-policy/selinux-* dependency from DEPEND but keep in RDEPEND (bug #... (diff)
downloadgentoo-2-35ee958559cfe68842f963119cb6c331ebc2983a.tar.gz
gentoo-2-35ee958559cfe68842f963119cb6c331ebc2983a.tar.bz2
gentoo-2-35ee958559cfe68842f963119cb6c331ebc2983a.zip
Version bump to 7.0.56
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'www-servers/tomcat')
-rw-r--r--www-servers/tomcat/ChangeLog8
-rw-r--r--www-servers/tomcat/files/tomcat-7.0.56-build.xml.patch126
-rw-r--r--www-servers/tomcat/tomcat-7.0.56.ebuild141
3 files changed, 274 insertions, 1 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index ca1e552cc842..f77f64f80abb 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/tomcat
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.329 2014/11/02 08:05:27 ercpe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.330 2014/11/02 10:19:15 ercpe Exp $
+
+*tomcat-7.0.56 (02 Nov 2014)
+
+ 02 Nov 2014; Johann Schmitz <ercpe@gentoo.org>
+ +files/tomcat-7.0.56-build.xml.patch, +tomcat-7.0.56.ebuild:
+ Version bump to 7.0.56
*tomcat-6.0.41 (02 Nov 2014)
diff --git a/www-servers/tomcat/files/tomcat-7.0.56-build.xml.patch b/www-servers/tomcat/files/tomcat-7.0.56-build.xml.patch
new file mode 100644
index 000000000000..d97891832077
--- /dev/null
+++ b/www-servers/tomcat/files/tomcat-7.0.56-build.xml.patch
@@ -0,0 +1,126 @@
+diff --git a/apache-tomcat-7.0.56-src/build.xml b/apache-tomcat-7.0.56-src/build.xml
+index 166f45e..cb82a5f 100644
+--- a/apache-tomcat-7.0.56-src/build.xml
++++ b/apache-tomcat-7.0.56-src/build.xml
+@@ -686,7 +686,8 @@
+ filesId="files.annotations-api"
+ manifest="${tomcat.manifests}/annotations-api.jar.manifest" />
+
+- <!-- Servlet 3.0 Implementation JAR File -->
++<!--
++ Servlet 3.0 Implementation JAR File
+ <jarIt jarfile="${servlet-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.servlet-api"
+@@ -694,7 +695,7 @@
+ notice="${tomcat.manifests}/servlet-api.jar.notice"
+ license="${tomcat.manifests}/servlet-api.jar.license" />
+
+- <!-- JSP 2.2 Implementation JAR File -->
++ JSP 2.2 Implementation JAR File
+ <jarIt jarfile="${jsp-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.jsp-api"
+@@ -702,11 +703,12 @@
+ notice="${tomcat.manifests}/jsp-api.jar.notice"
+ license="${tomcat.manifests}/jsp-api.jar.license" />
+
+- <!-- JSP 2.2 EL Implementation JAR File -->
++ JSP 2.2 EL Implementation JAR File
+ <jarIt jarfile="${el-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.el-api"
+ manifest="${tomcat.manifests}/el-api.jar.manifest" />
++-->
+
+ <!-- Bootstrap JAR File -->
+ <jarIt jarfile="${bootstrap.jar}"
+@@ -801,16 +803,19 @@
+ <target name="package-java7" depends="compile,build-manifests"
+ if="java.7.home">
+ <!-- WebSocket 1.0 API JAR File -->
++<!--
+ <jarIt jarfile="${websocket-api.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.websocket-api"
+ manifest="${tomcat.manifests}/websocket-api.jar.manifest" />
+-
++-->
+ <!-- WebSocket 1.0 implementation JAR File -->
++<!--
+ <jarIt jarfile="${tomcat7-websocket.jar}"
+ filesDir="${tomcat.classes}"
+ filesId="files.tomcat7-websocket"
+ meta-inf="${tomcat.manifests}/tomcat7-websocket.jar"/>
++-->
+ </target>
+
+ <target name="build-docs" depends="compile-prepare" description="Builds all documentation from XML sources">
+@@ -952,13 +957,14 @@
+ <target name="deploy" depends="package,build-docs,compile-webapp-examples"
+ description="Default. Builds a working Tomcat instance">
+
++<!--
+ <copy tofile="${tomcat.build}/bin/tomcat-native.tar.gz"
+ file="${tomcat-native.tar.gz}" />
+ <copy tofile="${tomcat.build}/bin/commons-daemon-native.tar.gz"
+ file="${commons-daemon.native.src.tgz}" />
+
+ <copy tofile="${tomcat.build}/bin/commons-daemon.jar" file="${commons-daemon.jar}" />
+-
++-->
+ <!-- Copy scripts -->
+ <copy todir="${tomcat.build}/bin">
+ <fileset dir="bin">
+@@ -1011,9 +1017,11 @@
+ <!-- Add sources for examples -->
+ <antcall target="examples-sources" />
+
++<!--
+ <copy file="${tomcat-dbcp.jar}" todir="${tomcat.build}/lib"
+ failonerror="false"/>
+ <copy file="${jdt.jar}" todir="${tomcat.build}/lib" />
++-->
+
+ <!-- build the jdbc-pool jar and source jar-->
+ <echo message="Building Tomcat JDBC pool libraries"/>
+@@ -1606,7 +1614,8 @@
+
+ <target name="extras-webservices-prepare"
+ depends="extras-prepare"
+- description="Prepare to build web services extras package">
++ description="Prepare to build web services extras package"
++ unless="noget">
+
+ <antcall target="downloadfile">
+ <param name="sourcefile" value="${jaxrpc-lib.loc}"/>
+@@ -2651,7 +2660,8 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
+ </target>
+
+ <target name="download-compile"
+- description="Download (and build) components necessary to compile" >
++ description="Download (and build) components necessary to compile"
++ unless="noget">
+
+ <antcall target="downloadfile-2">
+ <param name="sourcefile.1" value="${tomcat-native.loc.1}"/>
+@@ -2708,7 +2718,8 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
+ </target>
+
+ <target name="download-test-compile"
+- description="Download additional components for the tests" >
++ description="Download additional components for the tests"
++ unless="noget">
+
+ <antcall target="downloadfile">
+ <param name="sourcefile" value="${junit.loc}"/>
+@@ -2736,7 +2747,8 @@ Apache Tomcat ${version} native binaries for Win64 AMD64/EMT64 platform.
+ </target>
+
+ <target name="download-dist"
+- description="Download additional components for a distribution" >
++ description="Download additional components for a distribution"
++ unless="noget">
+
+ <antcall target="downloadzip-2">
+ <param name="sourcefile.1" value="${tomcat-native.win.1}"/>
diff --git a/www-servers/tomcat/tomcat-7.0.56.ebuild b/www-servers/tomcat/tomcat-7.0.56.ebuild
new file mode 100644
index 000000000000..5e2335ab9de7
--- /dev/null
+++ b/www-servers/tomcat/tomcat-7.0.56.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.56.ebuild,v 1.1 2014/11/02 10:19:15 ercpe Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit eutils java-pkg-2 java-ant-2 prefix user
+
+MY_P="apache-${P}-src"
+
+DESCRIPTION="Tomcat Servlet-3.0/JSP-2.2 Container"
+HOMEPAGE="http://tomcat.apache.org/"
+SRC_URI="mirror://apache/${PN}/tomcat-7/v${PV}/src/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="7"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="extra-webapps"
+
+RESTRICT="test" # can we run them on a production system?
+
+ECJ_SLOT="4.4"
+SAPI_SLOT="3.0"
+
+COMMON_DEP="
+ dev-java/eclipse-ecj:${ECJ_SLOT}
+ ~dev-java/tomcat-servlet-api-${PV}
+ extra-webapps? ( dev-java/jakarta-jstl:0 )"
+RDEPEND="${COMMON_DEP}
+ !<dev-java/tomcat-native-1.1.24
+ >=virtual/jre-1.6"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.6
+ >=dev-java/ant-core-1.8.1:0
+ test? (
+ dev-java/ant-junit:0
+ dev-java/junit:4
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ enewgroup tomcat 265
+ enewuser tomcat 265 -1 /dev/null tomcat
+}
+
+java_prepare() {
+ find -name '*.jar' -exec rm -frv {} + || die
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+
+ # For use of catalina.sh in netbeans
+ sed -i -e "/^# ----- Execute The Requested Command/ a\
+ CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
+ bin/catalina.sh || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+EANT_BUILD_TARGET="deploy"
+EANT_GENTOO_CLASSPATH="tomcat-servlet-api-${SAPI_SLOT},eclipse-ecj-${ECJ_SLOT}"
+EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
+EANT_NEEDS_TOOLS="true"
+EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false -Djava.7.home=${JAVA_HOME}"
+
+# revision of the instance-manager script
+IM_REV="-r1"
+
+src_compile() {
+ EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
+ java-pkg-2_src_compile
+}
+
+EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit-4"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ local dest="/usr/share/${PN}-${SLOT}"
+
+ java-pkg_jarinto "${dest}"/bin
+ java-pkg_dojar output/build/bin/*.jar
+ exeinto "${dest}"/bin
+ doexe output/build/bin/*.sh
+
+ java-pkg_jarinto "${dest}"/lib
+ java-pkg_dojar output/build/lib/*.jar
+
+ # so we don't have to call java-config with --with-dependencies, which might
+ # bring in more jars then actually desired.
+ java-pkg_addcp "$(java-pkg_getjars eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT})"
+
+ dodoc RELEASE-NOTES RUNNING.txt
+ use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
+ use source && java-pkg_dosrc java/*
+
+ ### Webapps ###
+
+ insinto "${dest}"/webapps
+ doins -r output/build/webapps/{host-manager,manager,ROOT}
+ use extra-webapps && doins -r output/build/webapps/{docs,examples}
+
+ ### Config ###
+
+ # replace the default pw with a random one, see #92281
+ local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
+ sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
+
+ insinto "${dest}"
+ doins -r output/build/conf
+
+ ### rc ###
+
+ cp "${FILESDIR}"/tomcat{.conf,.init,-instance-manager${IM_REV}.bash} "${T}" || die
+ eprefixify "${T}"/tomcat{.conf,.init,-instance-manager${IM_REV}.bash}
+ sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,.init,-instance-manager${IM_REV}.bash} || die
+
+ insinto "${dest}"/gentoo
+ doins "${T}"/tomcat.conf
+ exeinto "${dest}"/gentoo
+ doexe "${T}"/tomcat.init
+ newexe "${T}"/tomcat-instance-manager${IM_REV}.bash tomcat-instance-manager.bash
+}
+
+pkg_postinst() {
+ elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
+ elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
+ elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
+
+ elog "To manage Tomcat instances, run:"
+ elog " ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
+
+ ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
+ ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
+
+# einfo "Please read http://www.gentoo.org/proj/en/java/tomcat6-guide.xml for more information."
+}