summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-11-20 09:05:35 +0000
committerThilo Bangert <bangert@gentoo.org>2009-11-20 09:05:35 +0000
commita7dce19e5e6a7eb919dfeb6a24d446f15b915ec0 (patch)
tree4041ede603e93cd363ba004746b90d443c5883bf /www-servers/varnish
parentMake udev happy. Fix installation of kvm_stat command, Bug #281031. (diff)
downloadgentoo-2-a7dce19e5e6a7eb919dfeb6a24d446f15b915ec0.tar.gz
gentoo-2-a7dce19e5e6a7eb919dfeb6a24d446f15b915ec0.tar.bz2
gentoo-2-a7dce19e5e6a7eb919dfeb6a24d446f15b915ec0.zip
version bump
(Portage version: 2.2_rc50/cvs/Linux i686)
Diffstat (limited to 'www-servers/varnish')
-rw-r--r--www-servers/varnish/ChangeLog7
-rw-r--r--www-servers/varnish/varnish-2.0.5.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/www-servers/varnish/ChangeLog b/www-servers/varnish/ChangeLog
index 414337effb44..6887f777d178 100644
--- a/www-servers/varnish/ChangeLog
+++ b/www-servers/varnish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/varnish
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.28 2009/10/07 13:10:34 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.29 2009/11/20 09:05:35 bangert Exp $
+
+*varnish-2.0.5 (20 Nov 2009)
+
+ 20 Nov 2009; Thilo Bangert <bangert@gentoo.org> +varnish-2.0.5.ebuild:
+ version bump
07 Oct 2009; Benedikt Böhm <hollow@gentoo.org> varnish-2.0.4-r1.ebuild:
stable on amd64
diff --git a/www-servers/varnish/varnish-2.0.5.ebuild b/www-servers/varnish/varnish-2.0.5.ebuild
new file mode 100644
index 000000000000..0c51bb40d939
--- /dev/null
+++ b/www-servers/varnish/varnish-2.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-2.0.5.ebuild,v 1.1 2009/11/20 09:05:35 bangert Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator."
+HOMEPAGE="http://varnish.projects.linpro.no/"
+SRC_URI="mirror://sourceforge/varnish/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+#varnish compiles stuff at run time
+RDEPEND="sys-devel/gcc"
+
+HTTP_HDR_MAX_VAL=${HTTP_HDR_MAX_VAL:-32}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.4-link-order.patch
+ epatch "${FILESDIR}"/${PN}-2.0.4-virtual-ncsa.patch
+ sed -e "s/#define HTTP_HDR_MAX_VAL .*/#define HTTP_HDR_MAX_VAL ${HTTP_HDR_MAX_VAL}/" \
+ -i bin/varnishd/cache.h
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/varnishd.initd varnishd || die
+ newconfd "${FILESDIR}"/varnishd.confd varnishd || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/varnishd.logrotate" varnishd
+
+ dodir /var/log/varnish
+}
+
+pkg_postinst () {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "please read the man-page for more info."
+ elog "A sample (localhost:8080 -> localhost:80) for gentoo is given in"
+ elog " /etc/conf.d/varnishd"
+ echo
+}