summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2010-10-21 20:31:50 +0000
committerThilo Bangert <bangert@gentoo.org>2010-10-21 20:31:50 +0000
commitdad7590c0788f9902c169600bf8e91164c50f6dc (patch)
tree29f4517e1a2bbdb20fade530a79dc0f6a76ad00c /www-servers/varnish
parentMarking xdg-user-dirs-gtk-0.8-r1 ~ppc for bug 337632 (diff)
downloadgentoo-2-dad7590c0788f9902c169600bf8e91164c50f6dc.tar.gz
gentoo-2-dad7590c0788f9902c169600bf8e91164c50f6dc.tar.bz2
gentoo-2-dad7590c0788f9902c169600bf8e91164c50f6dc.zip
version bump (#313377)
(Portage version: 2.2_rc98/cvs/Linux i686)
Diffstat (limited to 'www-servers/varnish')
-rw-r--r--www-servers/varnish/ChangeLog7
-rw-r--r--www-servers/varnish/varnish-2.1.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/www-servers/varnish/ChangeLog b/www-servers/varnish/ChangeLog
index 1672b21b0781..27a79d7a9043 100644
--- a/www-servers/varnish/ChangeLog
+++ b/www-servers/varnish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/varnish
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.31 2010/08/09 10:39:26 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.32 2010/10/21 20:31:50 bangert Exp $
+
+*varnish-2.1.3 (21 Oct 2010)
+
+ 21 Oct 2010; Thilo Bangert <bangert@gentoo.org> +varnish-2.1.3.ebuild:
+ version bump (#313377)
09 Aug 2010; Thilo Bangert <bangert@gentoo.org> -varnish-2.0.4.ebuild,
varnish-2.0.4-r1.ebuild, -varnish-2.0.5.ebuild, varnish-2.0.6.ebuild:
diff --git a/www-servers/varnish/varnish-2.1.3.ebuild b/www-servers/varnish/varnish-2.1.3.ebuild
new file mode 100644
index 000000000000..97efda6c3ad9
--- /dev/null
+++ b/www-servers/varnish/varnish-2.1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-2.1.3.ebuild,v 1.1 2010/10/21 20:31:50 bangert Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator."
+HOMEPAGE="http://www.varnish-cache.org/"
+SRC_URI="http://www.varnish-software.com/sites/default/files/${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+#varnish compiles stuff at run time
+RDEPEND="sys-devel/gcc"
+
+RESTRICT="test" #315725
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.4-virtual-ncsa.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}"/varnishd.initd varnishd || die
+ newconfd "${FILESDIR}"/varnishd.confd varnishd || die
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/varnishd.logrotate" varnishd
+
+ dodir /var/log/varnish
+}
+
+pkg_postinst () {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "please read the man-page for more info."
+ elog "A sample (localhost:8080 -> localhost:80) for gentoo is given in"
+ elog " /etc/conf.d/varnishd"
+ echo
+ ewarn "Varnish 2.1.x introduces VCL changes wrt. 2.0.x. See also"
+ ewarn "http://www.varnish-cache.org/docs/2.1/reference/vcl.html"
+}