summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2012-01-27 11:10:27 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2012-01-27 11:10:27 +0000
commit1f4815fca8c1582205b520c4f741d3403fdb3efa (patch)
treea697fbdf7ee8e2237271000c9874d2bd55312ec9 /www-servers
parentAdd 0.8 live branch ebuild. (diff)
downloadgentoo-2-1f4815fca8c1582205b520c4f741d3403fdb3efa.tar.gz
gentoo-2-1f4815fca8c1582205b520c4f741d3403fdb3efa.tar.bz2
gentoo-2-1f4815fca8c1582205b520c4f741d3403fdb3efa.zip
version bump, add reload functionnality to init script
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/uwsgi/ChangeLog10
-rw-r--r--www-servers/uwsgi/files/uwsgi-1.0.2.1-no-werror.patch11
-rw-r--r--www-servers/uwsgi/files/uwsgi.initd12
-rw-r--r--www-servers/uwsgi/uwsgi-1.0.2.1.ebuild72
4 files changed, 101 insertions, 4 deletions
diff --git a/www-servers/uwsgi/ChangeLog b/www-servers/uwsgi/ChangeLog
index 3ef793abac05..7a37c83ee32e 100644
--- a/www-servers/uwsgi/ChangeLog
+++ b/www-servers/uwsgi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/uwsgi
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/ChangeLog,v 1.8 2011/06/08 18:00:12 maksbotan Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/ChangeLog,v 1.9 2012/01/27 11:10:27 ultrabug Exp $
+
+*uwsgi-1.0.2.1 (27 Jan 2012)
+
+ 27 Jan 2012; Ultrabug <ultrabug@gentoo.org> +uwsgi-1.0.2.1.ebuild,
+ +files/uwsgi-1.0.2.1-no-werror.patch, files/uwsgi.initd:
+ Version bump, add reload functionnality to init script
*uwsgi-0.9.8 (08 Jun 2011)
diff --git a/www-servers/uwsgi/files/uwsgi-1.0.2.1-no-werror.patch b/www-servers/uwsgi/files/uwsgi-1.0.2.1-no-werror.patch
new file mode 100644
index 000000000000..9786186fe5e3
--- /dev/null
+++ b/www-servers/uwsgi/files/uwsgi-1.0.2.1-no-werror.patch
@@ -0,0 +1,11 @@
+--- a/uwsgiconfig.py 2012-01-11 19:38:58.000000000 +0100
++++ b/uwsgiconfig.py 2012-01-27 11:43:47.969407343 +0100
+@@ -252,7 +252,7 @@
+ self.gcc_list.append('proto/fastcgi')
+ self.include_path = []
+
+- self.cflags = ['-O2', '-Wall', '-Werror', '-D_LARGEFILE_SOURCE', '-D_FILE_OFFSET_BITS=64'] + os.environ.get("CFLAGS", "").split()
++ self.cflags = ['-O2', '-Wall', '-D_LARGEFILE_SOURCE', '-D_FILE_OFFSET_BITS=64'] + os.environ.get("CFLAGS", "").split()
+
+ if uwsgi_os == 'Linux':
+ self.gcc_list.append('lib/linux_ns')
diff --git a/www-servers/uwsgi/files/uwsgi.initd b/www-servers/uwsgi/files/uwsgi.initd
index 3fedecc64f63..3e6542e9f67c 100644
--- a/www-servers/uwsgi/files/uwsgi.initd
+++ b/www-servers/uwsgi/files/uwsgi.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/files/uwsgi.initd,v 1.1 2011/05/31 19:49:07 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/files/uwsgi.initd,v 1.2 2012/01/27 11:10:27 ultrabug Exp $
PROGNAME=${SVCNAME#*.}
@@ -9,6 +9,8 @@ UWSGI_EXEC=/usr/bin/uwsgi
PIDPATH=/var/run/uwsgi
PIDFILE="${PIDPATH}/${PROGNAME}.pid"
+extra_started_commands="reload"
+
depend() {
need net
}
@@ -94,6 +96,12 @@ start() {
eend $?
}
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ kill -HUP `cat ${PIDFILE}` &>/dev/null
+ eend $? "Failed to reload ${SVCNAME}"
+}
+
stop() {
ebegin "Stopping uWSGI application ${PROGNAME}"
start-stop-daemon --stop --pidfile "${PIDFILE}" --signal 3
diff --git a/www-servers/uwsgi/uwsgi-1.0.2.1.ebuild b/www-servers/uwsgi/uwsgi-1.0.2.1.ebuild
new file mode 100644
index 000000000000..635ae1ca52a6
--- /dev/null
+++ b/www-servers/uwsgi/uwsgi-1.0.2.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/uwsgi-1.0.2.1.ebuild,v 1.1 2012/01/27 11:10:27 ultrabug Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python toolchain-funcs apache-module
+
+DESCRIPTION="uWSGI server for Python web applications"
+HOMEPAGE="http://projects.unbit.it/uwsgi/"
+SRC_URI="http://projects.unbit.it/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2"
+DEPEND="${RDEPEND}"
+
+APXS2_S="${S}/apache2"
+APACHE2_MOD_CONF="42_mod_${PN}"
+want_apache2_2
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-werror.patch
+ python_copy_sources
+}
+
+src_compile() {
+ python_src_compile CC="$(tc-getCC)"
+
+ if use apache2 ; then
+ for m in Ruwsgi uwsgi ; do
+ APXS2_ARGS="-c mod_${m}.c"
+ apache-module_src_compile
+ done
+ fi
+}
+
+src_install() {
+ installation() {
+ newbin uwsgi uwsgi-${PYTHON_ABI}
+ }
+ python_execute_function -s installation
+
+ python_generate_wrapper_scripts "${ED}usr/bin/uwsgi"
+
+ if use apache2; then
+ for m in Ruwsgi uwsgi ; do
+ APACHE2_MOD_FILE="${APXS2_S}/.libs/mod_${m}.so"
+ apache-module_src_install
+ done
+ fi
+
+ newinitd "${FILESDIR}"/uwsgi.initd uwsgi
+ newconfd "${FILESDIR}"/uwsgi.confd uwsgi
+ mkdir -p "${ED}"/var/run/uwsgi
+}
+
+pkg_postinst() {
+ if use apache2 ; then
+ elog "Two Apache modules have been installed: mod_uwsgi and mod_Ruwsgi."
+ elog "You can enable them with -DUWSGI or -DRUWSGI in /etc/conf.d/apache2."
+ elog "Both have the same configuration interface and define the same symbols."
+ elog "Therefore you can enable only one of them at a time."
+ elog "mod_uwsgi is commercially supported by Unbit and stable but a bit hacky."
+ elog "mod_Ruwsgi is newer and more Apache-API friendly but not commercially supported."
+ fi
+}