summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-05-23 15:42:00 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-05-23 15:42:00 +0000
commit4d4fea6bac002967f1104da0dfc3976b99437f44 (patch)
tree498c09781dfd3946d24ce0526ca4a21c5f55e75e /www-servers
parentVersion bump (bug #417203). (diff)
downloadgentoo-2-4d4fea6bac002967f1104da0dfc3976b99437f44.tar.gz
gentoo-2-4d4fea6bac002967f1104da0dfc3976b99437f44.tar.bz2
gentoo-2-4d4fea6bac002967f1104da0dfc3976b99437f44.zip
Install man pages in the correct section
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/monkeyd/ChangeLog9
-rw-r--r--www-servers/monkeyd/files/monkeyd-fix-manpage-path.patch42
-rw-r--r--www-servers/monkeyd/monkeyd-0.33.0-r1.ebuild (renamed from www-servers/monkeyd/monkeyd-0.33.0.ebuild)6
3 files changed, 54 insertions, 3 deletions
diff --git a/www-servers/monkeyd/ChangeLog b/www-servers/monkeyd/ChangeLog
index eb6d3c8862d9..4a28b716acdc 100644
--- a/www-servers/monkeyd/ChangeLog
+++ b/www-servers/monkeyd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/monkeyd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.32 2012/03/24 11:44:36 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.33 2012/05/23 15:42:00 blueness Exp $
+
+*monkeyd-0.33.0-r1 (23 May 2012)
+
+ 23 May 2012; Anthony G. Basile <blueness@gentoo.org> -monkeyd-0.33.0.ebuild,
+ +monkeyd-0.33.0-r1.ebuild, +files/monkeyd-fix-manpage-path.patch:
+ Install man pages in the correct section
+ See: http://bugs.monkey-project.com/ticket/156
24 Mar 2012; Anthony G. Basile <blueness@gentoo.org> metadata.xml:
Adopt package
diff --git a/www-servers/monkeyd/files/monkeyd-fix-manpage-path.patch b/www-servers/monkeyd/files/monkeyd-fix-manpage-path.patch
new file mode 100644
index 000000000000..ecb20e720159
--- /dev/null
+++ b/www-servers/monkeyd/files/monkeyd-fix-manpage-path.patch
@@ -0,0 +1,42 @@
+From 4817136af00893fd46a2993d79c7aeb9fafaa119 Mon Sep 17 00:00:00 2001
+From: Anthony G. Basile <blueness@gentoo.org>
+Date: Wed, 23 May 2012 10:53:10 -0400
+Subject: [PATCH] configure: fix #156, install man pages to the correct sections
+
+The current configure script installs the man pages banana.1, monkey.1
+and monkey-api.3 at the top level man dir, /usr/share/man, and not in
+the appropriate categories by FHS standards. This fixes the issue.
+
+Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
+---
+ configure | 7 +++++--
+ 1 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/configure b/configure
+index ab02d30..d4e8956 100755
+--- a/configure
++++ b/configure
+@@ -347,7 +347,8 @@ distclean:
+ install:
+ \$(MAKE) -C src all
+ install -d \$(BINDIR)
+- install -d \$(MANDIR)
++ install -d \$(MANDIR)/man1
++ install -d \$(MANDIR)/man3
+ install -d \$(SYSCONFDIR)
+ install -d \${SYSCONFDIR}/sites
+ install -d \${SYSCONFDIR}/plugins
+@@ -362,7 +363,9 @@ install:
+ $plgconf
+ install -m 644 ./conf/sites/* \${SYSCONFDIR}/sites
+ $plglist
+- install -m 644 ./man/* \$(MANDIR)
++ install -m 644 ./man/banana.1 \$(MANDIR)/man1
++ install -m 644 ./man/monkey.1 \$(MANDIR)/man1
++ install -m 644 ./man/monkey-api.3 \$(MANDIR)/man3
+ install -m 644 ./htdocs/*.* \$(DATADIR)
+ install -m 644 ./htdocs/imgs/*.* \${DATADIR}/imgs
+ $STRIP \$(BINDIR)/monkey
+--
+1.7.3.4
+
diff --git a/www-servers/monkeyd/monkeyd-0.33.0.ebuild b/www-servers/monkeyd/monkeyd-0.33.0-r1.ebuild
index 2821ea543830..78b161f47d19 100644
--- a/www-servers/monkeyd/monkeyd-0.33.0.ebuild
+++ b/www-servers/monkeyd/monkeyd-0.33.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-0.33.0.ebuild,v 1.2 2012/03/18 18:00:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-0.33.0-r1.ebuild,v 1.1 2012/05/23 15:42:00 blueness Exp $
EAPI="4"
-inherit toolchain-funcs depend.php multilib
+inherit eutils toolchain-funcs depend.php multilib
WEBROOT=/var/www/localhost
@@ -27,6 +27,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}/${PN}-fix-manpage-path.patch"
+
# Don't install the banana script, it is broken as is anyway and the
# functionality is provided by the ${FILESDIR}/monkeyd.init.d script.
sed -i '/install -m 755 bin\/banana/d' configure || die "sed banana"