summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-03-08 14:42:54 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-03-08 14:42:54 +0000
commit86265eaf412b1769a9fe93e27019eebb5631bdb5 (patch)
tree15dfb3e9fea5cee81c0b0de134f5add9893a124a /www-servers
parentshiney new package, ebuild by me (diff)
downloadgentoo-2-86265eaf412b1769a9fe93e27019eebb5631bdb5.tar.gz
gentoo-2-86265eaf412b1769a9fe93e27019eebb5631bdb5.tar.bz2
gentoo-2-86265eaf412b1769a9fe93e27019eebb5631bdb5.zip
Revision bump; added static support via USE=static for bug 84485.
(Portage version: 2.0.51.19)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/thttpd/ChangeLog7
-rw-r--r--www-servers/thttpd/Manifest14
-rw-r--r--www-servers/thttpd/files/digest-thttpd-2.25b-r11
-rw-r--r--www-servers/thttpd/thttpd-2.25b-r1.ebuild52
4 files changed, 62 insertions, 12 deletions
diff --git a/www-servers/thttpd/ChangeLog b/www-servers/thttpd/ChangeLog
index 67e2dd75e691..f286998f2fed 100644
--- a/www-servers/thttpd/ChangeLog
+++ b/www-servers/thttpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/thttpd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/ChangeLog,v 1.4 2005/02/09 16:12:53 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/ChangeLog,v 1.5 2005/03/08 14:42:54 ka0ttic Exp $
+
+*thttpd-2.25b-r1 (08 Mar 2005)
+
+ 08 Mar 2005; Aaron Walker <ka0ttic@gentoo.org> +thttpd-2.25b-r1.ebuild:
+ Revision bump; added static support via USE=static for bug 84485.
*thttpd-2.25b (09 Feb 2005)
diff --git a/www-servers/thttpd/Manifest b/www-servers/thttpd/Manifest
index 127a605aedc7..4ebfe5a2b177 100644
--- a/www-servers/thttpd/Manifest
+++ b/www-servers/thttpd/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 53f962724891d65e45ce4ab2257421eb ChangeLog 1432
+MD5 c32b6f42dac03a19092322de33a21659 thttpd-2.25b-r1.ebuild 1231
+MD5 4ad5efddbb72bfd4b4e3cb1cb2d4c24a ChangeLog 1607
MD5 4a186842848d9c384e2d12785ba426bc metadata.xml 165
MD5 01cfdda0a52d777aa2c814dcf4ba9d95 thttpd-2.25b.ebuild 1188
+MD5 1e6cbba778f6846533ae1d69310e0c4e files/digest-thttpd-2.25b-r1 64
MD5 1e6cbba778f6846533ae1d69310e0c4e files/digest-thttpd-2.25b 64
MD5 84af2600ce2cfa9331871027accd00f5 files/thttpd-2.25/thttpd.confd 1152
MD5 98bfd7ed90b6a438a940413d5e541c29 files/thttpd-2.25/thttpd.init 828
MD5 1d3e759791468812bd3c6dd786428cac files/thttpd-2.25/thttpd.conf.sample 672
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD8DBQFCE1fEEZCkKN40op4RAvruAKC8lTiu86vlFxn6g9ZQW7TsgnanpwCgmuuc
-V79jTFXxi8hfzc3GJXHfVaw=
-=fKIa
------END PGP SIGNATURE-----
diff --git a/www-servers/thttpd/files/digest-thttpd-2.25b-r1 b/www-servers/thttpd/files/digest-thttpd-2.25b-r1
new file mode 100644
index 000000000000..823600acb15d
--- /dev/null
+++ b/www-servers/thttpd/files/digest-thttpd-2.25b-r1
@@ -0,0 +1 @@
+MD5 a0e9cd87455d3a0ea11e5ea7e947adf6 thttpd-2.25b.tar.gz 132363
diff --git a/www-servers/thttpd/thttpd-2.25b-r1.ebuild b/www-servers/thttpd/thttpd-2.25b-r1.ebuild
new file mode 100644
index 000000000000..f4bf5552116c
--- /dev/null
+++ b/www-servers/thttpd/thttpd-2.25b-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thttpd/thttpd-2.25b-r1.ebuild,v 1.1 2005/03/08 14:42:54 ka0ttic Exp $
+
+inherit flag-o-matic
+
+MY_P="${P%[a-z]*}"
+
+DESCRIPTION="Small and fast multiplexing webserver."
+HOMEPAGE="http://www.acme.com/software/thttpd/"
+SRC_URI="http://www.acme.com/software/thttpd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="static"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ ## TODO: what to do with IPv6?
+
+ append-ldflags -Wl,-z,now
+ use static && append-ldflags -static
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ dodir /usr/share/man/man1
+ make prefix=${D}/usr \
+ MANDIR=${D}/usr/share/man \
+ WEBGROUP=nogroup \
+ WEBDIR=${D}/var/www/localhost \
+ "$@" install || die "make install failed"
+
+ mv ${D}/usr/sbin/{,th_}htpasswd
+ mv ${D}/usr/share/man/man1/{,th_}htpasswd.1
+
+ newinitd ${FILESDIR}/${MY_P}/thttpd.init thttpd
+ newconfd ${FILESDIR}/${MY_P}/thttpd.confd thttpd
+
+ dodoc README INSTALL TODO
+
+ insinto /etc/thttpd
+ doins ${FILESDIR}/${MY_P}/thttpd.conf.sample
+}
+
+pkg_postinst() {
+ einfo "Adjust THTTPD_DOCROOT in /etc/conf.d/thttpd !"
+}