summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-07-26 08:24:17 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-07-26 08:24:17 +0000
commit8704ffd1e085c09f83f43889a8ecdfbb1cc670af (patch)
treef5af99aa2ac01cc769f4202262ee528c020c6bb3 /www-servers
parentUpdate (diff)
downloadgentoo-2-8704ffd1e085c09f83f43889a8ecdfbb1cc670af.tar.gz
gentoo-2-8704ffd1e085c09f83f43889a8ecdfbb1cc670af.tar.bz2
gentoo-2-8704ffd1e085c09f83f43889a8ecdfbb1cc670af.zip
* bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest2
-rw-r--r--www-servers/nginx/files/digest-nginx-0.1.411
-rw-r--r--www-servers/nginx/nginx-0.1.41.ebuild68
4 files changed, 77 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 0a1b39557d5c..98275dc48a59 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.35 2005/07/22 15:39:20 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.36 2005/07/26 08:24:17 voxus Exp $
+
+*nginx-0.1.41 (26 Jul 2005)
+
+ 26 Jul 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.1.41.ebuild:
+ Version bump.
*nginx-0.1.40 (22 Jul 2005)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index 3aec5fd51487..aef49d573436 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -1,4 +1,5 @@
MD5 4d709334244203f40e373b840fc93315 nginx-0.1.38.ebuild 1824
+MD5 348a4e843d8b7c319f6294e37031afa4 nginx-0.1.41.ebuild 1900
MD5 98db90f9a2bfa831d161546966272c78 nginx-0.1.37.ebuild 1822
MD5 a4845998e1ff711794ec93349eb25484 nginx-0.1.39.ebuild 1900
MD5 814f3c9a10958da40b0df3f043329ecf ChangeLog 6293
@@ -8,5 +9,6 @@ MD5 23dc869263233b746e0a92df932c1d77 files/digest-nginx-0.1.37 64
MD5 08b4fee07b21ac422ba46360d47971f5 files/digest-nginx-0.1.38 64
MD5 777f6009404998ee19def5cf7f35834b files/digest-nginx-0.1.39 64
MD5 97d4ddf24f616dabd0a2f1b3a7068952 files/digest-nginx-0.1.40 64
+MD5 d726deb4444f111650634a938adba396 files/digest-nginx-0.1.41 64
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
MD5 fecedd05099122b1f8169152e5bc9462 files/nginx.conf 1400
diff --git a/www-servers/nginx/files/digest-nginx-0.1.41 b/www-servers/nginx/files/digest-nginx-0.1.41
new file mode 100644
index 000000000000..ee2089b31db4
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.1.41
@@ -0,0 +1 @@
+MD5 475ae6d06dd61dc93fdcaf1069d7db21 nginx-0.1.41.tar.gz 315507
diff --git a/www-servers/nginx/nginx-0.1.41.ebuild b/www-servers/nginx/nginx-0.1.41.ebuild
new file mode 100644
index 000000000000..f4ae26725882
--- /dev/null
+++ b/www-servers/nginx/nginx-0.1.41.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.41.ebuild,v 1.1 2005/07/26 08:24:17 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || myconf="${myconf} --without-pcre"
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}