summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-31 08:30:59 +0000
committerMike Frysinger <vapier@gentoo.org>2014-01-31 08:30:59 +0000
commitd774d4e4a371b72916fd34d7e282f67e0c18d4c0 (patch)
tree741dfbcae294fc8f619bcb0b350cd0b68e1c8c82 /www-servers
parentfix pcre-config/pkg-config/apr/apr-util handling when cross-compiling by leve... (diff)
downloadgentoo-2-d774d4e4a371b72916fd34d7e282f67e0c18d4c0.tar.gz
gentoo-2-d774d4e4a371b72916fd34d7e282f67e0c18d4c0.tar.bz2
gentoo-2-d774d4e4a371b72916fd34d7e282f67e0c18d4c0.zip
Add workaround for gen_test_char behavior when cross-compiling #385783 by Bertrand Jacquin.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/apache/ChangeLog6
-rw-r--r--www-servers/apache/apache-2.4.7.ebuild16
2 files changed, 20 insertions, 2 deletions
diff --git a/www-servers/apache/ChangeLog b/www-servers/apache/ChangeLog
index 811794cc3d6a..a4786c32071a 100644
--- a/www-servers/apache/ChangeLog
+++ b/www-servers/apache/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/apache
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.254 2014/01/24 03:39:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/ChangeLog,v 1.255 2014/01/31 08:30:59 vapier Exp $
+
+ 31 Jan 2014; Mike Frysinger <vapier@gentoo.org> apache-2.4.7.ebuild:
+ Add workaround for gen_test_char behavior when cross-compiling #385783 by
+ Bertrand Jacquin.
24 Jan 2014; Mike Frysinger <vapier@gentoo.org> apache-2.2.24.ebuild,
apache-2.2.25.ebuild, apache-2.2.26.ebuild, apache-2.4.6-r1.ebuild,
diff --git a/www-servers/apache/apache-2.4.7.ebuild b/www-servers/apache/apache-2.4.7.ebuild
index 8f4f09d33db6..4813c4c9fa4b 100644
--- a/www-servers/apache/apache-2.4.7.ebuild
+++ b/www-servers/apache/apache-2.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.4.7.ebuild,v 1.4 2014/01/24 03:39:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/apache/apache-2.4.7.ebuild,v 1.5 2014/01/31 08:30:59 vapier Exp $
EAPI=5
@@ -157,6 +157,20 @@ src_configure() {
apache-2_src_configure
}
+src_compile() {
+ if tc-is-cross-compiler; then
+ # This header is the same across targets, so use the build compiler.
+ pushd server >/dev/null
+ emake gen_test_char
+ tc-export_build_env BUILD_CC
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${BUILD_LDFLAGS} \
+ gen_test_char.c -o gen_test_char $(apr-1-config --includes) || die
+ popd >/dev/null
+ fi
+
+ default
+}
+
src_install() {
apache-2_src_install
for i in /usr/bin/{htdigest,logresolve,htpasswd,htdbm,ab,httxt2dbm}; do