summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-07 16:55:35 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-07 16:55:35 +0000
commitea24d9f15ed5815e286ca11a023158be464a6392 (patch)
tree637dae730503df444d59ea8f83698f583c423892 /www-servers
parentNew package, bug 445298. Ebuild by Matthew Reaume and Charles Nerot (diff)
downloadgentoo-2-ea24d9f15ed5815e286ca11a023158be464a6392.tar.gz
gentoo-2-ea24d9f15ed5815e286ca11a023158be464a6392.tar.bz2
gentoo-2-ea24d9f15ed5815e286ca11a023158be464a6392.zip
Version bump. The new version fixes issues with broken connections causing program termination.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pshs/ChangeLog8
-rw-r--r--www-servers/pshs/pshs-0.2.4.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/www-servers/pshs/ChangeLog b/www-servers/pshs/ChangeLog
index 7c70814ff400..cc725a6cf8e1 100644
--- a/www-servers/pshs/ChangeLog
+++ b/www-servers/pshs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/pshs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.10 2014/12/05 15:05:31 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/ChangeLog,v 1.11 2014/12/07 16:55:35 mgorny Exp $
+
+*pshs-0.2.4 (07 Dec 2014)
+
+ 07 Dec 2014; Michał Górny <mgorny@gentoo.org> +pshs-0.2.4.ebuild:
+ Version bump. The new version fixes issues with broken connections causing
+ program termination.
05 Dec 2014; Michał Górny <mgorny@gentoo.org> -pshs-0.2.2.ebuild:
Remove the broken version.
diff --git a/www-servers/pshs/pshs-0.2.4.ebuild b/www-servers/pshs/pshs-0.2.4.ebuild
new file mode 100644
index 000000000000..c363a977f8b1
--- /dev/null
+++ b/www-servers/pshs/pshs-0.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pshs/pshs-0.2.4.ebuild,v 1.1 2014/12/07 16:55:35 mgorny Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Pretty small HTTP server - a command-line tool to share files"
+HOMEPAGE="https://bitbucket.org/mgorny/pshs/"
+SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+magic +netlink qrcode upnp"
+
+RDEPEND=">=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ upnp? ( net-libs/miniupnpc:0= )"
+DEPEND="${RDEPEND}
+ netlink? ( sys-apps/iproute2
+ >=sys-kernel/linux-headers-2.6.27 )"
+# libnetlink is static only ATM
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable magic libmagic)
+ $(use_enable netlink)
+ $(use_enable qrcode qrencode)
+ $(use_enable upnp)
+ )
+
+ autotools-utils_src_configure
+}