summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-24 21:23:30 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-24 21:23:30 +0000
commit2db68af471ebdfa2be61e634b357c2694e1a30d8 (patch)
treebeaa6596845fc5ea637cf37fe7f40483a40049dd /x11-apps/ccsm
parentfix python eclass use, bug #207667 (diff)
downloadgentoo-2-2db68af471ebdfa2be61e634b357c2694e1a30d8.tar.gz
gentoo-2-2db68af471ebdfa2be61e634b357c2694e1a30d8.tar.bz2
gentoo-2-2db68af471ebdfa2be61e634b357c2694e1a30d8.zip
use distutils eclass, fix python eclass use, bug #207667
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-apps/ccsm')
-rw-r--r--x11-apps/ccsm/ChangeLog7
-rw-r--r--x11-apps/ccsm/ccsm-0.6.0.ebuild13
2 files changed, 12 insertions, 8 deletions
diff --git a/x11-apps/ccsm/ChangeLog b/x11-apps/ccsm/ChangeLog
index acb262ed26b0..e987ca18bd50 100644
--- a/x11-apps/ccsm/ChangeLog
+++ b/x11-apps/ccsm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-apps/ccsm
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/ccsm/ChangeLog,v 1.3 2007/10/25 14:17:43 tester Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/ccsm/ChangeLog,v 1.4 2008/02/24 21:23:30 eva Exp $
+
+ 24 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org> ccsm-0.6.0.ebuild:
+ use distutils eclass, fix python eclass use, bug #207667
25 Oct 2007; Olivier Crête <tester@gentoo.org> ccsm-0.6.0.ebuild:
Marked ~amd64
diff --git a/x11-apps/ccsm/ccsm-0.6.0.ebuild b/x11-apps/ccsm/ccsm-0.6.0.ebuild
index 583a7347333a..9fd1144bfdbe 100644
--- a/x11-apps/ccsm/ccsm-0.6.0.ebuild
+++ b/x11-apps/ccsm/ccsm-0.6.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/ccsm/ccsm-0.6.0.ebuild,v 1.3 2007/10/25 14:17:43 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/ccsm/ccsm-0.6.0.ebuild,v 1.4 2008/02/24 21:23:30 eva Exp $
+
+inherit distutils
DESCRIPTION="Compizconfig Settings Manager"
HOMEPAGE="http://compiz-fusion.org"
@@ -14,13 +16,12 @@ IUSE=""
DEPEND="dev-python/compizconfig-python
>=dev-python/pygtk-2.10"
-S="${WORKDIR}/${P}"
+DOCS="AUTHORS PKG-INFO"
src_compile() {
- ./setup.py build --prefix=/usr || die "build failed"
+ distutils_src_compile --prefix=/usr
}
src_install() {
- ./setup.py install --root="${D}" --prefix=/usr || die "install failed"
- dodoc AUTHORS PKG-INFO || die "dodoc failed"
+ distutils_src_install --prefix=/usr
}