summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-05-07 15:37:10 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-05-07 15:37:10 +0000
commit5b778db3417aa4ad21a2dd23286e538306953f2c (patch)
treed97955c4c18cd3de475da75d12270a7179a4dbf5 /x11-apps/simple-ccsm
parentVersion bump. Remove old which no longer work. (diff)
downloadgentoo-2-5b778db3417aa4ad21a2dd23286e538306953f2c.tar.gz
gentoo-2-5b778db3417aa4ad21a2dd23286e538306953f2c.tar.bz2
gentoo-2-5b778db3417aa4ad21a2dd23286e538306953f2c.zip
Revision bump: migrate to distutils-r1
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'x11-apps/simple-ccsm')
-rw-r--r--x11-apps/simple-ccsm/ChangeLog9
-rw-r--r--x11-apps/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/x11-apps/simple-ccsm/ChangeLog b/x11-apps/simple-ccsm/ChangeLog
index 232020d22ce0..727644f23501 100644
--- a/x11-apps/simple-ccsm/ChangeLog
+++ b/x11-apps/simple-ccsm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/simple-ccsm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/ChangeLog,v 1.15 2012/08/31 11:36:52 pinkbyte Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/ChangeLog,v 1.16 2013/05/07 15:37:10 pinkbyte Exp $
+
+*simple-ccsm-0.8.4-r2 (07 May 2013)
+
+ 07 May 2013; Sergey Popov <pinkbyte@gentoo.org> +simple-ccsm-0.8.4-r2.ebuild:
+ Revision bump: migrate to distutils-r1
31 Aug 2012; Sergey Popov <pinkbyte@gentoo.org> metadata.xml:
Remove myself and proxy maintainer from maintainers
diff --git a/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild b/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild
new file mode 100644
index 000000000000..6e1fd81d47b8
--- /dev/null
+++ b/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/simple-ccsm/simple-ccsm-0.8.4-r2.ebuild,v 1.1 2013/05/07 15:37:10 pinkbyte Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_{6,7} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="Simplified Compizconfig Settings Manager"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+RDEPEND="
+ >=dev-python/compizconfig-python-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}]
+ >=x11-apps/ccsm-${PV}[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # return error if wrong arguments passed to setup.py
+ sed -i -e 's/raise SystemExit/\0(1)/' setup.py || die 'sed on setup.py failed'
+ # fix desktop file
+ sed -i \
+ -e '/Categories/s/Compiz/X-\0/' \
+ -e '/Encoding/d' \
+ "${PN}".desktop.in || die "sed on ${PN}.desktop.in failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ mydistutilsargs=( build --prefix=/usr )
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}