summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-08 06:28:13 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-08 06:28:13 +0000
commit57fb94ba97fd17987ae03bea4bd04417b795d84b (patch)
tree9bfd00b09ca8ce22f5f0c789638e86d6e99bbc25 /x11-apps/xedit
parentversion bump (diff)
downloadgentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.tar.gz
gentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.tar.bz2
gentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.zip
Initial commit for modular X.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-apps/xedit')
-rw-r--r--x11-apps/xedit/ChangeLog9
-rw-r--r--x11-apps/xedit/Manifest2
-rw-r--r--x11-apps/xedit/files/digest-xedit-0.99.01
-rw-r--r--x11-apps/xedit/xedit-0.99.0.ebuild23
4 files changed, 35 insertions, 0 deletions
diff --git a/x11-apps/xedit/ChangeLog b/x11-apps/xedit/ChangeLog
new file mode 100644
index 000000000000..de6f85eae38b
--- /dev/null
+++ b/x11-apps/xedit/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-apps/xedit
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/ChangeLog,v 1.1 2005/08/08 06:28:11 spyderous Exp $
+
+*xedit-0.99.0 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; +xedit-0.99.0.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-apps/xedit/Manifest b/x11-apps/xedit/Manifest
new file mode 100644
index 000000000000..f5347a82e436
--- /dev/null
+++ b/x11-apps/xedit/Manifest
@@ -0,0 +1,2 @@
+MD5 25b8deb37d3c632db52398397c37fe2c xedit-0.99.0.ebuild 528
+MD5 215aa7769c436bb259b3b28bb49af9ea files/digest-xedit-0.99.0 65
diff --git a/x11-apps/xedit/files/digest-xedit-0.99.0 b/x11-apps/xedit/files/digest-xedit-0.99.0
new file mode 100644
index 000000000000..8ef2994f83c1
--- /dev/null
+++ b/x11-apps/xedit/files/digest-xedit-0.99.0
@@ -0,0 +1 @@
+MD5 c673117da2e3ccb2809c59701a4e7c46 xedit-0.99.0.tar.bz2 318965
diff --git a/x11-apps/xedit/xedit-0.99.0.ebuild b/x11-apps/xedit/xedit-0.99.0.ebuild
new file mode 100644
index 000000000000..d7088e7c56a2
--- /dev/null
+++ b/x11-apps/xedit/xedit-0.99.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/xedit-0.99.0.ebuild,v 1.1 2005/08/08 06:28:11 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xedit application"
+KEYWORDS="~x86"
+IUSE="xprint"
+RDEPEND="xprint? ( x11-libs/libXprintUtil )
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}