summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-11-14 14:18:45 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-11-14 14:18:45 +0000
commit03cba3a189fe7013c1b7c2bc280bebc522285d8d (patch)
tree75050321ce7f311ea08c53e78bdb630d68a67598 /x11-apps/xinit
parentFix alignment bug that causes out of memory aborts at PDF export. Bug #287701. (diff)
downloadgentoo-2-03cba3a189fe7013c1b7c2bc280bebc522285d8d.tar.gz
gentoo-2-03cba3a189fe7013c1b7c2bc280bebc522285d8d.tar.bz2
gentoo-2-03cba3a189fe7013c1b7c2bc280bebc522285d8d.zip
Version bump. Drop old.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps/xinit')
-rw-r--r--x11-apps/xinit/ChangeLog11
-rw-r--r--x11-apps/xinit/files/00-xhost7
-rw-r--r--x11-apps/xinit/files/0001-Gentoo-specific-customizations.patch61
-rw-r--r--x11-apps/xinit/files/chooser.sh15
-rw-r--r--x11-apps/xinit/files/xdm-setup.initd-12
-rw-r--r--x11-apps/xinit/files/xdm.confd-224
-rw-r--r--x11-apps/xinit/files/xdm.initd-4245
-rw-r--r--x11-apps/xinit/files/xserverrc1
-rw-r--r--x11-apps/xinit/xinit-1.0.8-r4.ebuild68
-rw-r--r--x11-apps/xinit/xinit-1.0.8-r8.ebuild80
-rw-r--r--x11-apps/xinit/xinit-1.2.0.ebuild (renamed from x11-apps/xinit/xinit-1.0.8-r7.ebuild)37
11 files changed, 365 insertions, 186 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 79f31337553c..51bc180e8acf 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.162 2009/10/18 14:14:53 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.163 2009/11/14 14:18:45 scarabeus Exp $
+
+*xinit-1.2.0 (14 Nov 2009)
+
+ 14 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org> +files/00-xhost,
+ files/xdm-setup.initd-1, -xinit-1.0.8-r4.ebuild, -xinit-1.0.8-r7.ebuild,
+ -xinit-1.0.8-r8.ebuild, +xinit-1.2.0.ebuild, +files/xdm.confd-2,
+ +files/0001-Gentoo-specific-customizations.patch, +files/xdm.initd-4,
+ files/chooser.sh, +files/xserverrc:
+ Version bump. Drop old.
18 Oct 2009; Brent Baude <ranger@gentoo.org> xinit-1.0.8-r10.ebuild:
Marking xinit-1.0.8-r10 ppc64 for bug 287913
diff --git a/x11-apps/xinit/files/00-xhost b/x11-apps/xinit/files/00-xhost
new file mode 100644
index 000000000000..82cf10381e68
--- /dev/null
+++ b/x11-apps/xinit/files/00-xhost
@@ -0,0 +1,7 @@
+#!/bin/sh
+# Allow all local connections from the current UID
+# This fixes issues with hostname changes (usually by dhcp clients)
+# see bug 287498 for more info
+
+[ -x /usr/bin/xhost ] && [ -x /usr/bin/id ] &&
+ xhost +si:localuser:`id -un` > /dev/null 2>&1
diff --git a/x11-apps/xinit/files/0001-Gentoo-specific-customizations.patch b/x11-apps/xinit/files/0001-Gentoo-specific-customizations.patch
new file mode 100644
index 000000000000..a54272a08348
--- /dev/null
+++ b/x11-apps/xinit/files/0001-Gentoo-specific-customizations.patch
@@ -0,0 +1,61 @@
+From fdeff43b7550a63643a1cec743e0f8b838e65af5 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Cardona?= <remi@gentoo.org>
+Date: Thu, 5 Nov 2009 20:46:56 +0100
+Subject: [PATCH] Gentoo-specific customizations
+
+---
+ xinitrc.cpp | 28 ++++++++++++++++------------
+ 1 files changed, 16 insertions(+), 12 deletions(-)
+
+diff --git a/xinitrc.cpp b/xinitrc.cpp
+index 379b1f3..f7f8784 100644
+--- a/xinitrc.cpp
++++ b/xinitrc.cpp
+@@ -2,8 +2,8 @@ XCOMM!SHELL_CMD
+
+ userresources=$HOME/.Xresources
+ usermodmap=$HOME/.Xmodmap
+-sysresources=XINITDIR/.Xresources
+-sysmodmap=XINITDIR/.Xmodmap
++sysresources=XINITDIR/Xresources
++sysmodmap=XINITDIR/Xmodmap
+
+ XCOMM merge in defaults and keymaps
+
+@@ -84,19 +84,23 @@ fi
+ XCOMM This is the fallback case if nothing else is executed above
+ #endif /* !defined(__SCO__) && !defined(__UNIXWARE__) */
+
+-#ifdef __APPLE__
++if [ -n "`/etc/X11/chooser.sh`" ]; then
++ command="`/etc/X11/chooser.sh`"
++else
++ command="XTERM -geometry 80x66+0+0 -name login"
++ failsafe="yes"
++fi
+
+ if [ -d XINITDIR/xinitrc.d ] ; then
+- for f in XINITDIR/xinitrc.dXSLASHGLOB.sh ; do
++ for f in XINITDIR/xinitrc.dXSLASHGLOB ; do
+ [ -x "$f" ] && . "$f"
+ done
+ unset f
+ fi
+-
+-#endif
+-
+-TWM &
+-XCLOCK -geometry 50x50-1+1 &
+-XTERM -geometry 80x50+494+51 &
+-XTERM -geometry 80x20+494-0 &
+-exec XTERM -geometry 80x66+0+0 -name login
++if [ $failsafe = "yes" ]; then
++ TWM &
++ XCLOCK -geometry 50x50-1+1 &
++ XTERM -geometry 80x50+494+51 &
++ XTERM -geometry 80x20+494-0 &
++fi
++exec $command
+--
+1.6.5.2
+
diff --git a/x11-apps/xinit/files/chooser.sh b/x11-apps/xinit/files/chooser.sh
index b22153608afd..f24be46dc46d 100644
--- a/x11-apps/xinit/files/chooser.sh
+++ b/x11-apps/xinit/files/chooser.sh
@@ -2,22 +2,13 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2
# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/chooser.sh,v 1.4 2006/09/05 23:22:13 dberkholz Exp $
-
-# If $XSESSION is "", source first /etc/conf.d/basic, and then /etc/rc.conf
-if [ -z "${XSESSION}" ]
-then
- [ -f /etc/conf.d/basic ] && . /etc/conf.d/basic
- [ -f /etc/rc.conf ] && . /etc/rc.conf
-fi
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/chooser.sh,v 1.5 2009/11/14 14:18:43 scarabeus Exp $
# Find a match for $XSESSION in /etc/X11/Sessions
GENTOO_SESSION=""
-for x in /etc/X11/Sessions/*
-do
+for x in /etc/X11/Sessions/* ; do
if [ "`echo ${x##*/} | awk '{ print toupper($1) }'`" \
- = "`echo ${XSESSION} | awk '{ print toupper($1) }'`" ]
- then
+ = "`echo ${XSESSION} | awk '{ print toupper($1) }'`" ]; then
GENTOO_SESSION=${x}
break
fi
diff --git a/x11-apps/xinit/files/xdm-setup.initd-1 b/x11-apps/xinit/files/xdm-setup.initd-1
index 1a4074e671fb..047bbd59c239 100644
--- a/x11-apps/xinit/files/xdm-setup.initd-1
+++ b/x11-apps/xinit/files/xdm-setup.initd-1
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/xdm-setup.initd-1,v 1.6 2009/10/06 16:44:38 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/xdm-setup.initd-1,v 1.7 2009/11/14 14:18:43 scarabeus Exp $
depend() {
need localmount
diff --git a/x11-apps/xinit/files/xdm.confd-2 b/x11-apps/xinit/files/xdm.confd-2
new file mode 100644
index 000000000000..1ca9517ccce8
--- /dev/null
+++ b/x11-apps/xinit/files/xdm.confd-2
@@ -0,0 +1,24 @@
+# We always try and start X on a static VT. The various DMs normally default
+# to using VT7. If you wish to use the xdm init script, then you should ensure
+# that the VT checked is the same VT your DM wants to use. We do this check to
+# ensure that you haven't accidentally configured something to run on the VT
+# in your /etc/inittab file so that you don't get a dead keyboard.
+CHECKVT=7
+
+# What display manager do you use ? [ xdm | gdm | kdm | kdm-4.3 | gpe | entrance ]
+# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
+#
+# KDE-specific note:
+# - If you are using kdeprefix go with "kdm-4.Y", e.g. "kdm-4.3".
+# You can find possible versions by looking at the directories in /usr/kde/.
+# - Else, if you are using KDE 3 enter "kdm-3.5"
+# - Else, if you are using KDE 4 enter "kdm" without a version
+DISPLAYMANAGER="xdm"
+
+# Set whether xorg should depend on hald or not. If set to 'auto' then the init
+# script tries to determine the dependency on hald automatically, by examining
+# xorg.conf files on various locations. If you have built xorg without hal
+# use-flag, you should set 'no' here. If xorg has been built with hal then you
+# may set 'auto' or 'yes' here.
+# Possible values are: [ yes | no | auto ]
+NEEDS_HALD="auto"
diff --git a/x11-apps/xinit/files/xdm.initd-4 b/x11-apps/xinit/files/xdm.initd-4
new file mode 100644
index 000000000000..5e4afca770f9
--- /dev/null
+++ b/x11-apps/xinit/files/xdm.initd-4
@@ -0,0 +1,245 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/xdm.initd-4,v 1.1 2009/11/14 14:18:43 scarabeus Exp $
+
+# This is here to serve as a note to myself, and future developers.
+#
+# Any Display manager (gdm,kdm,xdm) has the following problem: if
+# it is started before any getty, and no vt is specified, it will
+# usually run on vt2. When the getty on vt2 then starts, and the
+# DM is already started, the getty will take control of the keyboard,
+# leaving us with a "dead" keyboard.
+#
+# Resolution: add the following line to /etc/inittab
+#
+# x:a:once:/etc/X11/startDM.sh
+#
+# and have /etc/X11/startDM.sh start the DM in daemon mode if
+# a lock is present (with the info of what DM should be started),
+# else just fall through.
+#
+# How this basically works, is the "a" runlevel is a additional
+# runlevel that you can use to fork processes with init, but the
+# runlevel never gets changed to this runlevel. Along with the "a"
+# runlevel, the "once" key word means that startDM.sh will only be
+# run when we specify it to run, thus eliminating respawning
+# startDM.sh when "xdm" is not added to the default runlevel, as was
+# done previously.
+#
+# This script then just calls "telinit a", and init will run
+# /etc/X11/startDM.sh after the current runlevel completes (this
+# script should only be added to the actual runlevel the user is
+# using).
+#
+# Martin Schlemmer
+# aka Azarah
+# 04 March 2002
+
+
+hald_depend() {
+ if [ "${NEEDS_HALD}" = "yes" ]; then
+ need hald
+ elif [ "${NEEDS_HALD}" = "no" ]; then
+ use hald
+ else
+ local found=0
+ # search paths according to xorg.conf man page
+ for xorgconf in "${XORGCONFIG}" "/etc/X11/${XORGCONFIG}" \
+ /etc/X11/xorg.conf{-4,} /etc/xorg.conf \
+ "/usr/etc/X11/xorg.conf.$(hostname)" \
+ /usr/etc/X11/xorg.conf{-4,} \
+ "/usr/lib/X11/xorg.conf.$(hostname)" \
+ /usr/lib/X11/xorg.conf{-4,}
+ do
+ if [ -f "${xorgconf}" ]; then
+ # we found the config file
+ found=1
+
+ # check if AutoAddDevices has been disabled
+ if grep -Eiq '^[[:blank:]]*Option[[:blank:]]+"AutoAddDevices"[[:blank:]]+"(0|off|false|no)"' "${xorgconf}"; then
+ # there might be another ServerLayout section which requires hald
+ use hald
+ else
+ need hald
+ fi
+
+ # baselayout-2 only
+ [ ! -n "${RC_UNAME}" ] && config "${xorgconf}"
+
+ # process only the first existing file in the search list
+ break
+ fi
+ done
+
+ # if no configuration file was found, we must depend
+ # on hald for automatic discovery of input devices
+ [ ${found} -eq 0 ] && need hald
+ fi
+}
+
+depend() {
+ need localmount xdm-setup
+
+ # this should start as early as possible
+ # we can't do 'before *' as that breaks it
+ # (#139824) Start after ypbind and autofs for network authentication
+ # (#145219 #180163) Could use lirc mouse as input device
+ # (#70689 comment #92) Start after consolefont to avoid display corruption
+ # (#291269) Start after quota, since some dm need readable home
+ after bootmisc consolefont modules netmount
+ after readahead-list ypbind autofs openvpn gpm lircmd
+ after quota
+ before alsasound
+
+ # Start before X
+ use acpid consolekit xfs
+
+ hald_depend
+}
+
+setup_dm() {
+ local MY_XDM="$(echo "${DISPLAYMANAGER}" | tr '[:upper:]' '[:lower:]')"
+
+ # Load our root path from profile.env
+ # Needed for kdm
+ PATH="${PATH}:$(. /etc/profile.env; echo "${ROOTPATH}")"
+
+ case "${MY_XDM}" in
+ kdm|kde)
+ EXE="$(which kdm)"
+ PIDFILE=/var/run/kdm.pid
+ ;;
+ kdm-*)
+ EXE="/usr/kde/${MY_XDM#kdm-}/bin/kdm"
+ PIDFILE=/var/run/kdm.pid
+ ;;
+ entrance*)
+ EXE=/usr/sbin/entranced
+ PIDFILE=/var/lib/entranced.pid
+ ;;
+ gdm|gnome)
+ EXE=/usr/bin/gdm
+ [ "${RC_UNAME}" != "Linux" ] && NAME=gdm-binary
+ PIDFILE=/var/run/gdm.pid
+ ;;
+ wdm)
+ EXE=/usr/bin/wdm
+ PIDFILE=
+ ;;
+ gpe)
+ EXE=/usr/bin/gpe-dm
+ PIDFILE=/var/run/gpe-dm.pid
+ ;;
+ *)
+ EXE=
+ # Fix #65586, where MY_XDM is empty so EXE=somedir
+ [ -x "/usr/bin/${MY_XDM}" ] && [ -f "/usr/bin/${MY_XDM}" ] \
+ && EXE="/usr/bin/${MY_XDM}"
+ if [ -z "${EXE}" ] ; then
+ EXE=/usr/bin/xdm
+ PIDFILE=/var/run/xdm.pid
+ fi
+ ;;
+ esac
+
+ if ! [ -x "${EXE}" ] ; then
+ EXE=/usr/bin/xdm
+ PIDFILE=/var/run/xdm.pid
+ if ! [ -x "/usr/bin/xdm" ] ; then
+ echo "ERROR: Please set your DISPLAYMANAGER variable in /etc/conf.d/xdm,"
+ echo " or install x11-apps/xdm package"
+ eend 255
+ fi
+ fi
+}
+
+# Check to see if something is defined on our VT
+vtstatic() {
+ if [ -e /etc/inittab ] ; then
+ grep -Eq "^[^#]+.*\<tty$1\>" /etc/inittab
+ elif [ -e /etc/ttys ] ; then
+ grep -q "^ttyv$(($1 - 1))" /etc/ttys
+ else
+ return 1
+ fi
+}
+
+start() {
+ local EXE= NAME= PIDFILE=
+ setup_dm
+
+ if [ -f /etc/.noxdm ] ; then
+ einfo "Skipping ${EXE}, /etc/.noxdm found"
+ rm /etc/.noxdm
+ return 0
+ fi
+
+ ebegin "Setting up ${EXE##*/}"
+
+ # save the prefered DM
+ save_options "service" "${EXE}"
+ save_options "name" "${NAME}"
+ save_options "pidfile" "${PIDFILE}"
+
+ if [ -n "${CHECKVT-y}" ] ; then
+ if vtstatic "${CHECKVT:-7}" ; then
+ if [ -x /sbin/telinit ] && [ "${SOFTLEVEL}" != "BOOT" ] && [ "${RC_SOFTLEVEL}" != "BOOT" ] ; then
+ ewarn "Something is already defined on VT ${CHECKVT:-7}, will start X later"
+ telinit a >/dev/null 2>/dev/null
+ return 0
+ else
+ eerror "Something is already defined on VT ${CHECKVT:-7}, not starting"
+ return 1
+ fi
+ fi
+ fi
+
+ /etc/X11/startDM.sh
+ eend 0
+}
+
+stop() {
+ local retval=0
+ local curvt=
+ if [ -t 0 ] ; then
+ if type fgconsole >/dev/null 2>/dev/null ; then
+ curvt="$(fgconsole 2>/dev/null)"
+ else
+ curvt="$(tty)"
+ case "${curvt}" in
+ /dev/ttyv[0-9]*) curvt="${curvt#/dev/ttyv*}" ;;
+ *) curvt= ;;
+ esac
+ fi
+ fi
+ local myexe="$(get_options "service")"
+ local myname="$(get_options "name")"
+ local mypidfile="$(get_options "pidfile")"
+ local myservice=${myexe##*/}
+
+ [ -z "${myexe}" ] && return 0
+
+ ebegin "Stopping ${myservice}"
+
+ if start-stop-daemon --quiet --test --stop --exec "${myexe}" ; then
+ start-stop-daemon --stop --exec "${myexe}" --retry TERM/5/TERM/5 \
+ ${mypidfile:+--pidfile} ${mypidfile} \
+ ${myname:+--name} ${myname}
+ retval=$?
+ fi
+
+ # switch back to original vt
+ if [ -n "${curvt}" ] ; then
+ if type chvt >/dev/null 2>/dev/null ; then
+ chvt "${curvt}"
+ else
+ vidcontrol -s "$((${curvt} + 1))"
+ fi
+ fi
+
+ eend ${retval} "Error stopping ${myservice}"
+ return ${retval}
+}
+
+# vim: set ts=4 :
diff --git a/x11-apps/xinit/files/xserverrc b/x11-apps/xinit/files/xserverrc
new file mode 100644
index 000000000000..6a636c119060
--- /dev/null
+++ b/x11-apps/xinit/files/xserverrc
@@ -0,0 +1 @@
+exec /usr/bin/X -nolisten tcp
diff --git a/x11-apps/xinit/xinit-1.0.8-r4.ebuild b/x11-apps/xinit/xinit-1.0.8-r4.ebuild
deleted file mode 100644
index 18c4644a98b0..000000000000
--- a/x11-apps/xinit/xinit-1.0.8-r4.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.8-r4.ebuild,v 1.13 2009/08/28 14:29:46 betelgeuse Exp $
-
-EAPI="2"
-
-# Must be before x-modular eclass is inherited
-# This is enabled due to modified Makefile.am from the patches
-SNAPSHOT="yes"
-
-inherit x-modular pam
-
-DESCRIPTION="X Window System initializer"
-
-LICENSE="${LICENSE} GPL-2"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="hal minimal pam"
-
-RDEPEND="x11-apps/xauth
- x11-libs/libX11
- hal? ( sys-auth/consolekit sys-apps/dbus[X] )"
-DEPEND="${RDEPEND}"
-PDEPEND="!minimal? ( x11-wm/twm
- x11-apps/xclock
- x11-apps/xrdb
- x11-apps/xsm
- x11-terms/xterm )"
-
-PATCHES=( "${FILESDIR}"/nolisten-tcp-and-black-background.patch
- "${FILESDIR}"/gentoo-startx-customization-1.0.8.patch
- "${FILESDIR}"/xinit-1.0.4-console-kit.patch )
-
-pkg_setup() {
- CONFIGURE_OPTIONS="$(use_with hal consolekit)"
-}
-
-src_prepare() {
- x-modular_patch_source
-
- sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" "${S}/Makefile.am"
-
- x-modular_reconf_source
-}
-
-src_install() {
- x-modular_src_install
- exeinto /etc/X11
- doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh || die
- exeinto /etc/X11/Sessions
- doexe "${FILESDIR}"/Xsession || die
- exeinto /etc/X11/xinit
- doexe "${FILESDIR}"/xinitrc || die
- newinitd "${FILESDIR}"/xdm.initd-2 xdm
- newconfd "${FILESDIR}"/xdm.confd-1 xdm
- newpamd "${FILESDIR}"/xserver.pamd xserver
-}
-
-pkg_postinst() {
- x-modular_pkg_postinst
- ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
- ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
- ewarn "any executable. When you run startx, it will run this as the login session."
- ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
- ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
- ewarn "Here's an example of setting it for the whole system:"
- ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
- ewarn " env-update && source /etc/profile"
-}
diff --git a/x11-apps/xinit/xinit-1.0.8-r8.ebuild b/x11-apps/xinit/xinit-1.0.8-r8.ebuild
deleted file mode 100644
index 9a4188dc2ebc..000000000000
--- a/x11-apps/xinit/xinit-1.0.8-r8.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.8-r8.ebuild,v 1.9 2009/10/06 20:42:58 williamh Exp $
-
-EAPI="2"
-
-# Must be before x-modular eclass is inherited
-# This is enabled due to modified Makefile.am from the patches
-SNAPSHOT="yes"
-
-inherit x-modular pam
-
-DESCRIPTION="X Window System initializer"
-
-LICENSE="${LICENSE} GPL-2"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="consolekit minimal pam"
-
-RDEPEND="
- x11-apps/xauth
- x11-libs/libX11
- consolekit? (
- sys-auth/consolekit
- sys-apps/dbus[X]
- )
-"
-DEPEND="${RDEPEND}"
-PDEPEND="!minimal? (
- x11-apps/xclock
- x11-apps/xrdb
- x11-apps/xsm
- x11-terms/xterm
- x11-wm/twm
- )
-"
-
-PATCHES=( "${FILESDIR}"/nolisten-tcp-and-black-background.patch
- "${FILESDIR}"/gentoo-startx-customization-1.0.8.patch
- "${FILESDIR}"/xinit-1.0.4-console-kit.patch )
-
-pkg_setup() {
- CONFIGURE_OPTIONS="$(use_with consolekit)"
-}
-
-src_prepare() {
- x-modular_patch_source
-
- sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" "${S}/Makefile.am"
-
- x-modular_reconf_source
-}
-
-src_install() {
- x-modular_src_install
- exeinto /etc/X11
- doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh || die
- exeinto /etc/X11/Sessions
- doexe "${FILESDIR}"/Xsession || die
- exeinto /etc/X11/xinit
- doexe "${FILESDIR}"/xinitrc || die
- newinitd "${FILESDIR}"/xdm.initd-3 xdm
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newconfd "${FILESDIR}"/xdm.confd-1 xdm
- newpamd "${FILESDIR}"/xserver.pamd xserver
-}
-
-pkg_postinst() {
- x-modular_pkg_postinst
- ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
- ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
- ewarn "any executable. When you run startx, it will run this as the login session."
- ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
- ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
- ewarn "Here's an example of setting it for the whole system:"
- ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
- ewarn " env-update && source /etc/profile"
- ewarn
- ewarn "If you use the nox boot option to prevent x from starting on boot,"
- ewarn "you should now use gentoo=nox."
-}
diff --git a/x11-apps/xinit/xinit-1.0.8-r7.ebuild b/x11-apps/xinit/xinit-1.2.0.ebuild
index ed15fb330f26..74247580db36 100644
--- a/x11-apps/xinit/xinit-1.0.8-r7.ebuild
+++ b/x11-apps/xinit/xinit-1.2.0.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.8-r7.ebuild,v 1.4 2009/09/21 07:53:47 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.2.0.ebuild,v 1.1 2009/11/14 14:18:45 scarabeus Exp $
EAPI="2"
# Must be before x-modular eclass is inherited
-# This is enabled due to modified Makefile.am from the patches
SNAPSHOT="yes"
inherit x-modular pam
@@ -14,16 +13,11 @@ DESCRIPTION="X Window System initializer"
LICENSE="${LICENSE} GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="consolekit hal minimal pam"
+IUSE="+minimal pam"
RDEPEND="
x11-apps/xauth
x11-libs/libX11
- hal? ( sys-apps/hal sys-apps/dbus[X] )
- consolekit? (
- sys-auth/consolekit
- hal? ( sys-apps/hal[consolekit] )
- )
"
DEPEND="${RDEPEND}"
PDEPEND="!minimal? (
@@ -35,20 +29,12 @@ PDEPEND="!minimal? (
)
"
-PATCHES=( "${FILESDIR}"/nolisten-tcp-and-black-background.patch
- "${FILESDIR}"/gentoo-startx-customization-1.0.8.patch
- "${FILESDIR}"/xinit-1.0.4-console-kit.patch )
+PATCHES=(
+ "${FILESDIR}/0001-Gentoo-specific-customizations.patch"
+)
pkg_setup() {
- CONFIGURE_OPTIONS="$(use_with consolekit)"
-}
-
-src_prepare() {
- x-modular_patch_source
-
- sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" "${S}/Makefile.am"
-
- x-modular_reconf_source
+ CONFIGURE_OPTIONS="--with-xinitdir=/etc/X11/xinit"
}
src_install() {
@@ -58,11 +44,14 @@ src_install() {
exeinto /etc/X11/Sessions
doexe "${FILESDIR}"/Xsession || die
exeinto /etc/X11/xinit
- doexe "${FILESDIR}"/xinitrc || die
- newinitd "${FILESDIR}"/xdm.initd-3 xdm
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newconfd "${FILESDIR}"/xdm.confd-1 xdm
+ doexe "${FILESDIR}"/xserverrc || die
+ newinitd "${FILESDIR}"/xdm.initd-4 xdm || die
+ newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup || die
+ newconfd "${FILESDIR}"/xdm.confd-2 xdm || die
newpamd "${FILESDIR}"/xserver.pamd xserver
+ dodir /etc/X11/xinit/xinitrc.d
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}/00-xhost"
}
pkg_postinst() {