summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-08 06:28:13 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-08 06:28:13 +0000
commit57fb94ba97fd17987ae03bea4bd04417b795d84b (patch)
tree9bfd00b09ca8ce22f5f0c789638e86d6e99bbc25 /x11-apps/xmh
parentversion bump (diff)
downloadgentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.tar.gz
gentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.tar.bz2
gentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.zip
Initial commit for modular X.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-apps/xmh')
-rw-r--r--x11-apps/xmh/ChangeLog9
-rw-r--r--x11-apps/xmh/Manifest2
-rw-r--r--x11-apps/xmh/files/digest-xmh-0.99.01
-rw-r--r--x11-apps/xmh/xmh-0.99.0.ebuild22
4 files changed, 34 insertions, 0 deletions
diff --git a/x11-apps/xmh/ChangeLog b/x11-apps/xmh/ChangeLog
new file mode 100644
index 000000000000..a91d8f52a35b
--- /dev/null
+++ b/x11-apps/xmh/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-apps/xmh
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xmh/ChangeLog,v 1.1 2005/08/08 06:28:12 spyderous Exp $
+
+*xmh-0.99.0 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; +xmh-0.99.0.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-apps/xmh/Manifest b/x11-apps/xmh/Manifest
new file mode 100644
index 000000000000..0554f2bd57b8
--- /dev/null
+++ b/x11-apps/xmh/Manifest
@@ -0,0 +1,2 @@
+MD5 d2922d213de65ba955a67387c661171a xmh-0.99.0.ebuild 490
+MD5 0953cac6dfffe62579c7df1d441fbe39 files/digest-xmh-0.99.0 63
diff --git a/x11-apps/xmh/files/digest-xmh-0.99.0 b/x11-apps/xmh/files/digest-xmh-0.99.0
new file mode 100644
index 000000000000..c0f961ab35a1
--- /dev/null
+++ b/x11-apps/xmh/files/digest-xmh-0.99.0
@@ -0,0 +1 @@
+MD5 161faf9cfb9cca5fa044fd835ab96c11 xmh-0.99.0.tar.bz2 128826
diff --git a/x11-apps/xmh/xmh-0.99.0.ebuild b/x11-apps/xmh/xmh-0.99.0.ebuild
new file mode 100644
index 000000000000..67eff278a7f4
--- /dev/null
+++ b/x11-apps/xmh/xmh-0.99.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xmh/xmh-0.99.0.ebuild,v 1.1 2005/08/08 06:28:12 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xmh application"
+KEYWORDS="~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXaw"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}