summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2009-06-20 10:22:24 +0000
committerRémi Cardona <remi@gentoo.org>2009-06-20 10:22:24 +0000
commit736800fe3b3be9adb93823226c03aa1389f8ab6e (patch)
tree30b86e844b3513876a0151171b2f944f42e34c9a /x11-apps
parentVersion bump. (diff)
downloadgentoo-2-736800fe3b3be9adb93823226c03aa1389f8ab6e.tar.gz
gentoo-2-736800fe3b3be9adb93823226c03aa1389f8ab6e.tar.bz2
gentoo-2-736800fe3b3be9adb93823226c03aa1389f8ab6e.zip
x11-apps/xfs: bump to 1.1.0
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xfs/ChangeLog7
-rw-r--r--x11-apps/xfs/xfs-1.1.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-apps/xfs/ChangeLog b/x11-apps/xfs/ChangeLog
index 8c0ca425e7c3..43a3846d157a 100644
--- a/x11-apps/xfs/ChangeLog
+++ b/x11-apps/xfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/xfs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/ChangeLog,v 1.61 2009/06/20 10:08:54 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/ChangeLog,v 1.62 2009/06/20 10:22:24 remi Exp $
+
+*xfs-1.1.0 (20 Jun 2009)
+
+ 20 Jun 2009; Rémi Cardona <remi@gentoo.org> +xfs-1.1.0.ebuild:
+ bump to 1.1.0
20 Jun 2009; Rémi Cardona <remi@gentoo.org> -xfs-1.0.6.ebuild:
drop old ebuilds
diff --git a/x11-apps/xfs/xfs-1.1.0.ebuild b/x11-apps/xfs/xfs-1.1.0.ebuild
new file mode 100644
index 000000000000..d36a5289befa
--- /dev/null
+++ b/x11-apps/xfs/xfs-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xfs/xfs-1.1.0.ebuild,v 1.1 2009/06/20 10:22:24 remi Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X font server"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+RDEPEND="x11-apps/ttmkfdir
+ x11-libs/libFS
+ x11-libs/libXfont"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6) --libdir=/etc"
+ enewgroup xfs 33
+ enewuser xfs 33 -1 /etc/X11/fs xfs
+}
+
+src_install() {
+ x-modular_src_install
+
+ insinto /etc/X11/fs
+ newins "${FILESDIR}"/xfs.config config
+ newinitd "${FILESDIR}"/xfs.start xfs
+ newconfd "${FILESDIR}"/xfs.conf.d xfs
+}