summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-12-04 18:07:49 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-12-04 18:07:49 +0000
commit0a51d9715e6d211befa246ec422e4e7cc7079c15 (patch)
tree0ab9dcc8933946048c85dcc4a2778cfe57204edf /x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild
parentversion bump, Thomas Beierlein as maintainer, bug #249714 (diff)
downloadgentoo-2-0a51d9715e6d211befa246ec422e4e7cc7079c15.tar.gz
gentoo-2-0a51d9715e6d211befa246ec422e4e7cc7079c15.tar.bz2
gentoo-2-0a51d9715e6d211befa246ec422e4e7cc7079c15.zip
minor 64 bit fix in this version
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild')
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild
new file mode 100644
index 000000000000..d7a2ded681c9
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.8.ebuild,v 1.1 2008/12/04 18:07:49 cardoe Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="hal"
+RDEPEND=">=x11-base/xorg-server-1.4.0.90
+ hal? ( >=sys-apps/hal-0.5.10 )"
+DEPEND="${RDEPEND}
+ || ( >=sys-kernel/linux-headers-2.6 >=sys-kernel/mips-headers-2.6 )
+ >=x11-proto/inputproto-1.4
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ pkg_info
+}
+
+pkg_info() {
+ if use hal; then
+ elog "If your XKB (keyboard settings) stopped working,"
+ elog "you may uninstall this driver or move your XKB configuration."
+ elog "Download an example from http://dev.gentoo.org/~compnerd/temp/hal-config-examples/"
+ elog "(these will be installed with sys-apps/hal soon),"
+ elog "and drop it into /etc/hal/fdi/policy/"
+ fi
+}